当前位置:→ 公式网 > 飞狐公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是狐版洗盘结束五星黄金柱指标有源码(无源码的请下载附件导入)

INPUT:M1(5,1,999),M2(35,1,999),M3(135,1,999);
黄金柱:=V/REF(V,1)>=2.0;
K1:=SUMBARS(黄金柱,1) ;
K2:=SUMBARS(黄金柱,2);
K3:=SUMBARS(黄金柱,3);
K4:=SUMBARS(黄金柱,4);
K5:=SUMBARS(黄金柱,5);
K6:=SUMBARS(黄金柱,6);
K7:=SUMBARS(黄金柱,7);
K8:=SUMBARS(黄金柱,8);
K9:=SUMBARS(黄金柱,9);
K10:=SUMBARS(黄金柱,10);
STICKLINE(K1,REF(L,K1-1)*1.002,REF(L,K1-1),10,0),COLORYELLOW;
AA:K1,COLORYELLOW,LINETHICK; 
{预定黄金柱}
{预定黄金柱:=REF(V,2)>=REF(V,3)*1.99 AND REF(C,2)>REF(O,2) 
AND REF(V,2)=HHV(V,3) AND C/REF(C,2) >=1.0995 AND REF(L,2)=LLV(L,3);}
{预定:STICKLINE(预定黄金柱,H,H,30,0),COLORRED;}
{DRAWICON(预定黄金柱,H,19);}
{将军柱中的五星上将黄金柱}
T60:=V=HHV(V,60);
T100:=V=HHV(V,100);
T2:=V/REF(VOL,1)>=3;
T3:=REF(C,1)/REF( O,1)<3;
五星上将:=(T60 AND T2 AND T3) OR (T100 AND T2 AND T3);
DRAWICON(五星上将,H,23);
{量柱图}
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,8,0),COLORWHITE;
STICKLINE(涨停,H,L,0,0),COLORWHITE;
DRAWICON(涨停,L-0.2,11);
DRAWTEXT(涨停,L-0.2,' --涨停');
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,8,0),COLORBLUE;
STICKLINE(跌停,H,L,0,1),COLORBLUE;
DRAWICON(跌停,H+0.2,2);
DRAWTEXT(跌停,H+0.2,' --跌停');
{大阳线:=IF((C-C2)*100/C2>=5,1,0) AND IF((C-C2)*100/C2<(10-0.01*100/C2),1,0) OR IF((C-O)*100/O>=5,1,0) AND IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阳线,OPEN,CLOSE,-1,0),COLORRED;
STICKLINE(大阳线,H,L,0,1),COLORRED;
大阴线:=IF((C2-C)*100/C2>=5,1,0) AND IF((C2-C)*100/C2<(10-0.01*100/C2),1,0) OR IF((O-C)*100/O>=5,1,0) AND IF((C2-C)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;
STICKLINE(大阴线,H,L,0,1),COLORGREEN;}
{MA13:MA(CLOSE,13),COLORWHITE;
MA34:MA(CLOSE,34),COLORYELLOW;
MA55:MA(CLOSE,55),COLOR9933FF;}
{MA4:MA(CLOSE,4),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLOR9933FF;
MA30:MA(CLOSE,30),COLORLIBLUE;
MA60:MA(CLOSE,60),COLORWHITE;
MA120:MA(CLOSE,120),COLORLIGREEN;}
TY:=C;
AA1:=REF(TY,10)=HHV(TY,2*10+1); BB1:=FILTER(AA1,10); C1:=BACKSET(BB1,10+1); HD:=FILTER(C1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(AA2,10); CC2:=BACKSET(B2,10+1); LD:=FILTER(CC2,10);
前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT,LINETHICK3;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT,LINETHICK3;
{求位置坐标}
PHD:=IF(LLV(L,3)>=REF(H,3),REF(H,3),
IF((LLV(L,3)>=REF(C,3) AND REF(C,3)>REF(O,3)),REF(C,3),
IF(LLV(L,3)>=REF(O,3) AND REF(C,3)>REF(O,3),REF(O,3),REF(L,3))));
{自动画量能评台}
{NN 1 300 21}
{NN:=21;
TTJ:=BARSLAST(REF(倍量黄金柱,NN-1));
K0:=TTJ=0;
K1:=SUMBARS(K0,1);
K2:=SUMBARS(K0,2);
K3:=SUMBARS(K0,3);
K4:=SUMBARS(K0,4);
K5:=SUMBARS(K0,5);
K6:=SUMBARS(K0,6);
K7:=SUMBARS(K0,7);
K8:=SUMBARS(K0,8);
K9:=SUMBARS(K0,9);
K10:=SUMBARS(K0,10);
CCCC1:=REF(C,K1-1);}
{在K线图上标示量柱类型}
DRAWICON((VOL>REF(V,1)*2.0 OR VOL=REF(V,1)*2.0) AND C>REF(C,1),H+0.2,26);
倍量:=(VOL>REF(V,1)*2.0 OR VOL=REF(V,1)*2.0) AND C>REF(C,1);
DRAWICON(VOL<REF(LLV(VOL,13),1),H+0.1,2);
低量:=VOL<REF(LLV(VOL,13),1);
DRAWICON(VOL<REF(LLV(VOL,100),1),H+0.1,12);
地量:=VOL<REF(LLV(VOL,100),1);
DRAWICON(ABS(VOL-HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.03 OR ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.03,H+0.1,16);
平量:=ABS(VOL-HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.03 OR ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.03;
DRAWICON(VOL<=REF(V,1)*0.5,H+0.1,27);
倍缩:=VOL<=REF(V,1)*0.5;
{画量柱标识:}
{1.画倍量黄金柱标识--红箭头图标}
DRAWICON((LLV(L,3)>REF(L,3) OR LLV(L,3)=REF(L,3)) AND HHV(V,3)<REF(V,3) AND 
REF(C,3)>REF(O,3) AND REF(V,3)>=2*REF(V,4),H+0.2,1);
倍量黄金柱:=(LLV(L,3)>REF(L,3) OR LLV(L,3)=REF(L,3)) AND HHV(V,3)<REF(V,3) AND 
REF(C,3)>REF(O,3) AND REF(V,3)>=2*REF(V,4);
{2.画梯量黄金柱标识--橘子图标}
DRAWICON(LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND 
REF(V,5)>REF(V,6) AND REF(V,4)>REF(V,5) AND REF(V,3)>REF(V,4),H,17);
梯量黄金柱:=LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND 
REF(V,5)>REF(V,6) AND REF(V,4)>REF(V,5) AND REF(V,3)>REF(V,4);
{3.画平量黄金柱标识--苹果图标}
DRAWICON(LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND 
REF(C,3)>REF(O,3) AND ABS(REF(V,3)-REF(V,4))/REF(V,4)<=0.03,H,19);
平量黄金柱:=LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND 
REF(C,3)>REF(O,3) AND ABS(REF(V,3)-REF(V,4))/REF(V,4)<=0.03;
{4.画立桩量标识--顶部红箭头图标}
N:=25;
立桩量:=REF(V,3)/REF(MA(V,5),4)>(N/10) AND 
REF(V,3)/REF(HHV(V,60),4)>1.5 AND LLV(L,3)>REF(L,3);
STICKLINE(倍量,OPEN,CLOSE,8,0),COLORYELLOW;
STICKLINE(倍量黄金柱,PHD,PHD,60,0),COLORWHITE;
倍量黄金线:倍量黄金柱,COLORWHITE,LINETHICK;
DRAWICON(倍量黄金柱,PHD*1.008,12);
DRAWTEXT(倍量黄金柱,PHD*1.010,' 标准黄金柱精准线'),COLORFF00FF;
DRAWTEXT(倍量黄金柱,PHD,'================='),COLORWHITE;
{平量黄金线:STICKLINE(平量黄金柱,PHD*1.002,PHD,100,0),COLORYELLOW;
DRAWTEXT(平量黄金柱,PHD*1.015,'平量黄金线'),COLORLIGREEN ;
梯量黄金线:STICKLINE(梯量黄金柱,PHD*1.002,PHD,100,0),COLORYELLOW;
DRAWTEXT(梯量黄金柱,PHD*1.015,'梯量黄金线'),COLORFF00FF ;}
DRAWICON(立桩量,H*1.002,1);
立桩量标识:立桩量,LINETHICK;
DRAWTEXT(立桩量,H*1.06,'立'),COLORRED;
DRAWTEXT(立桩量,H*1.04,'桩'),COLORRED;
DRAWTEXT(立桩量,H*1.02,'量'),COLORRED;
{DA:STICKLINE(K4<=30,REF(C,K4-1)*1.002,REF(C,K4-1),10,0),COLORBLUE;
EA:STICKLINE(K5<=30,REF(C,K5-1)*1.002,REF(C,K5-1),10,0),COLORBLUE;
FA:STICKLINE(K6<=30,REF(C,K6-1)*1.002,REF(C,K6-1),10,0),COLORBLUE;
GA:STICKLINE(K7<=30,REF(C,K7-1)*1.002,REF(C,K7-1),10,0),COLORBLUE;
HA:STICKLINE(K8<=30,REF(C,K8-1)*1.002,REF(C,K8-1),10,0),COLORBLUE;
IA:STICKLINE(K9<=30,REF(C,K9-1)*1.002,REF(C,K9-1),10,0),COLORBLUE;
JA:STICKLINE(K10<=30,REF(C,K10-1)*1.002,REF(C,K10-1),10,0),COLORBLUE; }
AAA:=REFX(HHV(H,90),DATACOUNT-BARPOS);
TS1:=0+0.03;
TS2:=TS1+0.03;
TS3:=TS2+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS1),'<一>.量柱的阶段性拐点标志--空间转化原则:'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS2),' 1.评台起柱:在K线整理评台上突然起柱;'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS3),' 2.凹口起柱:在K线逐步回调形成凹口时起柱.常见凹口倍量;'),COLORFF00FF ;
TS4:=TS3+0.03;
TS5:=TS4+0.03;
TS6:=TS5+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS4),' 3.过顶起柱:过左峰起柱.常见过顶倍量;'),COLORFF00FF;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS5),' 4.触底起柱:触前期谷底起柱.常见触底倍量.'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS6),'<二>.量柱的集合定性--组合量柱:'),COLORFF00FF ;
TS7:=TS6+0.03;
TS8:=TS7+0.03;
TS9:=TS8+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS7),' 1.低量柱+倍量柱:后市必大涨!'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS8),' 2.倍量柱+倍量柱:主庄控盘良好,急于拉升!'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS9),' 3.缩倍柱+倍量柱:机会就在眼前!'),COLORFF00FF ;

 
{============================}
BBB:=REFX(HHV(H,190),DATACOUNT-BARPOS);
TT1:=0+0.03;
TT2:=TT1+0.03;
TT3:=TT2+0.03;
DRAWTE

 


上一篇:没有了    下一篇:飞狐准确率很高的指标公式源码

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识