股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2012/6/8 6:34:59

飞狐个股盈亏副图公式

飞狐个股盈亏副图公式

初来咋到,没有积分很不方便,如果觉得有用请慷慨解囊,谢了!
公式的作用就是让你随时了解自己持仓股票的盈亏明细,你可以把他放在任何副图指标上,也可以放在主图上,随你喜欢

个股盈亏

参数:佣金 0.5  0.1  5

DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  : EMA(DIFF,9);
MACD : 2*(DIFF-DEA), COLORSTICK;
EXPLAIN(1, STRMID(STKLABEL,1,6)),LINETHICK;

进价:=SELFDATA('持仓股');
股数:=SELFDATA('持仓量');
买入价:进价,LINETHICK,COLORFFFFFF;
保本价:进价*(1.001+佣金*2/1000)+0.001,LINETHICK,COLOR00FF00;//默认佣金:万分之五  调整到自己的实际佣金 
盈亏:(DYNAINFO( 7)-保本价)*股数,LINETHICK,COLORFFFF;//保本价=进价*(印花税+佣金*2/1000)+0.001(过户费 可不计入)
每股盈亏:(DYNAINFO( 7)-保本价),LINETHICK,COLORFFFFFF;

A:=BARPOS; B:=DATACOUNT; A2:=SYSPARAM(2); A3:=SYSPARAM(3); HM:=A3-A2;
HQ:=HHV(HIGH,HM);{公式在线提供:www.gszx.com.cn}
LQ:=LLV(LOW,HM);
ZH:=HQ[B];
ZL:=LQ[B];
Q:=(ZH-ZL)/10;
MM:=HM/100;
DW:=A=A3-ROUND(MM*95);
DRAWTEXT(DW, 0.15 ,'买入价'+NUMTOSTR(进价,2)+'  持仓量'+NUMTOSTR(股数,0)),COLORFFFFFF,ALIGN1;
DRAWTEXT(DW, -0.15 ,'保本价'+NUMTOSTR(保本价,2)+'  总盈亏'+NUMTOSTR(盈亏,2)),COLORFFFFFF,ALIGN5;

飞狐个股盈亏副图公式



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网