股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2012/5/15 0:11:44

飞狐逃顶主图:凤冠霞帔

飞狐逃顶主图:凤冠霞帔

主图:凤冠霞帔

DRAWGBK(1,colorrgb(0,0,100),colorrgb(0,0,0),1);
DRAWBKBMP(BARPOS=SYSPARAM(1) and c>ref(c,1),'牛月');{自用背景图}

{---------立体K线-------------------------}
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color070084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color0000A3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color0000B7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color0000CD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color0000E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color0754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color076fF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color079BF3;

STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color0726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color0726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100;
{-----------------------------------------------}

{公式在线提供:www.gszx.com.cn}
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
HY1:=REF(EMA(V1,3),1);
APP:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
ZL:=IF((CLOSE > OPEN),(APP * (HIGH - LOW)),IF((CLOSE < OPEN),(APP * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
SF:=IF((CLOSE > OPEN),(0 - (APP * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (APP * (HIGH - LOW))),(0 - (VOL / 2))));
线性:=((((((CLOSE * 5) + (REF(CLOSE,1) * 4)) + (REF(CLOSE,2) * 3)) + (REF(CLOSE,3) * 2)) + (REF(CLOSE,4) * 1)) / ((((5 + 4) + 3) + 2) + 1));
决策:HY1,LINETHICK;
黄色线涨:pARTLINE((CLOSE > HY1),HY1),LINETHICK2,color00CCFF;//黄色
青色线跌:pARTLINE((CLOSE <= HY1),HY1),LINETHICK2,colorCCFF00;//青色


{---------------以下关注多线粘合与分开------------------}
m1:=hy1;
M2:EMA(M1,2),COLOR8FAAEE,LINEDOT;
M3:EMA(M2,4),COLORAD88CC,LINEDOT;
M4:EMA(M3,4),COLORCC66BB,LINEDOT;
M5:EMA(M4,4),COLOREA4499,LINEDOT;
M6:EMA(M5,4),COLORF83377,LINEDOT;


{M1S:PARTLINE(M1>REF(M1,1),M1),ALIGN0,COLORFFEE33;-------------这句不要了}
M2S:PARTLINE(M2>REF(M2,1),M2),ALIGN0,COLORCCEE66,LINEDOT;
M3S:PARTLINE(M3>REF(M3,1),M3),ALIGN0,COLORAADD99,LINEDOT;
M4S:PARTLINE(M4>REF(M4,1),M4),ALIGN0,COLOR88CCBB,LINEDOT;
M5S:PARTLINE(M5>REF(M5,1),M5),ALIGN0,COLOR66BBDD,LINEDOT;
M6S:PARTLINE(M6>REF(M6,1),M6),ALIGN0,COLOR44AAFF,LINEDOT;

ZZ1:=REF(CLOSE,1);
ZZ2:=SMA(MAX(CLOSE-ZZ1,0),6,1)/SMA(ABS(CLOSE-ZZ1),6,1)*100;
STICKLINE(CROSS(75,ZZ2),O,C,5,0),COLOR66ff00;
STICKLINE(CROSS(ZZ2,25),O,C,5,0),COLOR22ffee;
DRAWTEXT(M1<REF(M1,1) AND REF(M1,1)>REF(M1,2) AND M3>REF(M3,1),M1,'☆'),ALIGN0,COLORFF6633;
DRAWTEXT(M1>REF(M1,1) AND REF(M1,1)<REF(M1,2) AND M5<REF(M5,1),M1,'★'),ALIGN0,COLORYELLOW;
{-------------------------转折参考------------------------}
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'ψ'),ALIGN0,COLOR00ff00;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)) and ref(c,1)>m4,HIGH*1.03,'ψψ'),ALIGN0,COLOR55bb77;{未来,用于参考}
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10))and ref(c,1)>m5,HIGH*1.04,'ψψψ'),ALIGN0,COLOR9988aa;

DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)) and ref(c,1)>m6,HIGH*1.049,'ψψψ'),ALIGN0,COLORdd44ff;{注意花色的不同,有不同的提示作用}
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)) and COUNT( ref(c,1)>m6,3)=3,HIGH*1.056,'ψψψ'),ALIGN0,COLORddEEff;

A04:=(((ZIG( 3.000, 20.000) > REF(ZIG( 3.000, 20.000), 1.000)) AND (REF(ZIG( 3.000, 20.000), 1.000) <= REF(ZIG( 3.000, 20.000), 2.000))) AND (REF(ZIG( 3.000, 20.000), 2.000) <= REF(ZIG( 3.000, 20.000), 3.000)));
A05:=(((ZIG( 3.000, 20.000) < REF(ZIG( 3.000, 20.000), 1.000)) AND (REF(ZIG( 3.000, 20.000), 1.000) >= REF(ZIG( 3.000, 20.000), 2.000))) AND (REF(ZIG( 3.000, 20.000), 2.000) >= REF(ZIG( 3.000, 20.000), 3.000)));
A06:DRAWTEXT(A04,LOW*0.96, '●'),ALIGN0,COLORWHITE;{白珠子不作操作决策,用于转折参考}
DRAWTEXT(A04,LOW*0.90, '●'),ALIGN0,COLORWHITE;
STICKLINE(A04,l,l*0.8,0.1,0),color00ffff,LINEDOT;
A07:DRAWICON(A05,HIGH*1.01, 12),ALIGN0,colorffffff;

{-----------------------解盘----------------------------}

VAR1:=(((CLOSE - HY1) / HY1) * 100);
VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
TS:=BARSLAST((BARSLAST(((VAR1 > 0) AND (REF(VAR1,1) > 0))) > 0));
利润:=SUM(IF((TS > 0),VAR2,0),0);
EXPLAIN(1,'★决策系统★'),colorFFFF;
EXPLAINEX(HY1,'●决策:',HY1,2,0),colorFF;
EXPLAINEX(线性,'●导航:',线性,2,0),color99CC99;
EXPLAIN(CROSS(CLOSE,HY1),'★状态:参考买进!'),colorFF00FF;
EXPLAIN(CROSS(HY1,CLOSE),'★状态:参考卖出!'),colorFFFF00;
EXPLAIN((CLOSE > HY1),'●状态:关注、买入!'),colorFFFF;
EXPLAIN((CLOSE <= HY1),'●状态:观望、警戒、卖出!'),colorFF00;
EXPLAINEX(利润,'●获利:',利润,2,0),colorFF00FF;
EXPLAINEX(((CLOSE - HY1) * 10),'★多空趋势:',((CLOSE - HY1) * 10),2,1),colorFF00FF;
EXPLAINEX((ZL + SF),'库存能量:',(ZL + SF),2,0),colorFF;
EXPLAINEX(MA((ZL + SF),5),'库存平均:',MA((ZL + SF),5),2,0),colorFF;
EXPLAINEX(ZL,'库存主力:',ZL,2,0),colorFF;
EXPLAINEX(SF,'库存散户:',SF,2,0),colorFF00;

飞狐逃顶主图:凤冠霞帔
 



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网