股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2012/5/12 7:48:04

飞狐主图指标-融胜轨道主图+MACD优化+工作线

飞狐主图指标-融胜轨道主图+MACD优化+工作线

{融胜轨道}
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通1:=AA*102/100;
通2:=AA*(200-102)/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:(1+7/100)*DD,LINEDASHDOT,COLOR0099FF;
下:(1-7/100)*DD,LINEDASHDOT,COLOR0099FF;
中:(上+下)/2,LINETHICK0,COLOR0099FF;
顶:(1+14/100)*DD,LINETHICK2,COLORWHITE;
底:(1-14/100)*DD,LINETHICK2,COLORBLUE;
DRAWTEXT(SYSPARAM(1)=BARPOS and 顶,顶,'顶'+'\n'+NUMTOSTR(顶[SYSPARAM(1)],2)),pxup8,colorred;
DRAWTEXT(SYSPARAM(1)=BARPOS and 上,上,'上'+'\n'+NUMTOSTR(上[SYSPARAM(1)],2)),pxup8,colorwhite;
DRAWTEXT(SYSPARAM(1)=BARPOS and 中,中,'中'+'\n'+NUMTOSTR(中[SYSPARAM(1)],2)),pxup8,colorYellow;
DRAWTEXT(SYSPARAM(1)=BARPOS and 下,下,'下'+'\n'+NUMTOSTR(下[SYSPARAM(1)],2)),pxup8,colorwhite;
DRAWTEXT(SYSPARAM(1)=BARPOS and 底,底,NUMTOSTR(底[SYSPARAM(1)],2)+ '\n'+'底'),pxup8,colorred;

{MACD主升浪中轨变色}
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD := 2*(DIFF-DEA);

PARTLINE(DIFF<=0 OR MACD<=0,中),LINETHICK1,COLORGREEN;
PARTLINE(DIFF>0 and MACD>0,中),LINETHICK1,COLORRED;

{工作线}
A0:=(L+H+C*2)/4;
工作线:EMA(A0,14),LINETHICK0,COLORRED;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK0;
A1X:=(工作线-REF(工作线,1))/REF(工作线,1)*100,LINETHICK0;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,LINETHICK0;
PARTLINE(A1X<0 AND A2X<0,工作线),LINETHICK2,COLORGREEN;
PARTLINE(A1X>=0,工作线),LINETHICK2,COLORRED;
PARTLINE(A1X<0,工作线),LINETHICK2,COLORGREEN;

{MACD\KDJ\RSI背离}
A1:=BARSLAST(ref(cross("macd.diff","macd.dea"),1));
B1:=ref(c,A1+1)>c and ref("macd.diff",A1+1)<"macd.diff" and cross("macd.diff","macd.dea");
DRAWTEXT(FILTER(B1>0,5),L*0.98,'M'),COLORGREEN;

A2:=BARSLAST(ref(cross("kdj.k","kdj.d"),1));
B2:=ref(c,A2+1)>c and ref("kdj.k",A2+1)<"kdj.k" and cross("kdj.k","kdj.d");
DRAWTEXT(FILTER(B2>0,5),L*0.98,'K'),COLORYELLOW;

A3:=BARSLAST(ref(cross("RSI.RSI1","RSI.RSI2"),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1",A3+1)<"RSI.RSI1" and cross("RSI.RSI1","RSI.RSI2");
DRAWTEXT(FILTER(B3>0,5),L*0.98,'R'),COLORCYAN;

C1:=BARSLAST(ref(cross("macd.dea","macd.diff"),1));
D1:=ref(c,C1+1)<c and ref("macd.diff",C1+1)>"macd.diff" and cross("macd.dea","macd.diff");
DRAWTEXT(FILTER(D1>0,5),H*1.03,'M'),COLOR0066FF;

C2:=BARSLAST(ref(cross("kdj.d","kdj.k"),1));
D2:=ref(c,C2+1)<c and ref("kdj.k",C2+1)>"kdj.k" and cross("kdj.d","kdj.k");
DRAWTEXT(FILTER(D2>0,5),H*1.03,'K'),COLORRED;

C3:=BARSLAST(ref(cross("RSI.RSI2","RSI.RSI1"),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1",C3+1)>"RSI.RSI1" and cross("RSI.RSI2","RSI.RSI1");
DRAWTEXT(FILTER(D3>0,5),H*1.03,'R'),COLORMAGENTA;

{千均一发元旦主图}
OO:=if(DATATYPE=6,ma(O,22),if(DATATYPE=7,ma(O,10),ma(O,6)));j:=STKINDI('','kdj.j',0,6);
CC:=if(DATATYPE=6,ma(c,22),if(DATATYPE=7,ma(c,10),ma(c,6)));hs:=vol/CAPITAL*100;
jj:=(H+L+C)/3;qj0:=vol/IF(H=L,4,H-L);qj1:=IF(CAPITAL=0,qj0*(jj-MIN(C,O)),qj0*(MIN(O,C)-L));
qj2:=IF(CAPITAL=0,qj0*(MIN(O,C)-L),qj0*(jj-MIN(C,O)));qj3:=qj0*(H-MAX(O,C));qj4:=qj0*(MAX(C,O)-jj);
qj5:=qj1+qj2;qj6:=qj3+qj4;DD:=(qj5-qj6)/(qj5+qj6)*100;
DDX:=((qj1+qj2)-(qj3+qj4))/sum(vol,10)*100;DDZ:=DD*17;
DDY:=((qj2+qj4)-(qj1+qj3))/sum(vol,10)*100;
bb:=(cross(j,0)and ((ddx>0 and ddy>0) or DDZ>400));
主:=qj1+qj2;散:=qj3+qj4;T0:=VOL>REF(VOL,1) and MA(VOL,5)>REF(MA(VOL,5),1);
QJ11:=(HIGH+LOW)/2;QJ12:=EMA(QJ11,22);QJ13:=STD(QJ11,22);QJ14:=((QJ11-QJ12)/QJ13*100+200)/4;
QJ15:=(EMA(QJ14,5)-22)*1.56;QJ16:=SMA(QJ15,3,1);TJ1:=SMA(QJ16,3,1);TJ2:=3*QJ16-2.1*TJ1;
P:=SYSPARAM(1);
Q6:=atan((MA(C,5)/ref(MA(C,5),1)-1)*100)*57.3;Q2:=atan((MA(C,13)/ref(MA(C,13),1)-1)*100)*57.3;
Q1:=atan((MA(C,23)/ref(MA(C,23),1)-1)*100)*57.3;Q:=atan((MA(C,34)/ref(MA(C,34),1)-1)*100)*57.3;
Q3:=atan((MA(C,68)/ref(MA(C,68),1)-1)*100)*57.3;Q5:=atan((MA(C,250)/ref(MA(C,250),1)-1)*100)*57.3;
T1:=VOL<REF(VOL,1) and MA(VOL,5)>REF(MA(VOL,5),1);T2:=VOL>REF(VOL,1) and MA(VOL,5)<REF(MA(VOL,5),1);
T3:=VOL<REF(VOL,1) and MA(VOL,5)<REF(MA(VOL,5),1);T4:=主>REF(主,1) and 主>散 and if(CAPITAL=0,hs>1.3,hs>5);
T5:=主<REF(主,1) and 主>散 and if(CAPITAL=0,hs>0.5 and hs<1.3,hs>3 and hs<=5);
T6:=主>REF(主,1) and 主<散 and if(CAPITAL=0,hs<1.3 and hs>0.5,hs<5 and hs>3);
T7:=主<REF(主,1) and 主<散 and if(CAPITAL=0,hs<1.3,hs<3 and hs>=1);
DRAWTEXTEX(CLOSE,1,0,100,'5 日线夹角: '+NUMTOSTR(Q6[P],2)+' 度'),COLORAAAAAA;
DRAWTEXTEX(CLOSE,1,220,100,'13日线夹角: '+NUMTOSTR(Q2[P],2)+' 度'),COLORAAAAAA;
DRAWTEXTEX(CLOSE,1,450,100,'22日线夹角: '+NUMTOSTR(Q1[P],2)+' 度'),COLORAAAAAA;
DRAWTEXTEX(CLOSE,1,0,150,'34日线夹角: '+NUMTOSTR(Q[P],2)+' 度'),COLORAAAAAA;
DRAWTEXTEX(CLOSE,1,220,150,'68日线夹角: '+NUMTOSTR(Q3[P],2)+' 度'),COLORAAAAAA;
DRAWTEXTEX(CLOSE,1,450,150,'250日线夹角: '+NUMTOSTR(Q5[P],2)+' 度'),COLORAAAAAA;
DRAWTEXTEX(CLOSE,1,20,0,'上涨家数:'+NUMTOSTR(INDEXADV,0)+' 家'),COLOR0066FF;
DRAWTEXTEX(CLOSE,1,180,0,'下跌家数:'+NUMTOSTR(INDEXDEC,0)+' 家'),COLOR99FF99;
DRAWTEXTEX(CLOSE,1,340,0,'平盘家数:'+NUMTOSTR(PINGPAN,0)+' 家'),COLOREEEEEE;
{DRAWTEXT(bb,L*0.98,'弄\n点\n钱\n玩\n玩'),COLOR00FFFF;}
DRAWTEXTEX(T0,1,500,0,'成交大于昨日,有继续增大趋势'),Color00FFFF;
DRAWTEXTEX(T1,1,500,0,'成交小于昨日,但有放大迹象'),Color00DDFF;
DRAWTEXTEX(T2,1,500,0,'成交大于昨日,但有缩小迹象'),ColorFFFF00;
DRAWTEXTEX(T3,1,500,0,'成交小于昨日,且有缩小迹象'),ColorFFbb00;
DRAWTEXTEX(T4,1,760,0,'资金比较活跃,大资金活动明显'),Color00FFff;
DRAWTEXTEX(T5,1,760,0,'资金开始积极,大资金温和进场'),Color00DDff;
DRAWTEXTEX(T6,1,760,0,'散乱资金积极,散户行为明显'),ColorFFDD00;
DRAWTEXTEX(T7,1,760,0,'交易频率上升,散户相当积极'),ColorFFFF00;
DRAWTEXTEX(CLOSE,1,20,50,STKLABEL+' '+STKNAME+' '+STRLEFT(BLKNAME,40)),Color00AAAA;
a:=F10FIND('【十大流通股东】:',1);a0:=F10FIND('主要指标:',1);c0:=F10FIND('控盘情况:',a0);
hs:=F10FIND('总户数',500);
q1:=F10FIND('200',hs+40);q2:=F10FIND('200',q1+40);
g1:=LTRIM(F10TEXT(q1+14,10));g2:=LTRIM(F10TEXT(q2+14,10));
gd1:=STRTONUM(g1);gd2:=STRTONUM(g2);qq1:=gd1-gd2;qq2:=gd1-gd2;
DRAWTEXTex(qq1<0,1,820,960,'市场筹码较上期集中'),color00EEFF;
DRAWTEXTex(qq2>0,1,820,960,'市场筹码较上期分散'),colorFFAA00;

QSW:=F10FIND('按照资产负债率排名',5000);
QSZ:=F10FIND('按照每股收益排名',5000);
DRAWTEXTEX(c,1,10,900,'■按照每股收益排名:'+F10TEXT(QSz+20,0));
DRAWTEXTEX(c,1,10,950,'■按照资产负债率排名:'+F10TEXT(QSW+22,0));
DRAWTEXTEX(c,1,10,850,'■主题库:'+SELFSTRING('主题投资')),Color77AAFF;

飞狐主图指标-融胜轨道主图+MACD优化+工作线



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网