股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2012/5/12 7:40:35

飞狐箱体鳄鱼 取自阳光飞狐的鳄鱼线解盘 源码

飞狐箱体鳄鱼 取自阳光飞狐的鳄鱼线解盘 源码

箱体鳄鱼-取自阳光飞狐的鳄鱼线解盘

Var1:=(H+L)/2;
AO:=SMA(Var1,5,1)-SMA(Var1,34,1),COLOR6699CC;
AC:=SMA((AO-SMA(AO,5,1)),5,1),COLOR6699CC;
x1:=AO>REF(AO,1) and Ac>REF(Ac,1);
x2:=AO<REF(AO,1) and Ac<REF(Ac,1);
Y:=(H+L)/2;
RED:=SMA(Y,8,1);
R2:=REF(RED,5);
KU1:=IF(H=HHV(H,3),1,0);
KD1:=IF(L=LLV(L,3),1,0);
UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0,REF(H,2),REF (H,2+BARSLAST(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0)));
DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(L,2),REF (L,2+BARSLAST(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0)));
下颚:SMA(Y,13,1),SHIFT8,COLORBLUE;
牙齿:SMA(Y,5,1),SHIFT5,COLORRED;
上唇:SMA(Y,3,1),SHIFT3,COLORGREEN;
多:cross(SMA(Y,5,1),SMA(Y,13,1)),colorred,linethick0;
空:cross(SMA(Y,13,1),SMA(Y,5,1)),colorgreen,linethick0;
上张:=下颚>=ref(下颚,1) and 牙齿>=ref(牙齿,1) and 上唇>=ref(上唇,1);
下张:=下颚<ref(下颚,1) and 牙齿<ref(牙齿,1) and 上唇<ref(上唇,1);
上碎:IF(H>=R2,UL,REF(UL,BARSLAST(H>R2))),COLORMAGENTA, linethick0;
下碎:IF(L<=R2,DL,REF(DL,BARSLAST(L<=R2))),COLORCYAN, linethick0;
箱顶:=BARSLAST(ABS(上碎-REF(上碎,1)))<BARSLAST(c>上碎 AND REF (c,1)<REF(上碎,1)),COLORMAGENTA;
STICKLINE(箱顶,上碎,上碎,6,1),COLORMAGENTA;
箱底:=BARSLAST(ABS(下碎-REF(下碎,1)))<BARSLAST(c<下碎 AND REF (c,1)>REF(下碎,1)),COLORCYAN;
STICKLINE(箱底,下碎,下碎,6,1),COLORCYAN;
LC := REF(C,4);
RMI:=SMA(MAX(C-LC,0),7,1)/SMA(ABS(C-LC),7,1)*100;
QS:= HHV(MA(RMI,3),13),Color00ADFF;
RMIMA:= SMA(RMI,3,1),Color009C00;
向上突破有效上碎型:=cross(c,上碎), colorred, linethick0;
向下有效碎型被突破:=cross(下碎,c), colorgreen, linethick0;
AO与AC为多方趋势:=x1>0, colorred, linethick0;
AO与AC为空方趋势:=x2>0, colorgreen, linethick0;
买:向上突破有效上碎型=1 and AO与AC为多方趋势=1, colorred, linethick0;
卖:向下有效碎型被突破=1 and AO与AC为空方趋势=1, colorgreen, linethick0;
Drawicon(买,LOW*0.99,8);
Drawicon(卖,HIGH*1.01,9);

//大资金活动{公式在线提供:www.gszx.com.cn}
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
大资金活动:VAR11 AND COUNT(VAR11,30)=1,COLORFF00FF,LINETHICK0;
DRAWTEXT(大资金活动,LOW*0.95,'大资金活动'),LINETHICK1,COLORFF00FF;

VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
大笔成交:VAR1C AND COUNT(VAR1C,30)=1,colorwhite, linethick0;
DRAWTEXT(大笔成交,LOW*0.95,'大笔成交') COLORWHITE;
 

飞狐箱体鳄鱼 取自阳光飞狐的鳄鱼线解盘 源码



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网