股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2012/5/11 18:26:22

请老师把任意选股信号用“操作区”公式过滤?

问:请老师把任意选股信号用“操作区”公式过滤?

BIAS1:=MA((CLOSE-MA(CLOSE,13))/MA(CLOSE,13),3)*100;
BIAS3:=MA((CLOSE-MA(CLOSE,27))/MA(CLOSE,27),3)*100;
操作区:IF(BIAS3<0,BIAS3,0),COLORRED,LINETHICK2;
观望区:IF(BIAS3>0,BIAS3,0),COLORGREEN,LINETHICK2;
VAR1:=IF(DATE>=1990601,0,1);
VAR2:=TROUGHBARS(3,15,1)<10;
VAR3:=PEAKBARS(3,15,1)<10;
VAR4:=IF(VAR2=1,50,0);
VAR5:=IF(VAR3=1,50,0);
TJ1:=观望区<REF(观望区,1) OR 观望区-REF(观望区,1)<REF(观望区,1)-REF(观望区,2);
TJ2:=操作区>REF(操作区,1);
顶: IF(TJ1 AND VAR5=50,15,0),STICK,LINETHICK1,COLORGREEN;
底: IF(TJ2 AND VAR4=50,10,0),STICK,LINETHICK1,COLORRED;
DRAWICON(TJ1 AND VAR5=50,-2,8);
DRAWICON(TJ2 AND VAR4=50,11,7);

希望对任意选股信号,用上面的公式,从第一根红竖线到出现第一根骕竖线之间的信号保留,从这根绿竖线到下一线红竖线之间的信号过滤
 

 

{公式在线提供:www.gszx.com.cn}答案:

看看是不是这个意思
BIAS1:=MA((CLOSE-MA(CLOSE,13))/MA(CLOSE,13),3)*100;
BIAS3:=MA((CLOSE-MA(CLOSE,27))/MA(CLOSE,27),3)*100;
操作区:=IF(BIAS3<0,BIAS3,0);
观望区:=IF(BIAS3>0,BIAS3,0);
VAR1:=IF(DATE>=1990601,0,1);
VAR2:=TROUGHBARS(3,15,1)<10;
VAR3:=PEAKBARS(3,15,1)<10;
VAR4:=IF(VAR2=1,50,0);
VAR5:=IF(VAR3=1,50,0);
TJ1:=观望区<REF(观望区,1) OR 观望区-REF(观望区,1)<REF(观望区,1)-REF(观望区,2);
TJ2:=操作区>REF(操作区,1);
底:=TJ2 AND VAR4=50;
顶:=TJ1 AND VAR5=50;
JCCOUNT:COUNT(底,BARSLAST(cross(顶,0)))>0 and not(顶);

 



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网