股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2012/5/11 18:15:20

如何编写通达信均线托的选股指标?

问:如何编写通达信均线托的选股指标?

注明:图中白色线是2日均线,黄色线是28日均线,紫色线是78日均线    001.jpg (2.59 KB)

2010-8-31 17:03
要求:选出如图2日线上穿28日和78日均线且28日线上穿78日线形成的一个不太规则的三角形股来!并且这个不太规则的三角形图形在该股的20日之前(具体前面多久时间限定在250日内)已经就近出现过一次!求这样的一个选股公式!如果没有这样的公式的话!请老师可不可以把那个(TJ1,20)中的20设置为一个变数!如为N(20-250)!请老师帮助完善!谢谢老师!
MA2:=MA(C,2);
MA20:=MA(C,28);
MA78:=MA(C,78);
TJ1:=CROSS(MA2,MA20);
TJ2:=CROSS(MA2,MA78);
TJ3:=CROSS(MA20,MA78);
XUAN:COUNT(TJ1,20)=1 AND COUNT(TJ2,20)=1 AND TJ3;
 

{公式在线提供:www.gszx.com.cn}答案:

MA2:=MA(C,2);
MA28:=MA(C,28);
MA78:=MA(C,78);
TJ1:=CROSS(MA2,MA28);
TJ2:=CROSS(MA2,MA78);
TJ3:=CROSS(MA28,MA78);
TJ4:=COUNT(TJ1,28)=1 AND COUNT(TJ2,28)=1 AND TJ3;
TJ5:=BARSLAST(TJ4);
XUAN:TJ4=1 AND REF(TJ5,1)<250;

 



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网