股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2019/10/12 7:59:43

放牛郎三线图主图公式做选股

编写要求:

 

www.gszx.com.cn网解答:

 网友求助:

请老师将【三线图】做选股
1 白线上穿紫黄两线
2 加码 做两个选股 谢谢
源码如下
MA1:=MA(C,5);MA2:=MA(C,10);MA3:=MA(C,20);MA5:=MA(C,60);
M1:=5;M2:=10;M3:=20;M4:=60;P:=VOL;VOLUME:=VOL;
放牛郎源码:=VOL/REF(MA(VOL,5),1)COLORGREEN;
金牛登山系统:=IF(MA(P,M1)>MA(P,M4),22,0)COLORWHITE,LINETHICK2;
LONG:=26;SHORT:=12;M:=9;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
有钱大家赚:=IF(CROSS(DIFF,DEA) AND DIFF<0.0001
AND DEA<0.0001,8,0)COLORWHITE,LINETHICK3;
有奶大家喝:=IF(有钱大家赚 AND REF(EXIST(有钱大家赚,40),3)
AND DIFF<0.0001 AND DEA<0.0001,8,0)COLORGREEN,LINETHICK5;
Q1:=7;Q2:=21;Q3:=30;
金牛吃草线:EXPMA(CLOSE,Q1)COLORWHITE,LINETHICK2;
金牛耕田线:EXPMA(CLOSE,Q2),LINETHICK2;
金牛登山线:MA(CLOSE,Q3)COLORMAGENTA,LINETHICK3;
P3:=ABS(金牛吃草线-金牛耕田线)
+ABS(金牛耕田线-金牛登山线)+ABS(金牛吃草线-金牛登山线);
ZH:=IF((P3/C<3.3/100 OR REF(P3/C<3.3/100,1))
AND LAST(金牛吃草线<金牛登山线,12,3)
AND LAST(金牛耕田线<金牛登山线,12,3)
AND 金牛吃草线>REF(金牛吃草线,1)
AND REF(金牛吃草线,1)>REF(金牛吃草线,2)
AND 金牛耕田线>REF(金牛耕田线,1)
AND REF(金牛耕田线,1)>REF(金牛耕田线,2)
AND 金牛吃草线>金牛耕田线
AND 金牛吃草线>金牛登山线,30,0)COLORFF00FF,LINETHICK3;
喝牛奶:=(ZH=30 OR REF(ZH=30,1) OR REF(ZH=30,2) OR REF(ZH=30,3))
AND 金牛耕田线>金牛登山线 AND 金牛登山线>REF(金牛登山线,1)
AND REF(金牛登山线,1)>REF(金牛登山线,2)
AND 金牛耕田线>REF(金牛耕田线,1)
AND (金牛登山系统 OR LAST(金牛耕田线<金牛登山线,35,5)
OR LAST(金牛吃草线<金牛登山线,35,5))
AND REF(EXIST(有奶大家喝,30),5) AND MA3>REF(MA3,1);
DRAWICON(喝牛奶=1,金牛登山线*0.95,3);
DRAWICON(喝牛奶=1,金牛登山线*0.93,3);
DRAWICON(喝牛奶=1,金牛登山线*0.92,3);
DRAWICON(喝牛奶=1,金牛登山线*0.90,3);
DRAWICON(喝牛奶=1,金牛登山线*0.88,3);
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
DRAWTEXT((B1 = 1),(LOW * 0.96),'跟'),COLOR00FFFF;
DRAWTEXT((B1 = 1),(LOW * 0.92),'进'),COLOR00FFFF;
DRAWTEXT((B2 = 1),(LOW * 0.96),'加'),COLOR88FFFF;
DRAWTEXT((B2 = 1),(LOW * 0.925),'码'),COLOR88FFFF;

 

放牛郎三线图主图公式做选股

放牛郎三线图主图公式做选股

解答如下:
CROSS(EXPMA(CLOSE,7),EXPMA(CLOSE,21)) AND CROSS(EXPMA(CLOSE,7),MA(CLOSE,30));
===============
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));


网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网