股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2019/9/19 8:22:44

将见底公式做为选股公式

编写要求:

 

www.gszx.com.cn网解答:

 网友求助:

当出现砸锅买、机会、见底、来临信号时做为选股条件

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
有庄: STICKLINE(VAR8,0,VAR8,6,1) , COLORFFAAFF;
趋势线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORAABBDD;
AA:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-30) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-30,趋势线),1) AND CROSS(趋势线,-30)) OR 趋势线=-30;
DRAWTEXT(AA,500,'砸锅买'),COLORYELLOW;
砸锅买:IF(AA,500,-30),COLORYELLOW;
BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
DRAWTEXT(BB,300,'见底'),COLORRED;
见底:IF(BB,300,-20),COLORRED;
CC:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-25 AND 趋势线>-30) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-25,趋势线),1) AND CROSS(趋势线,-25));
DRAWTEXT(CC,400,'机会'),COLOR00FF00;
机会:IF(CC,400,-25),COLOR00FF00;

来临:IF(CROSS(-25,趋势线),150,-25),LINETHICK2,COLORF00FF0;
DRAWTEXT(CROSS(-25,趋势线),170,'★'),COLORF00FF0;

砸锅等:IF(CROSS(-30,趋势线),200,-30),LINETHICK2,COLORWHITE;
DRAWTEXT(CROSS(-30,趋势线),220,'★'),COLORWHITE;
 

 
解答如下:
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;
AA:((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-30) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-30,趋势线),1) AND CROSS(趋势线,-30)) OR 趋势线=-30;
==================
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;
BB:((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
=================
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;
来临:CROSS(-25,趋势线);


网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网