股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/5/23 6:17:48

飞狐反击图解盘副图指标

飞狐反击图解盘副图指标

源码

LC:=REF(CLOSE,1);
R1:=(SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1))*100;
R2:=(SMA(MAX(CLOSE-LC,0),12,1))/(SMA(ABS(CLOSE-LC),12,1))*100;
R3:=(SMA(MAX(CLOSE-LC,0),24,1))/(SMA(ABS(CLOSE-LC),24,1))*100;
B1:=IF(R1<20,1,0);
B2:=IF(R2<20,1,0);
B3:=IF(R3<20,1,0);
B4:=BARSSINCE(CLOSE>0);
BB:=IF(B4>100,B1+B2+B3,0);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
SA1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
SA2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
SA3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
SA4:=IF(SA1<-8,1,0);
SA5:=IF(SA2<-8,1,0);
SA6:=IF(SA3<-8,1,0);
DD:=SA4+SA5+SA6;
E1:=WINNER(CLOSE);
E2:=PWINNER(60,CLOSE);
E3:=PWINNER(150,CLOSE);
E4:=(E1+E2+E3)/3;
E5:=IF(E4<0.0382,1,0);
狼:(IF(E5>0 AND BB>1 AND DD>1,2,0)),STICK,colorFFFF;
EXPLAIN(狼>0,'狼终于来了,矛准备好了吗?'),colorFFFF;
DRAWICON(狼>0,2,7);
X:=1;
VAR1:=1;
VAR2:=CLOSE/REF(CLOSE,1)>=1.062 AND HIGH/CLOSE<1.005 AND MA(CLOSE,90)/CLOSE>=1.15;
VAR3:=VAR2 AND COUNT(VAR2,20)=1 AND VAR1*X;
VAR4:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
VAR5:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
VAR6:=IF(VAR4>0.01,0.9,1) AND IF(VAR4>-0.025,1,1.2);
VAR7:=VAR6*(VAR5-VAR4)*100;
VAR8:=SUM(VAR7,10)*X;
VAR9:=SMA(VAR8,40,1);
VAR10:=VAR8>20;
VAR11:=CROSS(CLOSE,MA(CLOSE*1.055,3)) AND CLOSE>OPEN*1.06 AND VOL>=REF(VOL,1)*1.5 AND CLOSE>=MA(CLOSE,10);
VAR12:=VAR10 AND VAR11 AND VAR1;
VAR13:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));
VAR14:=VAR1 AND CROSS(VAR13,-87) AND OPEN<MA(CLOSE,5) AND CLOSE>=1.09*REF(CLOSE,1) AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV(CLOSE,58);
VAR15:=EMA(CLOSE,12)-EMA(CLOSE,26);
VAR16:=EMA(VAR15,9)*X;
VAR17:=2*(VAR15-VAR16);
VAR18:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*X*100;
VAR19:=SMA(VAR18,3,1);
VAR20:=SMA(VAR19,3,1);
VAR21:=(EMA(IF(VAR16>REF(VAR16,1),1,-1),14))*14;
VAR22:=(EMA(IF(VAR20>REF(VAR20,1),1,-1),14))*14*2;
VAR23:=(MA(CLOSE,5)/MA(CLOSE,70)-1)*100;
VAR24:=(VAR23+VAR22+VAR21)/3;
VAR25:=MA(CLOSE,80)-MA(CLOSE,10)/3*X;
VAR26:=IF(CLOSE<VAR25 AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.062 AND CLOSE<MA(CLOSE,13)*1.13,88,0);
VAR27:=IF(CLOSE/REF(CLOSE,1)>1.05 AND VOL/CAPITAL*100<6 AND CLOSE<17 AND HIGH/CLOSE<1.01 AND VAR26>0,91,0);
VAR28:=IF(VAR24>REF(VAR24,1) AND REF(VAR24,1)<REF(VAR24,2) AND (VAR3 OR VAR12 OR VAR14) OR VAR26>0 OR VAR27>0,85,0);
高级:=IF(VAR27>0,95,0);
中级:=IF(VAR26>0 OR VAR27>0,91,0);
初级:=IF(VAR28>0 OR VAR27>0 OR VAR26>0,88,0);
兔子:(IF(高级>0 OR 中级>0 OR 初级>0,1,0)),STICK,colorFFFFFF;
EXPLAIN(兔子>0,'兔子出现,放箭!'),colorFFFFFF;
DRAWICON(兔子>0,1,8);
LGL:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=(IF(LGL>0 AND CCC<0,200,0))*X;
LXL:=IF(SX<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
JBJ:=(IF(CCC<0 AND LXL=-50,100,0))*X;
MA3:=MA(CLOSE,3);
C0:=REF(CLOSE,2)*0.865;
C1:=REF(CLOSE,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(CLOSE,13)*X;
CXC:=IF((CLOSE-BOT)/CLOSE<3/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),100,0);
V满仓:=VMC;
V半仓A:=IF(ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0) AND (LXL<0 OR LGL>0) AND VMC<10,50,0);
V93:=(ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0) AND (LXL<0 OR LGL>0);
V90:=ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
V半仓:=V93 OR V90;
XMM87:=V满仓 OR V半仓;
XMM91:=VMC;
G:=MA(CLOSE,80)-MA(CLOSE,10)/3*X;
初:=IF(XMM87>0,87,0);
中:=IF(XMM91>0,91,0);
高:=IF(VMC>0 AND CLOSE<G,97,0);
终结者:=MAX(MAX(高,初),中);
北极熊:IF(终结者>0,3,0),STICK,colorFFFF00;
EXPLAIN(北极熊>0,'北极熊?猎枪瞄准!'),colorFF;
DRAWICON(北极熊>0,3,13);

 

飞狐反击图解盘副图指标



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网