股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/5/22 7:41:27

飞狐多头能量副图指标

飞狐多头能量副图指标

源码

A01:=DYNAINFO(7);
A02:=MA(((AMOUNT / VOL) / 100),(VOL / CAPITAL));
A03:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A04:=IF((LOW > A01),0,IF((HIGH < A01),1,((A01 - LOW) / (HIGH - LOW))));
A05:=(DMA(A04,(VOL / CAPITAL)) * 100);
A06:=IF((((A05 > 0) AND (A05 > REF(A05,1))) AND (A03 <= 88)),A05,0);
FILLRGN((A06 > 0),0,A06),colorFF00FF;
VAR1:=(MA(((100 * (CLOSE - LLV(CLOSE,34))) / (HHV(HIGH,34) - LLV(LOW,34))),5) - 20);
VAR2:=(2 * ABS(VAR1));
VAR3:=((100 - (3 * SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),20,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),20,1),15,1)));
VAR4:=((100 - (3 * SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),20,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),20,1),15,1)));
VAR5:=(((HIGH + LOW) + CLOSE) / 3);
VAR6:=((VAR5 - MA(VAR5,14)) / (0.015 * AVEDEV(VAR5,14)));
VAR7:=((VAR5 - MA(VAR5,70)) / (0.015 * AVEDEV(VAR5,70)));
VAR8:=IF(((((VAR6 >= 150) AND (VAR6 < 200)) AND (VAR7 >= 150)) AND (VAR7 < 200)),10,0);
VAR9:=IF(((((VAR6 <= (0 - 150)) AND (VAR6 > (0 - 200))) AND (VAR7 <= (0 - 150))) AND (VAR7 > (0 - 200))),(0 - 10),VAR8);
VARA:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * 100);
VARB:=(100 - ABS(VARA));
VARC:=((3 * SMA((((INDEXC - LLV(INDEXL,75)) / (HHV(INDEXH,75) - LLV(INDEXL,75))) * 100),20,1)) - (2 * SMA(SMA((((INDEXC - LLV(INDEXL,75)) / (HHV(INDEXH,75) - LLV(INDEXL,75))) * 100),20,1),15,1)));
VARD:=((3 * SMA((((INDEXO - LLV(INDEXL,75)) / (HHV(INDEXH,75) - LLV(INDEXL,75))) * 100),20,1)) - (2 * SMA(SMA((((INDEXO - LLV(INDEXL,75)) / (HHV(INDEXH,75) - LLV(INDEXL,75))) * 100),20,1),15,1)));
VARE:=(REF(LOW,1) * 0.9);
VARF:=(LOW * 0.9);
VAR10:=(((VARF * VOL) + (VARE * (CAPITAL - VOL))) / CAPITAL);
VAR11:=EMA(VAR10,30);
VAR12:=(VAR11 - CLOSE);
VAR13:=REF(CLOSE,1);
VAR14:=((SMA(MAX((CLOSE - VAR13),0),7,1) / SMA(ABS((CLOSE - VAR13)),7,1)) * 100);
VAR15:=((SMA(MAX((CLOSE - VAR13),0),13,1) / SMA(ABS((CLOSE - VAR13)),13,1)) * 100);
VAR16:=BARSCOUNT(CLOSE);
VAR17:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),6,1)) * 100);
VAR18:=(((((0 - 100) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 50) * 2);
VAR19:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
VAR1A:=((SMA(VAR19,4,1) - 50) * 2);
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);
VAR20:=IF((((((((((VAR17 <= 25) AND (VAR18 < (0 - 95))) AND (VAR1F > 20)) AND (VAR1B < (0 - 30))) AND (VAR1E < 30)) AND (VAR12 >= (0 - 0.25))) AND (VAR14 < 22)) AND (VAR15 < 28)) AND (VAR16 > 50)),80,0);
天线:=IF((VARB < 90),VARB,100);
多头能量:IF((VAR1 > 0),VAR1,0),STICK,colorFFFF00;
空头能量:IF((VAR1 < 0),VAR2,0),STICK,colorFF00;
导弹:=VAR20;
预警系统:=(IF(((VAR7 >= 200) AND (VAR6 >= 150)),15,IF(((VAR7 <= (0 - 200)) AND (VAR6 <= (0 - 150))),(0 - 15),VAR9)) + 60);
VAR21:=((CLOSE > MA(CLOSE,20)) AND (MA(CLOSE,20) >= REF(MA(CLOSE,20),1)));
VAR22:=((CLOSE < MA(CLOSE,20)) AND (MA(CLOSE,20) < REF(MA(CLOSE,20),1)));
VAR23:=(((多头能量 > 50) AND (预警系统 > 60)) AND (天线 = 100));
VAR24:=(((多头能量 > 48) AND (预警系统 > 60)) AND (天线 < 100));
VAR25:=((空头能量 > 38) AND (预警系统 < 55));
VAR26:=((导弹 > 50) AND (天线 < 90));
VAR27:=(((VAR3 < REF(VAR4,1)) AND (VOL > REF(VOL,1))) AND (CLOSE > REF(CLOSE,1)));
VAR28:=((((((VAR3 >= REF(VAR4,1)) AND (CLOSE < REF(CLOSE,1))) AND (预警系统 = 60)) AND (导弹 = 0)) AND (空头能量 >= REF(空头能量,1))) AND (VARC < REF(VARD,1)));
DRAWTEXT((VAR23 AND (COUNT(VAR23,30) = 1)),70,'上\n涨\n过\n急'),ALIGN4;
DRAWTEXT((VAR24 AND (COUNT(VAR24,30) = 1)),80,'庄\n家\n出\n货'),ALIGN4;
DRAWTEXT((VAR25 AND (COUNT(VAR25,30) = 1)),50,'有\n小\n反\n弹 '),ALIGN4;
DRAWTEXT((VAR26 AND (COUNT(VAR26,30) = 1)),30,'坚\n决\n抢\n反\n弹'),ALIGN4;
DRAWTEXT((VAR27 AND (COUNT(VAR27,30) = 3)),40,'有\n资\n金\n活\n动\n迹\n象'),ALIGN4,colorFF00FF;
DRAWTEXT((VAR28 AND (COUNT(VAR28,30) = 1)),20,'见\n顶\n回\n落\n中'),ALIGN4;
PT:=(REF(HIGH,1) - REF(LOW,1));
CDP:=(((HIGH + LOW) + CLOSE) / 3);
AH:=(CDP + PT);
AL:=(CDP - PT);
NH:=((2 * CDP) - LOW);
NL:=((2 * CDP) - HIGH);
EXPLAINEX(1,'【波动系数】=',PT,2,0),colorFFFF;
EXPLAINEX(1,'【最高】=',AH,2,0),colorFF;
EXPLAINEX(1,'【中价】=',CDP,2,0),colorFFFF;
EXPLAINEX(1,'【最低】=',AL,2,0),colorFFFFFF;
EXPLAINEX(1,'【近高】=',NH,2,0),colorFFFF00;
EXPLAINEX(1,'【近低】=',NL,2,0),colorFF00FF;
A:=((((OPEN + HIGH) + LOW) + (CLOSE * 2)) / 5);
S:=(((HIGH - A) * 0.618) + A);
X:=(((A - LOW) * 0.382) + LOW);
卖出价:=(((CLOSE * 2.5) / 100) + CLOSE);
买入价:=(CLOSE - ((CLOSE * 2.5) / 100));
EXPLAINEX((1 = 1),'【买入价】=',买入价,2,0),colorFFFF;
EXPLAINEX((1 = 1),'【卖出价】=',卖出价,2,0),colorFF00;
A:=(VOL * CLOSE);
B:=(SUM(A,1) / SUM(VOL,1));
{B1:= EMA(B,17);
资金((B - B1) * 100) / B),colorFF;
强弱线:=0;
EXPLAINEX(1,'【资金增减程度】=',资金,2,0),colorFF;
EXPLAIN(VAR23,'股价上涨过急,\n短线需要调整'),colorFF;
EXPLAIN(VAR24,'庄家正在出货中,\n保持观望为好'),colorFFFFFF;
EXPLAIN(VAR25,'也许有小反弹,\n保持观望或小仓位参与'),colorFF00;
EXPLAIN(VAR26,'处于触底状态,\n短线高手坚决抢反弹'),colorFFFF00;
EXPLAIN(VAR27,'有大资金活动迹象,\n保持积极关注'),colorFF00FF;
EXPLAIN(VAR28,'见顶回落过程中,\n暂时保持观望,\n少安毋躁'),colorFFFF;
EXPLAINEX(1,'【多头能量】=',多头能量,2,0),colorFFFF00;
EXPLAINEX(1,'【空头能量】=',空头能量,2,0),colorFF00; }

飞狐多头能量副图指标



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网