股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/5/17 6:09:24

飞狐鬼眼鬼指副图指标

飞狐鬼眼鬼指副图指标

源码

{技术指标公式:鬼眼鬼指 (抄底逃顶极品,看长做短精品(鬼眼使者)) 缺省周期:日线}
Var1:=IF(YEAR>=2034 AND MONTH>0,0,1);
Var2:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
Var3:=SMA(Var2,3,1);
Var4:=SMA(Var3,3,1);
Var5:=3*Var3-2*Var4;
Var6:=LLV(LOW,5);
Var7:=HHV(HIGH,5);
Var8:=EMA((CLOSE-Var6)/(Var7-Var6)*100,4)*2;
Var9:=EMA(0.667*REF(Var8,1)+0.333*Var8,2);
VarA:=3*Var8-2*Var9;
VarB:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VarC:=POW(MA(LOW,5),2)+MA(LOW,5);
VarD:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VarE:=(VarB-LLV(VarC,64))/(HHV(VarD,64)-LLV(VarC,64))*150+65-10;
VarF:=SMA(VarE,3,1)*1.5-100;
Var10:=SMA(VarF,3,1);
Var11:=3*VarF-2*Var10;
Var12:=(HIGH+LOW+CLOSE*2)/4;
Var13:=EMA(Var12,13);
Var14:=STD(Var12,13);
Var15:=(Var12-Var13)*100/Var14;
Var16:=EMA(Var15,5);
Var17:=EMA(Var16,13);
Var18:=EMA(Var16,13)+200-100;
Var19:=EMA(Var18,10);
Var1A:=3*Var18-2*Var19;
Var1B:=Var3+Var8+VarF+Var18;
Var1C:=Var4+Var9+Var10+Var19;
Var1D:=Var5+VarA+Var11+Var1A;
Var1E:=(HIGH+LOW+CLOSE)/3;
Var1F:=AMOUNT/VOL/100;
Var20:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
Var21:=(Var1E-MA(Var1E,34))/(0.015*AVEDEV(Var1E,34));
Var22:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
Var23:=(HIGH+LOW+CLOSE+Var1E)/4;
Var24:=EMA(Var23,24);
Var25:=STD(Var23,24);
Var26:=(Var23-Var24)/Var25*100;
Var27:=(Var1E-MA(Var1E,24))/(0.015*AVEDEV(Var1E,24));
Var28:=EMA(Var26,5);
Var29:=(Var1F-MA(Var1F,21))/(0.015*AVEDEV(Var1F,21));
Var2A:=(Var20-MA(Var20,90))/(0.015*AVEDEV(Var20,90));
Var2B:=((Var28+Var27+Var21)/3+165)/4;
Var2C:=(EMA(EMA(EMA(Var2B,15),10),5)-25)*2+Var22;
Var2D:=(Var1B+Var1C+Var1D*30)/32/5-15;
Var2E:=EMA(Var2D,13);
Var2F:=(Var2B+Var2D)/2/1.1;
Var30:=Var2F*Var1;
短A: EMA(Var30,1), ,;
短B: EMA(短A,5), , ;
趋势线: EMA((Var2C+Var2E)/2,2), , ;
生死线: EMA(趋势线,40), ,;
Var31:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var32:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
Var33:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var34:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
Var35:=(CLOSE-Var34)/Var34*100;
Var36:=REF(Var35,1)<-40 AND Var35>REF(Var35,1) AND REF(Var35,1)2.5;
Var37:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,110)/MA(VOL,110)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<-0.273;
Var38:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)<-0.125;
Var39:=Var37 AND Var38;
Var3A:=Var31>=-45 AND Var31<=-10 AND Var32<=-15 AND Var33<=-20;
Var3B:=COUNT(Var3A,1)>=1;
Var3C:=1;
Var3D:=Var39 AND Var3B;
Var3E:=(MA(AMOUNT,5)*Var3C/MA(VOL,5)/100-MA(AMOUNT,125)/MA(VOL,125)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<(-0.4)*Var3C;
Var3F:=HHV(HIGH,500);
Var40:=LLV(LOW,500);
Var41:=HHV(HIGH,250);
Var42:=LLV(LOW,250);
Var43:=EMA(CLOSE,34);
Var44:=MA(Var43*0.82,5);
Var45:=CLOSE-REF(MA(CLOSE,20),11)<-2;
Var46:=LLV(LOW,125);
Var47:=MA((Var3F*0.45+Var41*0.5+Var40+Var42+Var46)/5,35);
Var48:=Var47;
Var49:=SMA(AMOUNT/VOL/100,13,1)*0.85;
Var4A:=CLOSE-REF(MA(CLOSE,20),11);
Var4B:=CLOSE<-1.5 OR Var3E AND CLOSE<-1.5 OR Var45 AND CLOSE<-1.5 OR CLOSE
Var4C:=Var37 AND Var38;
Var4D:=Var31>=-45 AND Var31<=-7 AND Var32<=-11 AND Var33<=-14;
Var4E:=COUNT(Var4D,1)>=1;
Var4F:=Var4C AND Var4E;
Var50:=Var3E AND CLOSE
Var51:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var52:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
Var53:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var54:=REF(CLOSE,1);
Var55:=SMA(MAX(CLOSE-Var54,0),5,1)/SMA(ABS(CLOSE-Var54),5,1)*100;
Var56:=(HIGH+LOW+CLOSE)/3;
Var57:=(Var56-MA(Var56,14))/(0.015*AVEDEV(Var56,14));
Var58:=REF(CLOSE,2)*0.865;
Var59:=REF(CLOSE,13)*0.772;
Var5A:=MIN(Var58,Var59);
Var5B:=100*VOL/CAPITAL;
Var5C:=Var51>=-15.8 AND Var51<=-12.2 AND Var52<=-20.8 AND Var53<=-27.5 AND Var55<=11.7 AND Var57<=-145;
鬼指: IF(Var36 OR Var3D OR Var50 OR Var5C OR (CLOSE-Var5A)/CLOSE<0.03 AND SUM(Var5B,5)/5<1.8,100,-32), ,;
风险区: STICKLINE(趋势线>105,140,130,10,1), ,;
鬼顶: STICKLINE(趋势线>135,140,130,10,0), , ;
鬼道: STICKLINE(BETWEEN(趋势线,CROSS(趋势线,150),140),-40,-30,10,0), , ;
安全区: STICKLINE(趋势线<-15,-41,-31,10,1), , ;
鬼底: STICKLINE(趋势线<-26,-41,-31,10,0), , ;
鬼指, ,;
IF(CROSS(100,短A) OR CROSS(80,短A),105,120), , ;
DRAWTEXT(CROSS(趋势线,130) OR CROSS(趋势线,135) OR CROSS(135,趋势线) OR CROSS(132,趋势线) OR CROSS(130,趋势线) OR CROSS(128,趋势线) OR CROSS(126,趋势线) OR CROSS(124,趋势线),140,'◆'), , {00010001};
DRAWICON(CROSS(短B,趋势线) AND 趋势线<=-17 OR CROSS(趋势线,生死线) AND 生死线<=5,-15,3);

飞狐鬼眼鬼指副图指标



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网