股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/5/16 6:13:12

飞狐黑马决策系统副图指标

飞狐黑马决策系统副图指标

源码

{黑马决策系统--辰之星决策系统}

DRAWGBK(VOL>1,COLORRGB(180,180,180),COLORRGB(25,15,0),70);

S:='股票代码:'+STKLABEL;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,S),ALIGN4,color222222;
DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,'                 所属板块:'+BLKNAME+'\n'+'发行价'+NUMTOSTR(FINANCE(51),2)+'元'+'  发行量'+NUMTOSTR(FINANCE(52),2)+'万股'+'\n'+'总股本'+NUMTOSTR(FINANCE(1),0)+'万股'+'  流通A股'+NUMTOSTR(FINANCE(7),0)+'万股'+'  净资产'+NUMTOSTR(FINANCE(35),2)+'亿元'+'  每股收益'+NUMTOSTR(FINANCE(33),2)+'元'+'  每股未分配'+NUMTOSTR(FINANCE(32),2)+'元'+'\n'+'市盈率'+NUMTOSTR(DYNAINFO(39),2)+'%'+'  投资收益'+NUMTOSTR(FINANCE(24),2)+'元'+'  股东总数'+NUMTOSTR(FINANCE(50),0)+'户'),ALIGN4,color222222;
BB:=BARPOS=SYSPARAM(1);
买线:=EMA(CLOSE,2) ;
卖线:=(EMA(SLOPE(CLOSE,13)*20+CLOSE,40)) ;
低吸:CROSS(买线,卖线),LINETHICK0;
高抛:CROSS(卖线,买线),LINETHICK0;
DRAWTEXT(低吸,LOW*0.996,'←低吸'),PXUP6,colorFF;
DRAWTEXT(高抛,HIGH*1.028,'←高抛'),PXUP6,colorFFFF00;
STICKLINE(买线>=卖线,LOW,HIGH,1,0),colorFF;
STICKLINE(买线>=卖线,CLOSE,OPEN,4.5,0),colorAA;
STICKLINE(买线>=卖线,CLOSE,OPEN,4,0),colorCC;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,0),colorCC;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,0),colorEE;
STICKLINE(买线<卖线,CLOSE,OPEN,4.5,0),colorAAAA00;
STICKLINE(买线<卖线,CLOSE,OPEN,4,0),colorBBBB00;
STICKLINE(买线<卖线,CLOSE,OPEN,3,0),colorCCCC00;
STICKLINE(买线<卖线,CLOSE,OPEN,2,0),colorEEEE00;
STICKLINE(买线<卖线,LOW,HIGH,1,0),colorFFFF00;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,3,0),colorFFFF;
主力短期成本:EMA((EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),LINETHICK1,colorFFFFFF;
主力中期成本:MA(CLOSE,21) ,LINETHICK1,colorFF00;
主力长期成本:MA(CLOSE,30) ,LINETHICK2,colorFFFF;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10) ;
DRAWTEXT(CROSS(V1,V2),V1+0.05,'←黑马起飞'),PXUP4,colorFF00;
黑马起飞:IF(CROSS(V1,V2),1,0),LINETHICK0;
VAR1:=LLV(LOW,21) ;
VAR2:=HHV(HIGH,21) ;
AK1:=EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,5) ;
AK:=EMA((CLOSE-VAR1)/(VAR2-VAR1)*50,13) ;
AB:=CROSS(AK1,AK);
DRAWICON(CROSS(V1,V2),V2,1);
DRAWTEXT(AB=1,LOW*0.99,'←黑马起步'),colorFFFF;
黑马起步:IF(AB=1,1,0),LINETHICK0;

飞狐黑马决策系统副图指标



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网