股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/4/7 5:56:43

飞狐天地波段副图指标

飞狐天地波段副图指标

源码

Var1:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*180;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=3*Var2-2*Var3;
Var5:=LLV(LOW,5);
Var6:=HHV(HIGH,5);
Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,4)*2;
Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2);
Var9:=3*Var7-2*Var8;
VarA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VarB:=POW(MA(LOW,5),2)+MA(LOW,5);
VarC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VarD:=(VarA-LLV(VarB,64))/(HHV(VarC,64)-LLV(VarB,64))*150+65-10;
VarE:=SMA(VarD,3,1)*1.5-100;
VarF:=SMA(VarE,3,1);
Var10:=3*VarE-2*VarF;
Var11:=(HIGH+LOW+CLOSE*2)/4;
Var12:=EMA(Var11,13);
Var13:=STD(Var11,13);
Var14:=(Var11-Var12)*100/Var13;
Var15:=EMA(Var14,5);
Var16:=EMA(Var15,13);
Var17:=EMA(Var15,13)+200-100;
Var18:=EMA(Var17,10);
Var19:=3*Var17-2*Var18;
Var1A:=Var2+Var7+VarE+Var17;
Var1B:=Var3+Var8+VarF+Var18;
Var1C:=Var4+Var9+Var10+Var19;
Var1D:=(HIGH+LOW+CLOSE)/3;
Var1E:=AMOUNT/VOL/100;
Var1F:=IF(DATE>=1191228,0,1);
Var20:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
Var21:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34));
Var22:=(CLOSE+HIGH+LOW+OPEN)/4;
Var23:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
Var24:=(HIGH+LOW+CLOSE+Var1D)/4;
Var25:=EMA(Var24,24);
Var26:=STD(Var24,24);
Var27:=(Var24-Var25)/Var26*100;
Var28:=(Var1D-MA(Var1D,24))/(0.015*AVEDEV(Var1D,24));
Var29:=EMA(Var27,5);
Var2A:=(Var1E-MA(Var1E,21))/(0.015*AVEDEV(Var1E,21));
Var2B:=SUMBARS(VOL,CAPITAL)*Var1F;
Var2C:=(Var20-MA(Var20,90))/(0.015*AVEDEV(Var20,90));
Var2D:=((Var2C+Var2A+Var29+Var28+Var21)/5+165)/4;
Var2E:=(EMA(EMA(EMA(Var2D,15),10),5)-25)*2+Var23;
Var2F:=(Var1A+Var1B+Var1C*30)/32/5-15;
Var30:=EMA(Var2F,13);
Var31:=(Var2D+Var2F)/2/1.1;
Var32:=HHV(Var22,Var2B);
Var33:=LLV(Var22,Var2B);
Var34:=(Var22-Var33)/(Var32-Var33);
Var35:=EMA(EMA(EMA(CLOSE,13),13),13);
Var36:=((Var35-REF(Var35,1))/REF(Var35,1)*100+0.45)*50;
Var37:=MA(Var36,21);
Var38:=((HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.96)*106;
Var39:=((HHV(HIGH,100)-CLOSE)/(HHV(HIGH,100)-LLV(LOW,100))*(-1)+0.96)*106;
Var3A:=(HIGH+LOW+CLOSE)/3;
Var3B:=((Var3A-MA(Var3A,14))/(0.015*AVEDEV(Var3A,14))+200)/4;
Var3C:=(HIGH+LOW+CLOSE*2)/4;
Var3D:=EMA(Var3C,13);
Var3E:=STD(Var3C,13);
Var3F:=(Var3C-Var3D)*100/Var3E;
Var40:=EMA(Var3F,5);
Var41:=EMA(Var40,13);
Var42:=(EMA(Var40,13)+100)/2-5;
Var43:=EMA(Var42,10);
Var44:=EMA(VOL/CAPITAL,21)*13;
Var45:=(92-100/(1+Var44))*2.38;
Var46:=REF(CLOSE,1);
Var47:=WINNER(CLOSE)*100;
Var48:=WINNER(REF(CLOSE,1))*100;
Var49:=REF(INDEXC,1);
Var4A:=(CLOSE-Var46)/Var46;
Var4B:=(INDEXC-Var49)/Var49;
Var4C:=Var4A-Var4B;
Var4D:=SMA(MAX(CLOSE-Var46,0),4,1)/SMA(ABS(CLOSE-Var46),4,1)*100;
Var4E:=SMA(MAX(CLOSE-Var46,0),8,1)/SMA(ABS(CLOSE-Var46),8,1)*100;
Var4F:=SMA(MAX(CLOSE-Var46,0),12,1)/SMA(ABS(CLOSE-Var46),12,1)*100;
擎天线:IF(Var22>=Var32,(2*Var22-Var33-REF(Var32,1))/(Var32-Var33)
*Var1F,Var34*Var1F);
地龙线:IF(Var22<=Var33,(2*Var22-Var33-REF(Var33,1))/(Var32-Var33)
*Var1F,Var34*Var1F);
地窖:0,POINTDOT ;
天堑:1,POINTDOT;
DRAWICON((地龙线<-0.04 and 地龙线>-0.06 )or cross(地龙线,0),-0.1,1);
DRAWICON(if(ma(c,250)=1.12,45),擎天线>=1.12),1.2,2);

 飞狐天地波段副图指标



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网