股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/4/7 5:55:23

飞狐天若有情副图指标

飞狐天若有情副图指标

源码

Var1:=CLOSE/"1A0001$CLOSE"*1000;
Var2:=EMA(Var1,12)-EMA(Var1,36);
Var3:=EMA(Var2,20);
Var4:=2*(Var2-Var3);
Var5:=IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.98,REF(CLOSE,1),LOW);
Var6:=IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<-0.98,REF(CLOSE,1),HIGH);
Var7:=SUM(CLOSE-Var5-Var6+CLOSE,0);
Var8:=EMA(Var7,12)-EMA(Var7,36);
Var9:=EMA(Var8,20);
VarA:=2*(Var8-Var9);
VarB:=MA(VarA,15);
VarC:=EMA(IF(VarB>=0 AND Var4>=0 AND CLOSE>MA(CLOSE,60),Var4,IF(VarB<0
AND MA(CLOSE,15)>CLOSE,VarB,Var4)),3);
M1: VarC, COLORSTICK ;
强弱: VarC,;
VarD:=MA(VarC,12);
长期: MA(VarC,24),,COLORRED ,linethick2 ;
VarE:=CROSS(MA(CLOSE,8),MA(CLOSE,60));
买:=VarE AND VarC>0 AND 长期>0 AND 长期/REF(长期,3)>1;
出击:if(买>0,0.5,0) STICK,COLORWHITE;
DRAWICON(出击>0,0.5 ,1 );
DRAWTEXT(出击>0,0.4, '★出击')COLORWHITE ;
卖:=IF(MA(CLOSE,60)/REF(MA(CLOSE,60),10)<1
AND CROSS(MA(CLOSE,20),MA(CLOSE,8)),-1,0), ;
卖出:if(卖<0,-0.5,0) STICK, ,COLORYELLOW ;
DRAWICON(卖出<0,-0.5 ,2);
DRAWTEXT(卖出<0,-0.4, '★卖出') ,COLORYELLOW ;
中线: DRAWICON(VarD<0 AND CROSS(强弱,VarD)
AND CROSS(MA(CLOSE,8),MA(CLOSE,60)),-0.5,1);

 飞狐天若有情副图指标



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网