股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/1/30 6:53:01

飞狐西北白乾宫公式

飞狐西北白乾宫公式

源码

DRAWGBK(C,COLORRGB(0,0,60),COLORRGB(40,100,80),1);

启动:STICKLINE(((COUNT(CROSS(EMA(CLOSE,3),EMA(CLOSE,13)),2) > 0) AND (EMA(CLOSE,3) > EMA(CLOSE,8))),-1,0.5,4.5,0),colorFFFF;

DRAWTEXT(((COUNT(CROSS(EMA(CLOSE,3),EMA(CLOSE,13)),2) > 0) AND (EMA(CLOSE,3) > EMA(CLOSE,8))),-1,'启动'),colorFFFF;

临界:STICKLINE(((COUNT(CROSS(EMA(CLOSE,13),EMA(CLOSE,32)),2) > 0) AND (EMA(CLOSE,13) > EMA(CLOSE,21))),3.5,5,4.5,0),COLORMAGENTA;

DRAWTEXT(((COUNT(CROSS(EMA(CLOSE,13),EMA(CLOSE,32)),2) > 0) AND (EMA(CLOSE,13) > EMA(CLOSE,21))),5.3,'临界'),COLORMAGENTA;

AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100);

BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100);

CC:=(AA - BB);

DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) /

100)))) * 100);

EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN <> LOW));

A1:=DYNAINFO(6);

A2:=IF((LOW > A1),0,IF((HIGH < A1),1,(((A1 - LOW) + 0.01) / ((HIGH - LOW) +

0.01))));

A3:=(VOL / WINNER(LOW));

A4:=REF(HHV(CLOSE,120),1);

A5:=REF(LLV(CLOSE,120),1);

A6:=((100 * (CLOSE - A5)) / (A4 - A5));

A7:=((A2 > 0) OR (A2 = 1));

A8:=((A7 AND ((A3 / REF(A3,3)) >= 3)) AND (A6 < 80));

A9:=(((REF(A8,1) OR REF(A8,2)) OR REF(A8,3)) OR REF(A8,4));

A10:=(A8 AND A9);

A11:=IF(FILTER(A8,3),5,0);

A12:=IF((FILTER(A10,3) OR EE),10,0);

进场:STICKLINE(A11,2,3.5,5,0),colorFF7700;

加仓:STICKLINE(A12,0.5,2,5,0),colorFF00FF;

STICKLINE(A11,2,3.5,5,0),colorFF7700;

STICKLINE(A11,2,3.5,4.5,0),colorFF8800;

STICKLINE(A11,2,3.5,4,0),colorFF9900;

STICKLINE(A11,2,3.5,3.5,0),colorFFAA00;

STICKLINE(A11,2,3.5,3,0),colorFFBB00;

STICKLINE(A11,2,3.5,2.5,0),colorFFCC00;

STICKLINE(A11,2,3.5,2,0),colorFFDD00;

STICKLINE(A11,2,3.5,1,0),colorFFEE00;

STICKLINE(A12,0.5,2,4.5,0),color102099;

STICKLINE(A12,0.5,2,4,0),color1020AA;

STICKLINE(A12,0.5,2,3.5,0),color1020BB;

STICKLINE(A12,0.5,2,3,0),color1020CC;

STICKLINE(A12,0.5,2,2.5,0),color1020DD;

STICKLINE(A12,0.5,2,2,0),color1020EE;

STICKLINE(A12,0.5,2,1,0),color1020FF;

DRAWTEXT(A11,4,'进场'),colorFFFF00;

DRAWTEXT(A12,0,'加仓'),colorred;

Var1:=(ema(close,34)-ema(close,52))/ma(close,54)*100;

Var2:=ema(Var1,10);

Var3:=Var1<0;

Var4:=Var3 AND cross(Var1,Var2);

Var5:=Var1>0;

Var6:=Var5 AND cross(Var2,Var1);

Va1:=(ema(close,26)-ema(close,52))/ma(close,60)*100;

Va2:=ema(Va1,18);

Va3:=Va1<0;

Va4:=Va3 AND cross(Va1,Va2);

Va5:=Va1>0;

Va6:=Va5 AND cross(Va2,Va1);

s2:if(va4,0.5,2),linethick2,color990000;

s3:if(va4,0.5,-1),linethick2,color990000;

s4:if(va6,3.5,2),linethick2,color990000;

s5:if(va6,3.5,5),linethick2,color990000;

DRAWTEXT(s5=3.5,3.5,'转向!!!'),colorred;

DRAWTEXT(s3=0.5 ,0.5,'变盘!!!'),coloryellow;

VAR26:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VAR36:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VAR46:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VAR56:=(((VAR26 + (2 * VAR36)) + (3 * VAR46)) / 6);

VAR66:=MA(VAR56,3);

VAR76:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);

VAR86:=SMA(VAR76,2,1);

VAR96:=SMA(VAR86,2,1);

VARA:=((3 * VAR86) - (2 * VAR96));

关注: STICKLINE((CROSS(VARA,VAR96) AND (COUNT((VAR66 < (0 - 9)),2) >= 1)),0.5,2,4.5,0),colorFFFFFF;

DRAWTEXT((CROSS(VARA,VAR96) AND (COUNT((VAR66 < (0 - 9)),2) >= 1)),0.3,'关注'),colorFFFFFF;

SK:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);

SD:= EMA(SK,2);

drawtext((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )

or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,3.2,' 超准短线'),color77AAFF;

stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )

or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),2,3.5,4.5,0),color77AAFF;
 

 

飞狐西北白乾宫公式



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网