股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/1/6 6:29:33

“量能均线”的这段代码

编写要求:

 

www.gszx.com.cn网解答:

 网友求助:

恳请那位老师费心给改改,谢谢谢谢乐!
A1:IF(B1>REF(B1,1),B1,DRAWNULL),COLORRED;
A2:IF(B2>REF(B2,1),B2,DRAWNULL),COLORRED;
A3:IF(B3>REF(B3,1),B3,DRAWNULL),COLORRED;
A4:IF(B4>REF(B4,1),B4,DRAWNULL),COLORRED;
A5:IF(B5>REF(B5,1),B5,DRAWNULL),COLORRED;
A6:IF(B6>REF(B6,1),B6,DRAWNULL),COLORRED;
A7:IF(B7>REF(B7,1),B7,DRAWNULL),COLORRED;
A8:IF(B8>REF(B8,1),B8,DRAWNULL),COLORRED;
A9:IF(B9>REF(B9,1),B9,DRAWNULL),COLORRED;
A10:IF(B10>REF(B10,1),B10,DRAWNULL),COLORRED;


{量能均线}
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击,3);0,POINTDOT,COLORWHITE;
B1:SUM(LLJX,1),COLORCYAN;
B2:SUM(LLJX,2),COLORCYAN;
B3:SUM(LLJX,3),COLORCYAN;
B4:SUM(LLJX,4),COLORCYAN;
B5:SUM(LLJX,5),COLORCYAN;
B6:SUM(LLJX,6),COLORCYAN;
B7:SUM(LLJX,7),COLORCYAN;
B8:SUM(LLJX,8),COLORCYAN;
B9:SUM(LLJX,9),COLORCYAN;
B10:SUM(LLJX,10),COLORCYAN;
A1:IF(B1>REF(B1,1),B1,DRAWNULL),COLORRED;
A2:IF(B2>REF(B2,1),B2,DRAWNULL),COLORRED;
A3:IF(B3>REF(B3,1),B3,DRAWNULL),COLORRED;
A4:IF(B4>REF(B4,1),B4,DRAWNULL),COLORRED;
A5:IF(B5>REF(B5,1),B5,DRAWNULL),COLORRED;
A6:IF(B6>REF(B6,1),B6,DRAWNULL),COLORRED;
A7:IF(B7>REF(B7,1),B7,DRAWNULL),COLORRED;
A8:IF(B8>REF(B8,1),B8,DRAWNULL),COLORRED;
A9:IF(B9>REF(B9,1),B9,DRAWNULL),COLORRED;
A10:IF(B10>REF(B10,1),B10,DRAWNULL),COLOR00FFFF,LINETHICK3;
CC1:=IF(B1>REF(B1,1),1,0);
CC2:=IF(B2>REF(B2,1),1,0);
CC3:=IF(B3>REF(B3,1),1,0);
CC4:=IF(B4>REF(B4,1),1,0);
CC5:=IF(B5>REF(B5,1),1,0);
CC6:=IF(B6>REF(B6,1),1,0);
CC7:=IF(B7>REF(B7,1),1,0);
CC8:=IF(B8>REF(B8,1),1,0);
CC9:=IF(B9>REF(B9,1),1,0);
CC10:=IF(B10>REF(B10,1),1,0);
DD:=CC1+CC2+CC3+CC4+CC5+CC6+CC7+CC8+CC9+CC10;
选股:DD>=9 ;

 
解答如下:
{量能均线}
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击,3);0,POINTDOT,COLORWHITE;
B1:SUM(LLJX,1),COLORCYAN;
B2:SUM(LLJX,2),COLORCYAN;
B3:SUM(LLJX,3),COLORCYAN;
B4:SUM(LLJX,4),COLORCYAN;
B5:SUM(LLJX,5),COLORCYAN;
B6:SUM(LLJX,6),COLORCYAN;
B7:SUM(LLJX,7),COLORCYAN;
B8:SUM(LLJX,8),COLORCYAN;
B9:SUM(LLJX,9),COLORCYAN;
B10:SUM(LLJX,10),COLORCYAN;
A1:PARTLINE(B1>REF(B1,1),B1),COLORRED;
A2:PARTLINE(B2>REF(B2,1),B2),COLORRED;
A3:PARTLINE(B3>REF(B3,1),B3),COLORRED;
A4:PARTLINE(B4>REF(B4,1),B4),COLORRED;
A5:PARTLINE(B5>REF(B5,1),B5),COLORRED;
A6:PARTLINE(B6>REF(B6,1),B6),COLORRED;
A7:PARTLINE(B7>REF(B7,1),B7),COLORRED;
A8:PARTLINE(B8>REF(B8,1),B8),COLORRED;
A9:PARTLINE(B9>REF(B9,1),B9),COLORRED;
A10:PARTLINE(B10>REF(B10,1),B10),COLOR00FFFF,LINETHICK3;
CC1:=IF(B1>REF(B1,1),1,0);
CC2:=IF(B2>REF(B2,1),1,0);
CC3:=IF(B3>REF(B3,1),1,0);
CC4:=IF(B4>REF(B4,1),1,0);
CC5:=IF(B5>REF(B5,1),1,0);
CC6:=IF(B6>REF(B6,1),1,0);
CC7:=IF(B7>REF(B7,1),1,0);
CC8:=IF(B8>REF(B8,1),1,0);
CC9:=IF(B9>REF(B9,1),1,0);
CC10:=IF(B10>REF(B10,1),1,0);
DD:=CC1+CC2+CC3+CC4+CC5+CC6+CC7+CC8+CC9+CC10;
选股:DD>=9 ;
 


网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网