股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2016/1/1 6:52:58

把智能辅助 RSI RSI中RSI1值上升 美人眼这四个选股公式给组合起

编写要求:

 

www.gszx.com.cn网解答:

 网友求助:

我只组合了一个那就是美人眼和RSI1值上升 需要老师再把那两个选股公式给组合到一块 也就是 这四个选股公式组合到一起就行啦 谢谢老师

这是智能辅助选股公式
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
牛:=(20*HHJsjda+19*REF(HHJsjda,1)+18*REF(HHJsjda,2)+17*REF(HHJsjda,3)+16*REF(HHJsjda,4)+15*REF(HHJsjda,5)+14*REF(HHJsjda,6)
+13*REF(HHJsjda,7)+12*REF(HHJsjda,8)+11*REF(HHJsjda,9)+10*REF(HHJsjda,10)+9*REF(HHJsjda,11)+8*REF(HHJsjda,12)
+7*REF(HHJsjda,13)+6*REF(HHJsjda,14)+5*REF(HHJsjda,15)+4*REF(HHJsjda,16)+3*REF(HHJsjda,17)+2*REF(HHJsjda,18)+
REF(HHJsjda,20))/210;
熊:=MA(牛,5);
(熊<牛);

这是RSI金叉选股公式
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
RSI1>RSI3;

这是我组合的美人眼和RSI1值上升选股公式
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
RSI11:=REF(RSI1,1);
xg1:=RSI1>RSI11;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
%K:=MA(RSV,3);
%D:=MA(%K,3);
XG2:=(%K>%D);
xg1 and xg2;
谢谢老师了

 
解答如下:
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
RSI11:=REF(RSI1,1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
£¥K:=MA(RSV,3);
£¥D:=MA(£¥K,3);
CROSS((£¥K>£¥D) AND RSI1>RSI3 AND RSI1>RSI11,0.5);


网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网