股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2015/11/19 7:00:09

“走势”主图中出现②信号时的预警公式

编写要求:

 

公式指标网解答:

 网友求助:

请老师帮我做个选股,要求在主图中出现②时发出预警
源码如下:MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120);
{}
GET:=ZIG(3,7);
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强一:=BARSLAST(PL5<REF(PL5,1));
走弱一:=BARSLAST(PL5>REF(PL5,1));
走强二:=BARSLAST(PL10<REF(PL10,1));
走弱二:=BARSLAST(PL10>REF(PL10,1));
走强三:=BARSLAST(PL20<REF(PL20,1));
走弱三:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强二),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强二),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱二),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱二),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强三),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强三),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱三),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱三),0);
DRAWTEXT(EN2 AND ZTJZ5=1,LOW+0.19,'②'),LINETHICK3,Color0000FF,ALIGN1,LAYER0;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H,'③'),LINETHICK3,COLOR00FF00,ALIGN1,LAYER0;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L,'②'),LINETHICK3,Color0000FF,ALIGN1,LAYER0;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H,'③'),LINETHICK3,COLOR00FF00,ALIGN1,LAYER0;
DRAWGBKLAST(CLOSE,STRIP(RGB(80,105,180),RGB(0,0,0),0));
{大盘走势}
VAR1:="SH000001$CLOSE";
VAR2:=MA(VAR1,13);
VAR3:=VAR1>VAR2;
VAR4:=VAR2>VAR1;
IF BARSTATUS=2 AND VAR3 THEN BEGIN
DRAWTEXTABS(10,20,'大盘走势:★·强·★·重仓参与,积极操作'),COLORRED,LINETHICK3;
END
ELSE
IF BARSTATUS=2 AND VAR4 THEN BEGIN
DRAWTEXTABS(10,20,'大盘走势:★·弱·★·严控仓位,谨慎操作'),COLORffffff,LINETHICK3;
END;
{①}
AA:=TROUGHBARS(3,15,1)<4;
XG1:=FILTER(AA=1,5);
DRAWTEXT(XG1,L,'①'),LINETHICK3,COLOR00FFFF,ALIGN1,LAYER0;
{太阳选股}
WF:=TROUGHBARS(3,5,2)<4 OR TROUGHBARS(3,5,1)<4;
WD:=((REF(C,1)-C)/C*100>1.5 OR ((REF(C,2)-C)/C*100>1.5) AND C<REF(C,1)) AND C>MA(C,13)*0.94;
XG3:=FILTER(WF=1,1) AND WD;
DRAWICON(XG3,l,12),ALIGN1,LAYER0;

TJ:=IF((C-REF(C,1))/REF(C,1)>0.025,1,0);
yl:=IF(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),0);
FT:=BARSLAST(yl);
YLX:=REF(yl,FT);
bt:=IF(C<OPEN and ref(C,1)>ref(OPEN,1),ref(C,1),0);
XFT:=BARSLAST(bt);
XYLX:=REF(bt,XFT);
平台调下:=CROSS(XYLX,C);
平台突破:=CROSS(C,YLX);
DRAWICON(平台突破,L* 0.93,7),ALIGN1,VALIGN2;
DRAWICON(平台调下,H,8),ALIGN1,VALIGN2;
VAR22:=REF(LOW,1);
VAR33:=SMA(ABS(LOW-VAR22),13,1)/SMA(MAX(LOW-VAR22,0),13,1)*100;
VAR44:=EMA(IF(CLOSE*1.2,VAR33*13,VAR33/13),13);
VAR55:=LLV(LOW,34);
VAR66:=HHV(VAR44,34);
VAR77:=IF(LLV(LOW,56),1,0);
VAR88:=EMA(IF(LOW<=VAR55,(VAR44+VAR66*2)/2,0),3)/618*VAR77;
主力进场:=VAR88>REF(VAR88,1);
坚决买入:=ref(主力进场,1);
DRAWTEXT(坚决买入 and 平台突破 ,L * 0.97,'坚决买入'),ALIGN1,COLOR0000FF;
ma6:=ma(c,6);
ma18:=ma(c,18);
ma30:=ma(c,30);

 
解答如下:
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
走强三:=BARSLAST(PL20<REF(PL20,1));
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强三),0);
EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;


网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网