股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2015/11/19 6:52:33

涨跌停公式

编写要求:

 

公式指标网解答:

 网友求助:

帮个忙写一下公式在同花顺主图中显示:1涨跌停标记;涨停为红色,跌停为绿色;2;昨日收盘价与今日最高价幅度大于九点五以上,和今日振幅大于九点五以上的,不论阴阳,在K线的最高价上做个标记
 
解答如下:
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(涨停=1,O,C,8,0) ,COLOR0000ff;
跌停:=IF((REF(C,1)-L)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(跌停=1,O,C,8,0) ,COLORff0000;
dd:=H/REF(C,1)>1.95 OR (H-L)/REF(C,1)*100>9.5;
STICKLINE(dd,H+0.2,H+0.3,8,0) ,COLORffffff;

 



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网