股票公式指标网-网站导航


网站搜索:  

公式指标网 发表于2015/11/8 7:47:57

量能观测的选股公式

编写要求:

 

公式指标网解答:

 网友求助:

源码:
A股:CAPITAL/1000000,LINETHICK0,COLORWHITE;
实际量:VOL,LINETHICK0;
{VAR1:=DYNAINFO(17)*REF(MA(VOL,5),1);
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
预测:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2)/10000;
预测量:STICKLINE(IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2),VAR1,0,7,1),COLORGRAY;}
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL /2)),POINTDOT,COLORRED;
主卖:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL /2)),LINETHICK0,COLORGREEN;
换手率%:VOL/CAPITAL*100,POINTDOT,COLORWHITE;
STICKLINE(C>=REF(C,1) ,0,VOL,2.5,1),COLORRED;
STICKLINE(C<REF(C,1),0,VOL,2.5,1),COLORGREEN;
STICKLINE(主买>0,0,主买,2.5,0),COLORRED;
STICKLINE(主卖<0 ,0,主卖,2.5,0),COLORGREEN;
资金异动:VOL/MA(VOL,55)*100,COLORYELLOW;
STICKLINE(资金异动>100 ,0,VOL,0.6,0),COLORYELLOW;
MA5:MA(V,5),COLORWHITE;
MA13:MA(V,13),COLORRED;
DRAWTEXT(CROSS(MA5,MA13),(V *1.05),'★关注'),COLORYELLOW;

条件:股价收于5线之上且K线为红K线,换手大于2%,源码中MA5<MA13但它们都大于上一交易日,
 

 
解答如下:
MA5:=MA(V,5);
MA13:=MA(V,13);
C>MA(C,5) AND C>=REF(C,1) AND V/CAPITAL*100>2 AND MA5<MA13 AND MA5>REF(MA5,1) AND MA13>REF(MA13,1);


网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网