股票公式指标网-网站导航


网站搜索:  

公式在线网 发表于2015/5/6 7:25:25

编个“短牛大牛”、“短牛中牛大牛”同时出现时的选股公式

编写要求:

短牛中牛大牛源码:请老师编个“短牛大牛”同时出现和“短牛中牛大牛”同时出现时的选股公式 N1:=5;N2:=10; LLC:=REF(CLOSE,1); RSI15:SMA(MAX(CLOSE-LLC,0),N1,1)/SMA(ABS(CLOSE-LLC),N1,1)*10; RSI10:SMA(MAX(CLOSE-LLC,0),N2,1)/SMA(ABS(CLOSE-LLC),N2,1)*10; VAR21:=C-REF(C,1); VAR22:=100*EMA(EMA(VAR21,6),6)/EMA(EMA(ABS(VAR21),6),6); MA5:=EMA(C,5); MA13:=EMA(C,13); UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS (MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS (MA5,MA13))+1),0); DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS (MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS (MA13,MA5))+1),0),COLOR00FF00; 短牛:(LLV(VAR22,2)=LLV(VAR22,7) AND COUNT(VAR22<0,2) AND CROSS(VAR22,MA(VAR22,2))) AND REF(DOWN,1)REF(DOWN,1); STICKLINE(UP,0,0.2,3,0),COLOR0000FF; STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00; STICKLINE(短牛,0,8,2,0),COLOR000088; STICKLINE(短牛,0,8,1,0),COLOR0000CC; STICKLINE(短牛,0,8,0.22,0),COLOR0000FF; DRAWTEXT(短牛,8,'←短牛'),COLOR0000FF; 中牛:REF(DOWN,1)REF(DOWN,1) AND CREF(DOWN,1) AND C 0) AND (HD > LD)),HD,0),10); DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10); PDI:=((DMP * 100) / TR1); MDI:=((DMM * 100) / TR1); ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5); AV:=(RSI5 + ADX); DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5); WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10))); NEWVOL:=(RSI5 - WR10); 最佳买入:=(AV + NEWVOL); 最佳买入选股:=IF(CROSS(最佳买入,0),1,0); VAR1:=SMA(最佳买入选股,3,1); VAR2:=SMA(VAR1,3,1),COLOR0000FF; VAR3:=SMA(VAR2,3,1),COLOR00FFFF; 建仓买点:IF(CROSS(VAR2,VAR3) AND (VAR2<40),1,0* 10000),COLORWHITE,NODRAW; STICKLINE(建仓买点,0,2,2,0),COLORLINETHICK0; STICKLINE(建仓买点,0.2,4.0,2,0),COLORLINETHICK0; RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50); K:=SMA(RSV,3,1); D:=SMA(K,3,1); J:=3*K-2*D; X:=LLV(J,2)=LLV(J,8); 最佳买入时机: IF(CROSS(J,3),1,0),COLORYELLOW; STICKLINE(最佳买入时机,0,1,3,0),COLOR009999; STICKLINE(最佳买入时机,0,1,2,0),COLOR00DDDD; STICKLINE(最佳买入时机,0,1,1,0),COLOR00FFFF; 机构建仓: IF(最佳买入<5,1,0),STICK,COLORFF00FF,LINETHICK1; 机构建仓日:STICKLINE(机构建仓,0,-0.3,3,0),COLORFF00FF,LINETHICK6; HIGHN:=5; RSII:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*10,COLORCYAN,LINETHICK1; LOWN:=HIGHN; AAA:=REF(RSII,HIGHN)=HHV(RSII,2*HIGHN+1); QY:=BACKSET(AAA,HIGHN+1); CCC:=FILTER(QY,HIGHN) AND RSII=HHV(RSII,HIGHN+1); DRAWICON(CCC,RSII*1.02,2); DDD:=BARSLAST(CCC); GDTS:=IF(CCC,CURRBARSCOUNT,0); DINGBU:=IF(DDD,REF(RSII,DDD),RSII);{顶部} DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DINGBU1:=REF(DINGBU,DDD+1); GDCS1:=CONST(DINGBUTS); DINGBUTS1:=REF(DINGBUTS,DDD+1); GDCS2:=CONST(DINGBUTS1); DINGBU2:=REF(DINGBU1,DDD+1); MM:=IF(CURRBARSCOUNT>GDCS2,0,1); AA1:=REF(RSII,LOWN)=LLV(RSII,2*LOWN+1); QY1:=BACKSET(AA1,LOWN+1); CC1:=FILTER(QY1,LOWN) AND RSII=LLV(RSII,LOWN+1); DRAWICON(CC1,RSI*0.098,1);

公式在线网解答:

 VAR1:=C-REF(C,1);

VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0);
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
短牛:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
中牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
大牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
选三牛合一:短牛+中牛+大牛=3;


网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网