公式指标网-网站导航


网站搜索:  

公式在线网 发表于2014/2/27 22:20:58

通达信会心整套原创指标

会心原创主图(其中的筹码分布是别人的东西借鉴过来)
{筹码图}
DA1:=IF(280>TOTALBARSCOUNT,TOTALBARSCOUNT,280);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{通达信文字指标}
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
{上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),
上市天数));
{}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率)
,市净率),净资收益率),毛利率),净利润率),主营利润率));
{}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/
FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
{}
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,股本市值),COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.18,0,财务系数),COLORGRAY;
{会心原创}
A1:=EMA(C,17);
A2:=SMA(C,17,1);
DRAWBAND(A2,RGB(0,120,120),A1,RGB(250,20,250));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{涨停K线图}
立桩量:=IF(NAMELIKE('S') OR NAMELIKE('*'),(C-REF(C,1))/REF(C,1)*100>4.95,
(C-REF(C,1))/REF(C,1)*100>9.88);
STICKLINE(立桩量,O,C,3.0,0),COLOR0000BB;
STICKLINE(立桩量,O,C,2.7,0),COLOR0000CC;
STICKLINE(立桩量,O,C,2.4,0),COLOR0011CC;
STICKLINE(立桩量,O,C,2.0,0),COLOR1122DD;
STICKLINE(立桩量,O,C,1.7,0),COLOR2233DD;
STICKLINE(立桩量,O,C,1.3,0),COLOR3344EE;
STICKLINE(立桩量,O,C,1,0),COLOR4455EE;
STICKLINE(立桩量,O,C,0.6,0),COLOR5566FF;
STICKLINE(立桩量,O,C,0.3,0),COLOR6677FF;
{跌停K线图}
VAR3K:=IF(NAMELIKE('S') OR NAMELIKE('*'),(C-REF(C,1))/REF(C,1)*100<-4.95,
(C-REF(C,1))/REF(C,1)*100<-9.88);
STICKLINE(VAR3K,C,O,3,0),COLOR009900;
STICKLINE(VAR3K,C,O,2.2,0),COLOR00BB00;
STICKLINE(VAR3K,C,O,1.5,0),COLOR00DD00;
STICKLINE(VAR3K,C,O,0.5,0),COLOR00FF00;
A11:EMA(C,17),NODRAW;
A22:SMA(C,17,1),COLORWHITE,LINETHICK2;
彩带倍数:A11/A22,NODRAW;
一号:MA(C,80),COLORGREEN,LINETHICK3;
IF(一号>=REF(一号,1),一号,DRAWNULL),LINETHICK3,COLORRED;
IF(一号>=REF(一号,1) AND REF(一号,1)<REF(一号,2),一号,DRAWNULL),CIRCLEDOT,COLORRED;
二号:MA(C,189),COLORBLUE,LINETHICK3;
IF(二号>=REF(二号,1),二号,DRAWNULL),LINETHICK3,COLORYELLOW;
IF(二号>=REF(二号,1) AND REF(二号,1)<REF(二号,2),二号,DRAWNULL),CIRCLEDOT,COLORYELLOW;
{会心原创-顶底}
AA1:=(C-REF(C,1))/REF(C,1)*100;
AA2:=(C-O)/C*100;
DRAWTEXT(((AA1>3 AND AA2<-5) OR (AA2<-10 AND AA1>-9))
AND BARSCOUNT(2) AND REF(C,1)>REF(O,1) AND V=HHV(V,30),H+0.3,'←【顶】')
,COLORCYAN;
DRAWTEXT((AA2>12 AND BARSCOUNT(2) AND V=HHV(V,30)) OR (AA2>16 AND V<MA(V,3))
,H+0.3,'←【逃】'),COLORGREEN;
BY1:=((AA1>3 AND AA2<-5) OR (AA2<-10 AND AA1>-9)) AND BARSCOUNT(2) AND REF
(C,1)>REF(O,1) AND V=HHV(V,30);
下突破:REF(C,BARSLAST(BY1)),COLORMAGENTA,CROSSDOT,LINETHICK2;
上突破:REF(O,BARSLAST(BY1)),COLORMAGENTA,CROSSDOT,LINETHICK2;
DRAWICON(CROSS(C,上突破) AND REF(EVERY(C<上突破,30),1),H+0.3,13);
DRAWTEXT(CROSS(C,上突破) AND REF(EVERY(C<上突破,30),1),H+0.5,'突破'),COLORYELLOW;
DRAWTEXT(O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND O<MA(C,30) AND C>MA(C,5)
AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,30),L*0.99,'四线合一'),COLORLIGREEN;
DRAWICON(O<MA(C,5) AND O<MA(C,10) AND O<MA(C,20) AND O<MA(C,30) AND C>MA(C,5)
AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,30) AND EXIST(CROSS(MA(C,20),MA(C,30)),3),L*0.98,13);
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=LLV(LOW,5);
VAR3:=HHV(HIGH,5);
VAR4:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,5);
MA1:=MA(VAR4,2);
VAR1Z:=(C+O+L+H)/4;
收:=C-VAR1Z;
XG:=VAR4>50 AND MA1<50 AND O<MA(C,10) AND O<=EMA(C,17) AND C>MA(C,10) AND C>EMA(C,17) AND
EMA(C,17)>SMA(C,17,1) AND SMA(C,17,1)>MA(C,80) AND MA(C,80)>MA(C,189) AND 收>MACD;
STICKLINE(XG,O,C,2.8,0),COLOR335555;
STICKLINE(XG,O,C,2,0),COLOR338888;
STICKLINE(XG,O,C,1.5,0),COLOR33AAAA;
STICKLINE(XG,O,C,1,0),COLOR33CCCC;
STICKLINE(XG,O,C,0,0),COLOR33EEEE;
A10:MA(C,10),LINETHICK2,COLORAA0000;
IF(A10>REF(SMA(A10,3,1),1),A10,DRAWNULL),COLOR0000AA,LINETHICK2;


会心完美
VAR1Z:=(C+O+L+H)/4;
开:O-VAR1Z,NODRAW;
高:H-VAR1Z,NODRAW;
低:L-VAR1Z,NODRAW;
收:C-VAR1Z,NODRAW;
上影线:IF(C>O,高-收,高-开),NODRAW;
下影线:IF(C>O,开-低,收-低),NODRAW;
收开线:IF(C>O,收-开,开-收),NODRAW;
STICKLINE(C>=O,收,开,2,1),COLORLIRED;
STICKLINE(C>=O,高,收,0,1),COLORLIRED;
STICKLINE(C>=O,低,开,0,1),COLORLIRED;
STICKLINE(C<O,收,开,2,1),COLORLIGREEN;
STICKLINE(C<O,高,开,0,1),COLORLIGREEN;
STICKLINE(C<O,低,收,0,1),COLORLIGREEN;
MACD:MACD,NODRAW;
MARD:SMA(MACD,3,1),NODRAW;
IF(MACD>MARD,MACD,DRAWNULL),COLORRED,NODRAW;
STICKLINE(MACD>MARD,MACD,MARD,3,0),COLORRED;
STICKLINE(MACD<MARD,MACD,MARD,3,0),COLORBLUE;
STICKLINE(MACD>MARD AND MACD<0,MACD,MARD,3,0),COLORYELLOW;
K:-MACD,COLORYELLOW;
D:-MARD,COLORWHITE;
倍数:MACD-MARD,NODRAW;
DRAWICON(MACD-MARD>0.1,(MACD+MARD)/2,1);


会心气泡
VAR1Z:=REF(MA(C,20),10);
开:=O-VAR1Z,NODRAW;
高:=H-VAR1Z,NODRAW;
低:=L-VAR1Z,NODRAW;
会心收盘价:C-VAR1Z,NODRAW;
MID:=(3*会心收盘价+低+开+高)/6;
红线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)
+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)
+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,COLORLIRED;
绿线:=MA(红线,6),COLORLIGREEN;
X1:=ABS(红线)/0.9,COLORBROWN;
气泡:IF(红线<=0,X1,DRAWNULL),COLORYELLOW,NODRAW;
中线:IF(红线<0,(X1+红线)/2,DRAWNULL),COLORMAGENTA,DOTLINE;
DRAWBAND(绿线,RGB(0,124,124),红线,RGB(155,96,96));
DRAWKLINE(高,开,低,会心收盘价);
ZP:=红线<=0 AND 气泡>REF(气泡,1);
天数:DRAWNUMBER(ZP,气泡,BARSLAST(REF(红线,1)>0 AND 红线<0)),COLORYELLOW;
ZP1:=红线<=0 AND 气泡<REF(气泡,1);
天数1:DRAWNUMBER(ZP1,气泡,BARSLAST(REF(气泡>REF(气泡,1),1) AND 气泡<REF(气泡,1))),COLORGREEN;


贴紧买优化1
AA := REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),34,1)/SMA(ABS(CLOSE-AA),34,1)*1000;
HHH:=BBB-LLV(BBB,36);
短期:(MA(HHH,2)*3+HHH*13)/16;
中期:MA(HHH,10);
差值:短期-中期,NODRAW;
CCC:=LLV(BBB,36)-BBB;
短期二:(MA(CCC,2)*3+CCC*13)/16;
中期二:MA(CCC,10);
STICKLINE(中期>100,10,-10,2,0),COLORLIGRAY;
STICKLINE(短期>100 AND 中期>100,10,-10,2,0),COLORRED;
STICKLINE(短期>200,10,-10,2,0),COLORYELLOW;
STICKLINE(短期>200 AND 中期>200,10,-10,2,0),COLORMAGENTA;
100,COLORGRAY,DOTLINE;
200,COLORLIGRAY,DOTLINE;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,'转强~灰色'),COLORLIGRAY;
DRAWTEXT_FIX(ISLASTBAR,0.12,0,0,'强势~红色'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.24,0,0,'超强~黄色'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.36,0,0,'顶级强~洋红色'),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,'注意颜色的顺序,如果相反就是转弱'),COLORCYAN;


贴紧买优化2
AA := REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),34,1)/SMA(ABS(CLOSE-AA),34,1)*1000;
HHH:=BBB-LLV(BBB,36);
短期:=(MA(HHH,2)*3+HHH*13)/16;
中期:=MA(HHH,10);
差值:短期-中期,NODRAW;
CCC:=LLV(BBB,36)-BBB;
短期二:=(MA(CCC,2)*3+CCC*13)/16;
中期二:=MA(CCC,10);
VB:=2*(短期-中期),NODRAW;
乖离率6:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
乖离率12:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
乖离率24:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
ZP:=乖离率6<-6 AND 乖离率12<-10 AND 乖离率24<-16;
DRAWICON(ZP,-50,26);
STICKLINE(VB>=0 AND VB>REF(VB,1),0,VB,1,0),COLORRED;
STICKLINE(VB>=0 AND VB<REF(VB,1),0,VB,1,1),COLORRED;
STICKLINE(VB<0 AND 中期>REF(中期,1),0,VB,1,1),COLORRED;
STICKLINE(VB<0 AND VB<REF(VB,1),0,VB,1,0),COLORGREEN;
STICKLINE(VB<0 AND VB>REF(VB,1),0,VB,1,1),COLORGREEN;
STICKLINE(VB<0 AND 中期>REF(中期,1),0,VB,2,-1),COLORRED;
STICKLINE(VB>=0 AND 中期<REF(中期,1),0,VB,2,-1),COLORGREEN;
STICKLINE(短期<3,VB,0,1,0),COLORYELLOW;
准备买:IF(短期<3,8,0),COLORYELLOW,NODRAW;
STICKLINE(短期=0,VB,0,1,0),COLORMAGENTA;
买入:IF(短期=0,8,0),COLORMAGENTA,NODRAW;
DRAWICON(MA(短期,3)=0,VB,1);
加仓:IF(MA(短期,3)=0,8,0),COLORRED,NODRAW;
STICKLINE(差值>60 AND VB>0 AND 中期>50,VB,0,1,0),COLORBLUE;
准备卖:IF(差值>60 AND VB>0 AND 中期>50,4,0),COLORBLUE;
STICKLINE(差值>60 AND VB>0 AND 中期>100,VB,0,1,0),COLORCYAN;
卖出:IF(差值>60 AND VB>0 AND 中期>100,4,0),COLORCYAN;
坚决卖:IF(EVERY(差值>60 AND VB>0 AND 中期>100,2),4,0),COLORGREEN;
DRAWICON(EVERY(差值>60 AND VB>0 AND 中期>100,2),VB,2);
STICKLINE(VB>100,100,VB,1,0),COLORBROWN;
STICKLINE(VB>200,200,VB,1,0),COLORLIRED;
100,DOTLINE,COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,'准备买~黄色'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.12,0,0,'买入~洋红色'),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.24,0,0,'加仓~红箭头'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.36,0,0,'准备卖~蓝色'),COLORBLUE;
DRAWTEXT_FIX(ISLASTBAR,0.48,0,0,'卖出~青色'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.60,0,0,'坚决卖~绿箭头'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,'{红色柱~买入}'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.24,0,'{绿色柱~卖出}'),COLORGREEN;

会心个股分时主图
大单买量:=SUM(IF(C>REF(C,1) AND V>4000,V/1000,0),0),NODRAW;
大单卖量:=SUM(IF(C<REF(C,1) AND V>4000,V/1000,0),0),NODRAW;
买单总量:=SUM(IF(C>REF(C,1),V/1000,0),0),NODRAW;
卖单总量:=SUM(IF(C<REF(C,1),V/1000,0),0),NODRAW;
小单买量:=买单总量-大单买量,NODRAW;
小单卖量:=卖单总量-大单卖量,NODRAW;
DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));
大宗进:=大单买量,NODRAW;
大宗出:=大单卖量,NODRAW;
非大宗进:=小单买量,NODRAW;
非大宗出:=小单卖量,NODRAW;
主力净流入:=大单买量-大单卖量,COLORRED,NODRAW;
散户净流入:=小单买量-小单卖量,COLORRED,NODRAW;
净流入:=买单总量-卖单总量,COLORRED,NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(0,255,0)));
DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(0,255,0),RGB(255,0,0)));
DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(150,0,0),RGB(0,150,150)));
DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(0,150,150),RGB(150,0,0)));
DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(255,255,0),RGB(23,125,255)));
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;
地:EMA(均价,50)/0.97,LINETHICK2,COLORGREEN;
IF(地>REF(地,1),地,DRAWNULL),COLORRED,LINETHICK2;
平衡线:(均价+地)/2,DOTLINE,COLORGRAY;
买单次数:=COUNT(V>4000 AND C>REF(C,1),0);
黄次数:COUNT(V>DYNAINFO(16)*10 AND C>REF(C,1),0),COLORYELLOW,NODRAW;
DRAWICON(买单次数>REF(买单次数,1) AND 黄次数>REF(黄次数,1) AND CROSS(C,地),C,7);
DRAWICON(小单买量>小单卖量 AND 大单买量>小单买量 AND 小单卖量>大单卖量,均价,38);
SUM(V*C,0)/SUM(V,0),COLORYELLOW;
C,COLORWHITE;


会心大盘分时主图
大单买量:=SUM(IF(C>REF(C,1) AND V>100000,V/1000,0),0),NODRAW;
大单卖量:=SUM(IF(C<REF(C,1) AND V>100000,V/1000,0),0),NODRAW;
买单总量:=SUM(IF(C>REF(C,1),V/1000,0),0),NODRAW;
卖单总量:=SUM(IF(C<REF(C,1),V/1000,0),0),NODRAW;
小单买量:=买单总量-大单买量,NODRAW;
小单卖量:=卖单总量-大单卖量,NODRAW;
DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));
大宗进:=大单买量,NODRAW;
大宗出:=大单卖量,NODRAW;
非大宗进:=小单买量,NODRAW;
非大宗出:=小单卖量,NODRAW;
主力净流入:=大单买量-大单卖量,COLORRED,NODRAW;
散户净流入:=小单买量-小单卖量,COLORRED,NODRAW;
净流入:=买单总量-卖单总量,COLORRED,NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(0,255,0)));
DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(0,255,0),RGB(255,0,0)));
DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(150,0,0),RGB(0,150,150)));
DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(0,150,150),RGB(150,0,0)));
DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(255,255,0),RGB(23,125,255)));
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;
地:EMA(均价,50)/0.99,LINETHICK2,COLORGREEN;
IF(地>REF(地,1),地,DRAWNULL),COLORRED,LINETHICK2;
平衡线:(均价+地)/2,DOTLINE,COLORGRAY;
买单次数:=COUNT(V>100000 AND C>REF(C,1),0);
黄次数:COUNT(V>DYNAINFO(16)*10 AND C>REF(C,1),0),COLORYELLOW,NODRAW;
DRAWICON(买单次数>REF(买单次数,1) AND 黄次数>REF(黄次数,1) AND CROSS(C,地),C,7);
DRAWICON(小单买量>小单卖量 AND 大单买量>小单买量 AND 小单卖量>大单卖量,均价,38);
SUM(V*C,0)/SUM(V,0),COLORYELLOW;
C,COLORWHITE;

会心个股资金博弈
大单买:SUM(IF(C>REF(C,1) AND V>4000,V/1000,0),0),COLORRED,LINETHICK3;
大单卖:SUM(IF(C<REF(C,1) AND V>4000,V/1000,0),0),COLORGREEN,LINETHICK3;
买单总:=SUM(IF(C>REF(C,1),V/1000,0),0);
卖单总:=SUM(IF(C<REF(C,1),V/1000,0),0);
小单买:买单总-大单买,COLORLIRED;
小单卖:卖单总-大单卖,COLORLIBLUE;
0,COLORGRAY,LINETHICK3;

会心大盘资金博弈
大单买:SUM(IF(C>REF(C,1) AND V>100000,V/1000,0),0),COLORRED,LINETHICK3;
大单卖:SUM(IF(C<REF(C,1) AND V>100000,V/1000,0),0),COLORGREEN,LINETHICK3;
买单总:=SUM(IF(C>REF(C,1),V/1000,0),0);
卖单总:=SUM(IF(C<REF(C,1),V/1000,0),0);
小单买:买单总-大单买,COLORLIRED;
小单卖:卖单总-大单卖,COLORLIBLUE;
0,COLORGRAY,LINETHICK3;

通达信会心整套原创指标



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
公式指标网-www.gszx.com.cn-股票指标公式网