股票公式指标网-网站导航


网站搜索:  

股旁网 发表于2012/11/12 8:04:14

飞狐张氏组合副图源码

飞狐张氏组合副图源码

认真看看均线.波段.买卖.主要讲讲买卖的未来.请看看图.未来是指标的极品.大家都想做(先知先觉)未来就能做到.它的上下信号出现可以在消失.但它己告诉你上下的趋势现在己进入终结.必须耐心等待下次信号的出现.各种周期会出现不同的提示如图.这就是未来的妙用.使用未来吧.个人观点

张氏均线

MA1:eMA(CLOSE,30);
MA2:eMA(CLOSE,60);
MA3:eMA(CLOSE,120);
MA4:eMA(CLOSE,240);

张氏波段

VARA:=LLV(LOW,35);
VARB:=HHV(HIGH,30);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;
QS:= VARC,COLORWHITE;
STICKLINE(VARC<10 && 100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))>97,0,25,3,0),COLORYELLOW;
STICKLINE(VARC>90,100,85,3,0),COLORRED;
VARD:=87.5;
VARE:=(VARC-LLV(VARC,4))/(HHV(VARC,4)-LLV(VARC,4))*4*25;
一:=CROSS(QS,VARD) AND VARE=100;
二:=CROSS(VARD,QS);
三:=CROSS(QS,VARE) AND QS>87;
DRAWTEXT(一,56,'目标');
DRAWTEXT(二,85,'跑');
DRAWTEXT(三,70,'卖');
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR8:=LLV(LOW,30);
VARAA:=HHV(HIGH,30);
B:=EMA((VAR6-VAR8)/(VARAA-VAR8)*100,8);
B1:=EMA(B,5);
STICKLINE(B>0 && B-B1>=0,79,80,3,0),COLORWHITE;
STICKLINE(B>0 && B-B1<0,79,80,3,0),COLORCYAN;
STICKLINE(B>0 && B-B1>=0,49,50,3,0),COLORRED;
STICKLINE(B>0 && B-B1<0,49,50,3,0),COLORRED;
STICKLINE(B>0 && B-B1>=0,19,20,3,0),COLORWHITE;
STICKLINE(B>0 && B-B1<0,19,20,3,0),COLORCYAN;
STICKLINE(B-B1>0,B,B1,3,1),COLORRED;
STICKLINE(B-B1<0,B,B1,3,1),COLORWHITE;

张氏买卖

VAR3:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;
VAR4:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;
VAR5:=(CLOSE-MA(CLOSE,0))/MA(CLOSE,0)*100;
VAR6:=(VAR3+VAR4+VAR5)/3;
VAR7:=EMA(VAR6,5);
ZHIB: EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VAR8:=IF(VAR6<=-20,10,0);
VAR9:=HHV(VAR8,10);
STICKLINE(VAR8=10,20,10,3,0),COLORRED;
VARA:=IF(VAR9 && CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:EMA(VAR7,5)*2,COLORGREEN;
D:EMA(K,5), COLORWHITE;
J:K*3-D*2, COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) && J>10;
DRAWTEXT(VARA=20,15,'底部');
STICKLINE((VARA=20),0,10,3,0),COLORWHITE;
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) && (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) && (REF(ZIG
(3,5),2)<=REF(ZIG(3,5),3));
VARD:=(ZIG(3,5)<REF(ZIG(3,5),1)) && (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) && (REF(ZIG
(3,5),2)>=REF(ZIG(3,5),3));
STICKLINE((VARC=1),(-14),0,3,0),COLORMAGENTA;
DRAWTEXT((VARC=1),(-14),'买');
STICKLINE((VARD=1),14,0,3,0),COLORGREEN;
DRAWTEXT((VARD=1),18,'卖');
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) && VOL>REF(VOL,1) && CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR11 && COUNT(VAR11,30)=1,15,'大资金活动');
STICKLINE(VAR11 && COUNT(VAR11,30)=1,1,10,3,0),COLORCYAN;
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 && VAR13<200 && VAR14>=150 && VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 && VAR13>-200 && VAR14<=-150 && VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 && VAR13>=150,15,IF(VAR14<=-200 && VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 && VAR1B>60 && VAR19<100;
DRAWTEXT(VAR1C && COUNT(VAR1C,30)=1,15,'大笔出货');
STICKLINE(VAR1C && COUNT(VAR1C,30)=1,0,10,3,0),COLORYELLOW;

飞狐张氏组合副图源码



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网