股票公式指标网-网站导航


网站搜索:  

股旁网 发表于2012/11/10 0:29:35

飞狐我用过多年支撑压力指标

飞狐我用过多年支撑压力指标

input:n1(14),n(3);
 LC := REF(CLOSE,1);
 RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
 ty:=rsi1;
 A1:=REF(ty,N)=HHV(ty,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高}
 A2:=REF(ty,N)=LLV(ty,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低}
 H1:=(D1 AND NOT(D2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
 L1:=(D2 AND NOT(D1));  H2:=D1 AND NOT(D2);
 X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
 G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
 L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
 X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
 G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
 R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
 T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
 R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
 T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
 T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
 T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
 R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
 R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
 压一:dRAWLINE(S2,ty,S1,ty,1),Color80FFFF; {★压力1:}        
 撑一:dRAWLINE(U2,ty,U1,ty,1),POINTDOT,Color00FFFF,linethick2;{★支撑1:}
 压二:dRAWLINE(S3,ty,S2,ty,1),ColorFF8000; {★压力2:}
 撑二:DRAWLINE(U3,ty,U2,ty,1),POINTDOT,ColorFF8000;{★支撑2:}        
 压三:DRAWLINE(S4,ty,S3,ty,1),Color0000FF;{★压力3:}
 撑三:DRAWLINE(U4,ty,U3,ty,1),POINTDOT,Color0000FF;{★支撑3:};
 QS:=HHV(RSI1,13);
 RS:=llV(RSI1,13);
 Var1:=BACKSET(REF(QS,2)=HHV(QS,5),3);
 Var2:=CROSS(Var1,0.9);
Var3:=BACKSET(REF(RS,2)=LLV(RS,5),3);
 Var4:=CROSS(Var3,0.9);
压力:REF(QS,BARSLAST(Var2)),POINTDOT,Color00ff00;
 STICKLINE(RSI1,REF(QS,BARSLAST(Var2)),REF(QS,BARSLAST(Var2)),5,0),Color00ff00;
 支撑:REF(RS,BARSLAST(Var4)),POINTDOT,Color0087FF;
 STICKLINE(RSI1,REF(RS,BARSLAST(Var4)),REF(RS,BARSLAST(Var4)),5,0),Color0087FF;

飞狐我用过多年支撑压力指标

 



网站搜索:  



Copyright © 2009-2010 gszb.com ™,All Rights Reserved. 
股票公式指标网-www.gszx.com.cn-股票指标公式网