当前位置:→ 公式网 > 其他公式 > 指南针公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是指南针神秘波段系列源码(无源码的请下载附件导入)

神秘波段系列 :
dy_多空博弈
ssl:=ema(c,3);
ssl,colorgreen;
mm:ema((slope(c,22)*20+c),55),colorwhite;
stickline(ssl>mm,ssl,mm,1,0),colormagenta;
stickline(ssl<=mm,ssl,mm,1,0),colorgreen;
stickline(c>=o,c,o,8,0),colorred;
stickline(c>=o,h,l,0,0),colorred;
stickline(c<=o,c,o,8,0),colorgreen;
stickline(c<=o,h,l,0,0),colorgreen;

dy_辅成交量
mid:=(high+low+close)/3;
cr26:=sum(max(0,high-ref(mid,1)),26)/sum(max(0,ref(mid,1)-l),26)*100;
chiu:=sma(cr26,25,1);
chiu1:=ema(cr26,5);
chiu2:=ema(cr26,10);
chiu1,colorred;
chiu,coloryellow;
chiu2,colorwhite;
stickline(chiu1>0,chiu1,0,5,0),colorred;

dy_辅助判市
b53:=(ma(close,9)-ref(ma(close,9),1))/ref(ma(close,9),1)*100;
jx:=atan(b53)/3.1416*180;
dysmk1:=sma(jx,10,1);
dysmd1:=sma(dysmk1,5,1);
dysmd:dysmd1,colorgreen;
dysmk:dysmk1,coloryellow;
stickline(dysmk>dysmd,dysmk,dysmd,2,0),colorred;
stickline(dysmk<=dysmd,dysmk,dysmd,2,0),colorgreen;
20;
-20;


dy_神密波段
kav:=(2*close+high+low)/4;
ak:=ema((kav-llv(low,34))/(hhv(high,34)-llv(low,34))*100,34);
dd:=ema(0.667*ref(ak,1)+0.333*ak,5);
mk:=ema((kav-llv(low,34))/(hhv(high,34)-llv(low,34))*100,5);
nk:=ema(mk,5);
nk,colorgreen;
dd,colorwhite;
ak,coloryellow;
stickline(mk>nk,mk,nk,5,0),colorred;
stickline(mk<=nk,mk,nk,5,0),colorgreen;
13;
35;
79;

==================================================
屠龙宝刀系列:
lm_屠龙宝刀
(虎线)短期线:ema((winner(close)*"lfsolfs")*("cycocyc13"/ma(c,13)),5),coloryellow;
(基准)中期线:ema((winner(close)*"lfsolfs")*("cycocyc13"/ma(c,13)),13),colorred;
(龙线)后续线:ema(("cycocyc13"/ma(c,13))*winner(close)*(100-"lfsolfs"),5),colormagenta;

lm_歼击机
a:=ema(("cycocyc13"/ma(c,13))*winner(close)*(100-"lfsolfs"),5);
龙线增长率7:=(a-ref(a,7))/ref(a,7);
龙线增长率7,pointdot;
stickline(龙线增长率7>0,龙线增长率7,0,6,0),colorred;
stickline(龙线增长率7<=0,龙线增长率7,0,6,0),coloryellow;

lm_量价平衡
价:ema((winner(close)-llv(winner(close),60))/(hhv(winner(close),60)-llv(winner(close),60))*100,1),coloryellow;
量:ema(("lfsolfs"-llv("lfsolfs",21))/(hhv("lfsolfs",21)-llv("lfsolfs",21))*100,1),colorred;

lm_龙线增长
a:=ema(("cycocyc13"/ma(c,13))*winner(close)*(100-"lfsolfs"),5);
龙线增长率(5):(a-ref(a,5))/ref(a,5),coloryellow;
龙线增长率(3):(a-ref(a,3))/ref(a,3),colorred;
龙线增长率(13):(a-ref(a,13))/ref(a,13),colorblue;

lm_倚天剑
a:=ema(("cycocyc13"/ma(c,13))*winner(close)*(100-"lfsolfs"),5);
龙线增长率5:=(a-ref(a,5))/ref(a,5);
龙线增长率3:=(a-ref(a,3))/ref(a,3);
龙线增长率7:=(a-ref(a,7))/ref(a,7);
龙线增长率7,coloryellow;
龙线增长率3,color0099ff;
龙线增长率5,colorwhite;

tn_印款机
短:=ema((winner(close)*"lfsolfs")*("cycocyc13"/ma(c,13)),5);
中:=ema((winner(close)*"lfsolfs")*("cycocyc13"/ma(c,13)),13);
后:=ema(("cycocyc13"/ma(c,13))*winner(close)*(100-"lfsolfs"),5);
买入:cross(后,中) and cross(后,短),stick,colormagenta;
卖出:后<ref(后,1) and 后>短 and 后>中,stick,colorcyan;
stickline(买入>0,1,0,5,0),colormagenta;
stickline(卖出>0,1,0,5,0),colorcyan;
============================================
战无不胜系列:

z出手就赢
dy11:=(2*close+high+low)/4;
dy22:=llv(low,34);
dy33:=hhv(high,34);
a11:=ema((dy11-dy22)/(dy33-dy22)*100,9);
b11:=ema((0.667*ref(a11,1)+0.333*a11),2);
dya:=ema((dy11-dy22)/(dy33-dy22)*100,30);
dyb:=ema(dya,5);
stickline(dyb>=a11,dyb,a11,6,0),coloryellow;
stickline(dyb>=a11,b11,dya,0,0),coloryellow;
stickline(dyb<=a11,dyb,a11,6,0),colorred;
stickline(dyb<=a11,b11,dya,0,0),colorred;

z大势乾坤
乾:winner(c)*100,colorred;
坤:100*(winner(1.08*c)-winner(0.92*c)),color339933;

z飞越巅峰
生命线:0,colorwhite;
散户:=sma((((hhv(h,9)-c)/(hhv(h,9)-llv(l,9))*200)-125),9,1);
a:=((c-llv(l,9))/(hhv(h,9)-llv(l,9))*200)-105;
b:=sma(a,3,1);
主力:sma(b,3,1),coloryellow;

z海底捕金
var1:=amount/vol/100;
var2:=(3*high+low+open+2*close)/7;
var3:=sum(amount,5)/var1/100;
dcyc:=dma(var2,(-1)*vol/var3);
上天揽月:(close-dcyc)/dcyc*100,coloryellow;
下海捉鳖:(1-winner(c))*100,color339933;

z金山银山(主图叠加)
diff:=ema(close,12)-ema(close,26);
dea:=ema(diff,9);
ma(c,8),colorwhite;
ma(c,21),coloryellow;
多头:stickline(diff>dea,c,o,8,0),colorred;
stickline(diff>dea,h,l,0,0),colorred;
空头:stickline(diff<=dea,c,o,8,0),colorcyan;
stickline(diff<=dea,h,l,0,0),colorcyan;
drawtext(cross(diff,dea),l-0.2,'买入'),colorwhite;
drawtext(cross(dea,diff),h+0.2,'卖出'),colorgreen;

z战无不胜
危机线:85,colorred;
中间线:50,colorwhite;
安全线:15,colorgreen;
v1:=(2*close+high+low)/4;
v2:=llv(low,34);
va:=hhv(high,34);
防线b:=ema((v1-v2)/(va-v2)*100,13);
防线bb:=ema((0.667*ref(防线b,1)+0.333*防线b),2);
战术线:防线b,coloryellow,pointdot;
战略线:ema(0.382*ref(防线b,2)+0.618*防线b,12),coloryellow;
stickline(防线b>防线bb,防线b,防线bb,6,0),colorred;
stickline(防线b<=防线bb,防线b,防线bb,6,0),colorcyan;

z直上云宵
穿云:winner(c)*100,colorred;
破雾:100*(winner(1.1*c)-winner(0.9*c)),color339933;

z走向辉煌
var1:=amount/vol/100;
var2:=(3*high+low+open+2*close)/7;
var3:=sum(amount,3)/var1/100;
var4:=sum(amount,10)/var1/100;
cyc3:=dma(var2,vol/var3);
cyc10:=dma(var2,vol/var4);
cyc10,coloryellow;
stickline(cyc3>cyc10,cyc3,cyc10,6,0),colorred;
stickline(cyc3<=cyc10,cyc3,cyc10,6,0),colorgreen;

F全盘穿越}
套牢盘:100*(1-WINNER(C)),colorgreen;
vr1:=BARSLAST(cross(90,套牢盘));
穿越天数:vr1,,LINETHICK0;
drawicon(cross(10,套牢盘),6,12),;
a1:=sum(VOL,13)/CAPITAL;
cyf:100-(100/(1+a1)),colorred,linethick2;
a2:=AMOUNT/(100*vol);
中线成本均线:=ma(a2,13);
cys:100*(c-中线成本均线)/中线成本均线+50,coloryellow,;
stickline(cys>50,50,cys,4,0),coloryellow,;
stickline(cys<50,50,cys,4,0),colorf0f000,;
10,colorccff66;
20,colorwhite;
90,colorccff66;

=======================
遍地黄金V4.0
=======================
__ZBT
_COMM
_PAR
_VAR
_ZB CYS, 短期控盘移动平均, 短期主力控盘指标, CYS∞, 博弈K线长, CYB牛, CYR13, 换手率, CYC5, CYC∞, 流通盘
_LOCAL
_RES ZW_DIN, ZW_IN, ZW_LOOK, ZW_OUT, ZW_XIN, ZW_KEEP
_DEF 0.000
_CODE
IF (CYS(8)>0)&(REF(CYS(8),1)<0)
THEN ZW_DIN=8;
ENDIF;
IF (CYS∞>28)&
(短期主力控盘指标<短期控盘移动平均)&
(REF(短期主力控盘指标,1)>REF(短期控盘移动平均,1))
THEN ZW_OUT=4;
ENDIF;
IF (CYS(8)<0)&(REF(CYS(8),1)<0)
THEN ZW_LOOK=4;
ENDIF;
IF (CYS(8)>0)&(REF(CYS(8),1)>0)&(CYS∞<28)
THEN ZW_IN=8;
ENDIF;
IF (CYS(8)>0)&(REF(CYS(8),1)>0)&(CYS∞>28)&(短期主力控盘指标>短期控盘移动平均)
THEN ZW_IN=8;
ENDIF;
IF (CYS∞>28)&(CYS(8)>0)&
(短期主力控盘指标<短期控盘移动平均)&
(REF(短期主力控盘指标,1)<REF(短期控盘移动平均,1))
THEN ZW_KEEP=4;
ENDIF;
IF (S0(CYR13)>1)&(REF(S0(CYR13),1)<1)&(S0(换手率)<4)&(S0(CYC5)>S0(CYC∞))&(CYB牛<15)
THEN ZW_XIN=8;
ENDIF;


__END
===================================
0amv原码
===================================
Var1:=移动平均(成交额,10,1)/1000000;
Var2:=向前引用(Var1,1);
Var3:=简单移动平均(向前引用(收盘价,1),5);
收盘:Var1*收盘价/Var3*1/10,COLOR009900,LINETHICK0,点状线;
开盘:Var1*开盘价/Var3*1/10,点状线,COLOR009900,LINETHICK0;
最高:Var1*最高价/Var3*1/10,点状线,COLOR009900,LINETHICK0;
最低:Var1*最低价/Var3*1/10,点状线,COLOR009900,LINETHICK0;
生命线:指数平滑移动平均(收盘,12),COLORCYAN;
昨收盘:=向前引用(收盘,1),点状线,COLOR009900,LINETHICK0;
涨跌:=(收盘-向前引用(收盘,1))/向前引用(收盘,1)*100,点状线,COLOR009900,LINETHICK0;
画柱线(收盘>开盘,收盘,开盘,5,0),COLORRED;
画柱线(收盘>开盘,最高,最大值(收盘,开盘),0,1),COLORRED;
画柱线(收盘>开盘,最小值(收盘,开盘),最低,0,1),COLORRED;
画柱线(收盘<开盘,收盘,开盘,5,0),COLORGREEN;
画柱线(收盘<开盘,最高,最大值(收盘,开盘),0,1),COLORGREEN;
画柱线(收盘<开盘,最小值(收盘,开盘),最低,0,1),COLORGREEN;

本文仅提供源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识