当前位置:→ 公式网 > 同花顺公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是同花顺买卖加仓减仓主图指标公式源码(无源码的请下载附件导入)

买卖加仓减仓同花顺主图指标
 

指标上面两条黄线分别为短期和中期的压力线,出现红柱为持股信号,出现蓝柱是持币信号。另外还带了加仓和减仓提示。趋势向上效果佳。
使用时请结合其他技术指标、成交量、大盘走势等多因素进行综合判断。
顶压:HHV(MA(H,11),50),Color00FFFF;
短压:HHV(MA(H,11),15),Color0090E0;
XL1:=LLV(MA(H,11),1);
趋势:IF(XL1>=短压,短压,XL1),ColorFFFFFF;
x1:=(3*C+H+L+O)/6;
x2:=EMA(x1,10);
x3:=REF(x2,1);
x4:=(REF(HIGH,1)+REF(LOW,1))/2;
x5:=MA(CLOSE,21)+2*STD(CLOSE,21);
x6:=REF(CLOSE,1);
x7:=SMA(MAX(CLOSE-x6,0),7,1)/SMA(ABS(CLOSE-x6),7,1)*100;
x8:=CROSS(79,x7);
x9:=FILTER(x8,4);
WZ1:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
WZ2:=POW(MA(LOW,5),2)+MA(LOW,5);
WZ3:=POW(MA(HIGH,5),2)+MA(HIGH,5);
WZ4:=(WZ1-LLV(WZ2,9))/(HHV(WZ3,9)-LLV(WZ2,9))*150+65;
Dk:=SMA(WZ4,3,1)*1.5;
DD:=SMA(Dk,3,1);
DJ:=3*Dk-2*DD;
WZ5:= EMA(CLOSE,12) - EMA(CLOSE,26);
WZ6:= EMA(WZ5,9);
WZ7:= 2*(WZ5-WZ6);
WZ8:= REF(WZ7,1);
WZ9:= CROSS(WZ8,WZ7) AND WZ8>0;
DRAWTEXT(WZ9 AND dj>250,H,'←减'),ColorBCFF8B;
var11:=EMA(CLOSE,8);
var2:=EMA(var11,20);
var3:=CROSS(var11,var2);
var4:=var11<MA(CLOSE,120);
var5:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
var6:=SMA(var5,5,1);
var7:=SMA(var6,8,1);
var8:=CROSS(var6,var7) AND var7<20;
var9:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND var8;
varA:=IF(CLOSE>1000,var8,var9);
起步:= var3 AND var4;
逃遁:= varA;
STICKLINE(x2>x3,x2*0.98,x2,6,1),Color0000FF;
STICKLINE(x2<x3,x2*0.98,x2,6,1),ColorF10011;
Ww1:= SUM( MA(C,10),9)/10.110;
Xx1:=MA(LOW,2)*0.96;
Xx2:=MA(LOW,26)*0.85;
Xx3:= REF(Xx1,1)<Xx2 AND REF(Xx1,1)<Xx1 AND REF(Xx1,1)<REF(Xx1,2);
var1:=INDEXC;
var12:=MA(var1,6);
var13:=MA(var1,24);
var14:=MA(var1,32);
var15:=MA(var1,62);
var16:=MA(var1,105);
var17:=var15<REF(var15,1) AND var6<REF(var16,1) AND var15<var6*0.98;
var18:=var14>var12*1.11 AND var13>var12*1.095;
var19:=var12>var1*0.95;
var111:=EMA(WINNER(CLOSE)*70,3);
var112:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
var113:=CLOSE/MA(CLOSE,40)*100<76;
var114:=CLOSE/MA(CLOSE,60)*100<74;
var115:=HIGH>LOW*1.051;
var116:=var115 AND COUNT(var15,5)>1;
var117:=var17 AND var8 AND var19 AND CLOSE/COST(8)<=0.8
AND (CLOSE>OPEN OR CLOSE<OPEN)
AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1))
AND CLOSE>0.1 OR var16
AND (var113 OR var114) AND var112<20 AND var111<20
AND (WINNER(CLOSE*125/100)-WINNER(CLOSE))*100<7.5 OR
TROUGHBARS(3,15,1)<4 AND CROSS(EMA(CLOSE,21)-EMA(CLOSE,8),
EMA(EMA(CLOSE,21)-EMA(CLOSE,8),5));
XL11:=EMA(CLOSE,10)/100;
XL2:= MA((XL11-REF(XL11,10))/REF(XL11,10),3)*100;
XL3:= MA(XL2,3);
XL4:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);
DRAWTEXT(IF(CROSS(3*XL4-2*SMA(XL4,3,1),8),87,0)
AND x2>x3,L-0.1,'←●反弹'),colorgreen;
DRAWTEXT(IF(CROSS((var11-LLV(var1,4))/(HHV(var11,4)-LLV
(var11,4))*4*25,87.5) AND
var1<40,87,0) AND x2>x3,L-0.2,'←●短买'),ColorFFBBD8;
DRAWTEXT(CROSS(var1,10) AND x2>x3,L-0.3,'←●买'),Color89B2FF;
DRAWTEXT(IF(CROSS(2*(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA
((CLOSE*2+HIGH+LOW)/4,26)-EMA(EMA((CLOSE*2+HIGH+LOW)/
4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26),2))*5.8,0.47),LOW,0)
AND x2>x3,L-0.4,'←●加仓'),ColorFF5ED8;
Ll1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
Ll2:=EMA(Ll1,9);
Ll3:=BARSLAST(CROSS(Ll1,Ll2));
Ll4:=REF(Ll3,Ll3+1);
Ll5:=Ll2<REF(Ll2,Ll4);
变盘:=CROSS(Ll1,Ll2) AND Ll5;
DRAWTEXT(起步>0,L,'★起步?'),Color00FF00;
STICKLINE(起步>0,C*1.05,C,7,0),colorred;
DRAWTEXT(逃遁>0,H*1.04,'●←逃'),Color7FFFD6;

 


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识