当前位置:→ 公式网 > 同花顺公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是同花顺启动拉升副图指标有用法说明(无源码的请下载附件导入)

启动拉升

 
在牛市中,黄柱出现,短期买点,也意味着中线行情启动,不怕回调,大胆买入;
绿柱出现,主力拉升,不怕回调,大胆买入。
其他买点,除了macd本身买卖判断以外,添加了早晨之星,单针探底,底背离顶背离,黄昏之星和乌云盖顶等买卖提示。
在熊市中,一般不出现黄和绿色柱子,即便出现大概率是高点,买进成功率低,要想在熊市中用好盖指标,需要将量比指标范围调低。
添加了缩量涨停短线指标和搓揉指标短线买点。
做了大量的测试,做了多次修改,信号少但很准确。
ZF5:=C/REF(C,5)<=1.3;"这是5日涨幅小于30%";
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
短线:=SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21);
中线:=SMA(RSV2,5,1)+2*STD(CLOSE,37);
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
长线:=SMA(RSV3,5,1);
金坑:=短线<20 AND 中线<20 AND 长线<20,colorwhite,nodraw;
STICKLINE(金坑>0 AND 金坑>=REF(金坑,1),0,金坑,1,0),colorwhite;
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26),colorwhite;
DEA : EMA(DIFF,9),coloryellow;
MACD:2*(DIFF-DEA),nodraw;
Zero := 0;
gj:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,1,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1,0),color00ff00;
m5:=EMA(C,5);
m10:=EMA(C,10);
m20:=EMA(C,20);
zf:=(H-L)/REF(C,1)*100;
v1:=C>m5 AND m5>m10 AND m10>m20 AND C>REF(C,1) AND m5>REF(m5,1)
AND m10>REF(m10,1) AND m20>REF(m20,1) AND C/O>1.03 AND (H-C)/C<0.02;
v2:=V>REF(V,1)*1.3 ;
V3:=V/REF(MA(V,5),1)*2>=4;
V4:=V/REF(MA(V,5),1)*2<=15;
大60度且5日线:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14159>60;
开始拉升:=zf>10 AND v1 AND v2 AND V3 AND 大60度且5日线 AND V4 AND ZF5,colorgreen,nodraw;
STICKLINE(开始拉升>0 AND 开始拉升>=REF(开始拉升,1),0,开始拉升,8,0),colorgreen;
DRAWTEXT(开始拉升,1.3,"将要拉升"),colorgreen;
DRAWICON(开始拉升,DEA,1);
AAA1:=(DIFF-DEA)*2*60;
短线宝:=CROSS(AAA1-REF(AAA1,1),7) AND DIFF>=DEA AND 大60度且5日线 AND V/REF(MA(V,5),1)*2>=6 AND V4 AND ZF5,coloryellow,nodraw;
STICKLINE(短线宝>0 AND 短线宝>=REF(短线宝,1),0,短线宝,8,0),coloryellow;
DRAWTEXT(短线宝,1.3,"短线买中线将启动"),coloryellow;
DRAWICON(短线宝,DEA,1);
DD:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
顶背:=(DD AND EE AND DEA< HHV(DEA,180))*DEA,STICK,nodraw,coloryellow;;
DRAWICON(顶背,DEA,2);
FF:=C=LLV(C,180);
GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
底背:=(FF AND GG AND DEA> LLV(DEA,180))*DEA,STICK,nodraw,coloryellow;;
DRAWICON(底背,DEA,1);
五日总涨幅:=SUM((C-REF(C,1))/REF(C,1)*100,5)<1;
下影线:=(H-L)/L*100>5 AND (MIN(O,C)-L)/L*100>5;
针底:五日总涨幅 AND 下影线 AND DIFF>=DEA,nodraw,coloryellow;;
DRAWICON(针底,DEA,1);
晨星:REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2),nodraw,coloryellow;;
DRAWICON(晨星,DEA,1 );
STICKLINE(晨星>0 AND 晨星>=REF(晨星,1),0,晨星,8,),coloryellow;
昏星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2),nodraw,colorblue;
DRAWICON(昏星,DEA,2);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND
CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR
(REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND
CLOSE>REF(OPEN,1) AND
OPEN<REF(CLOSE,1));
买:=(穿头破脚 AND  CLOSE>OPEN AND CLOSE>0);
DRAWICON(买,DEA,1);
卖:=(穿头破脚 AND CLOSE<OPEN);
DRAWICON( 卖,DEA,2),colorblue;
揉搓:REF(V,1)>REF(V,2)*2 AND REF(C,1)>REF(O,1) AND REF(H,1)-REF(C,1)>(REF(C,1)-REF(L,1))
AND MIN(C,O)-L>(H-MIN(C,O)),nodraw,colormagenta;
STICKLINE(揉搓>0 AND 揉搓>=REF(揉搓,1),0,揉搓,8,0),colormagenta;
搓揉2:=(REF(H,1)-MAX(REF(C,1),REF(O,1)))/(REF(H,1)-REF(L,1))>0.7 AND (MIN(O,C)-L)/(H-L)>0.7;
STICKLINE(搓揉2>0 AND 搓揉2>=REF(搓揉2,1),0,搓揉2,8,0),colorlimagenta;
DRAWICON(搓揉2,DEA,1);
DRAWICON(揉搓,DEA,1);
AA:=CLOSE/REF(CLOSE,1)>=1.09;
AB:=VOL/REF(VOL,1);
缩停:AA AND AB<1 AND CLOSE>OPEN,colorgreen,nodraw;
STICKLINE(缩停>0 AND 缩停>=REF(缩停,1),0,缩停,8,0),colorgreen;
DRAWICON(缩停,DEA,1);
AA:=(O+H+L+C)/4;
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A3:=A1-A2;
A4:=EMA((AA-A2)/A3,2)*9;
RSV:= (HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*10;
空:=SMA(RSV,2,1)/5;
多:=A4;
STICKLINE(空>1.3 AND 多<0.3 AND C*0.02<(EMA(C,5)-C),0,ABS(SMA(MAX(MACD,0),5,1)-ABS(MACD))*0.5,8,0),colorwhite;
建仓区:=0,colorwhite;
a:=CROSS(MA(V,5),MA(V,35));
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
b:=CROSS(MA(C,5),MA(C,10));
xg:=a AND b AND dif >=0 AND CROSS(dif,dea);
STICKLINE(xg>0,0,xg,4),colorgreen;
DRAWICON(xg,DEA,1);
EMA18:=MA(C,18);
中线【买入】:=COUNT(CLOSE<EMA18,5)=4 AND
CLOSE/EMA18>1.004 AND CROSS(CLOSE,EMA18) AND EMA18>=
REF(EMA18,1) AND MACD>-0.4 AND diff<0.15;
DRAWICON(中线【买入】,DEA,1);
STICKLINE(中线【买入】>0,0,中线【买入】,4),colorgreen;
量比大于二点五:=V/REF(MA(V,5),1)>=2;
涨幅小于四:=(C-REF(C,1))/REF(C,1)*100<4;
流通盘小于三亿:=SHGZG/100000000<20 ;
换手率:=VOL/CAPITAL*100;
五日换手率小于三:=MA(换手率,5)<=3;
竞价后选股:=量比大于二点五 AND 涨幅小于四 AND 流通盘小于三亿 AND 五日换手率小于三 AND CLOSE>OPEN;
DRAWICON(竞价后选股,DEA,1);
散户: =SMA(HIGH,21,2)*1.05,colorwhite;
主力: =SMA(CLOSE,2,1),colorgreen;
能量:=2*(主力-散户),nodraw;
Zero := 0;//公式平台,公式指标和源码
STICKLINE(能量>0 AND 能量>=REF(能量,1),0,能量,8,0),color0000ff,linethick3;
STICKLINE(能量>0 AND 能量<REF(能量,1),0,能量,1,0),colorffff00;

 


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识