当前位置:→ 公式网 > 同花顺公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是同花顺大机构仓位副图公式源码(无源码的请下载附件导入)

大机构仓位:=100*(1-WINNER(CLOSE)),colorred,LINETHICK3;
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,120);
VAR6:=HHV(HIGH,120);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,10,1);
VARB:=3*VAR9-2*SMA(VAR9,10,1);
VARC:=100-VARB;
私募仓位:= (100-VARA),coloryellow,LINETHICK2;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
STICKLINE(VAR20,0,80,5,0),LINETHICK4,colorred;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,90,'超级主力建仓!') , colorred;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
V10:=PEAKBARS(3,15,1)<10; V12:=IF(V10=1,50,0);
头部:= IF(V12=50,100,0);
卖:=IF(IF(V12=50,100,0)>REF(IF(V12=50,100,0),1),40,0),colorgreen,LINETHICK3;
V9:=TROUGHBARS(3,15,1)<10; V11:=IF(V9=1,50,0);
底部:= IF(V11=50,50,0);
买:=IF( 底部>REF(底部,1),40,0),colorred,LINETHICK4;
V7:=TROUGHBARS(3,15,1)<10; V9:=IF(V7=1,50,0);
v1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
V11:=3*SMA((C-LLV(L,42))/(HHV(H,42)-LLV(L,42))*100,5,1)-2*SMA(SMA((C-LLV(L,42))/(HHV(H,42)-LLV(L,42))*100,5,1),3,1);
V12:=(EMA(V11,3)-REF(EMA(V11,3),1))/REF(EMA(V11,3),1)*100;
准备现金: =STICKLINE(EMA(V11,1)<=8,0,10,4,0),colorred;
AA:=(EMA(V11,3)<=13) AND FILTER((EMA(V11,3)<=13),15);
//买入股票: =STICKLINE(EMA(V11,3)<=10 AND V12>10,0,20,4,0),colorred;
BB:= (EMA(V11,3)<=13 AND V12>13) AND FILTER((EMA(V11,3)<=13 AND V12>13),10),colorwhite,LINETHICK3;
//卖临界: =STICKLINE(EMA(V11,3)>60 AND EMA(V11,3)>REF(EMA(V11,3),1),100,95,15,1),colorgreen;
CC:=(EMA(V11,3)>=90 AND V12) AND FILTER((EMA(V11,3)>=90 AND V12),10);
DD:=(EMA(V11,3)>=120 AND V12) AND FILTER((EMA(V11,3)>=120 AND V12),10);
VAR1aa:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR2aa:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR3aa:=(SMA(VAR2aa,3,1)-18)*1.55;
VAR4aa:=SMA(VAR3aa,3,1);
VAR5aa:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
VAR6aa:=SMA(VAR5aa,10,1);
VAR7aa:=(EMA(SMA(VAR6aa,8,1),34)-25)*2.6;
VAR8aa:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR9aa:=POW(MA(LOW,5),2)+MA(LOW,5);
VARAaa:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARBaa:=((VAR8aa-LLV(VAR9aa,64))/(HHV(VARAaa,64)-LLV(VAR9aa,64))*150+65-10)/2;
VARCaa:=SMA(VARBaa,3,1)*1.5-46;
VARDaa:=SMA(VARCaa,3,1);
VAREaa:=3*VARCaa-2*VARDaa;
VARFaa:=(VAR1aa+VAR2aa+VAR5aa)/3;
VAR10a:=((VAR3aa+VAR3aa+VAR6aa+VARCaa)/4-15)*1.67;
VAR11a:=((VAR4aa+VAR4aa+VAR7aa+VARDaa)/4-15)*1.67;
VAR12a:=((VAR1aa+VAR5aa*2+VARFaa+VAR10a+VAR11a+VARBaa+VARCaa+VARDaa+VAREaa)/10-15)*1.67;
VAR13a:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*(-1)+0.9;
VAR14a:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*(-1)+0.92;
VAR15a:=(HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.93;
VAR16a:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*(-1)+0.94;
VAR17a:=(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89))*(-1)+0.95;
VAR18a:=(HHV(HIGH,120)-CLOSE)/(HHV(HIGH,120)-LLV(LOW,120))*(-1)+0.91;
VAR19a:=(HHV(HIGH,180)-CLOSE)/(HHV(HIGH,180)-LLV(LOW,180))*(-1)+0.96;
VAR1Aa:=((VAR13a*8+VAR14a*8+VAR15a*8+VAR16a+VAR17a+VAR18a+VAR19a)/28-0.1)*185;
VAR1Ba:=SMA(VAR1Aa,3,1);
VAR1Ca:=(SMA(VAR1Ba,8,1)-8)*1.18;
浮筹:=(VAR10a+VAR11a+VAR12a+VARCaa+VARDaa+VAREaa+VAR1Ca+VAR7aa)/13 ;
浮筹1:=(VAR10a+VAR11a+VAR12a+VARCaa+VARDaa+VAREaa+VAR1Ca+VAR7aa)/21 ;
浮筹2:=(VAR10a+VAR11a+VAR12a+VARCaa+VARDaa+VAREaa+VAR1Ca+VAR7aa)/34;
VAR1Z:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2Z:=SMA(ABS(LOW-VAR1Z),10,1)/SMA(MAX(LOW-VAR1Z,0),10,1);
VAR3Z:=EMA(VAR2Z,10);
VAR4Z:=LLV(LOW,14);
VAR5Z:=EMA(IF(LOW<=VAR4Z,VAR3Z,0),3);
//进场:=STICKLINE(VAR5Z>REF(VAR5Z,1),0,VAR5Z,2,0),Colorff00ff;
//洗盘:=STICKLINE(VAR5Z<REF(VAR5Z,1),0,VAR5Z,2,0),colorgreen;
N:=27*1;
M1:=5*1;
M2:=3*1;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
N3:=16*1;
M4:=5*1;
M5:=3*1;
RSV3:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K1:SMA(RSV3,M4,1);
D1:SMA(K1,M5,1);
J1:3*K1-2*D1;
超卖10: IF(J<=10 OR J1<=10,20,0);
超卖5:  IF(J<=5 OR J1<=5,40,0);
超卖3:  IF(J<=3 OR J1<=2.5,60,0);
顶:80;
底:0;

 


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识