当前位置:→ 公式网 > 同花顺公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是同花顺螺旋起爆主图指标公式源码(无源码的请下载附件导入)

P1:=7;
AAA:=CONst(HHV(H*0.5,90));
DIF:=Ema(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA2:=(DIF-DEA)*2*60;
启:=crOSS(AAA-REF(AAA,1),15);
DRAWTEXT(CROSS(REF(zig(3,10),1),ZIG(3,10)),HIGH*1.02,'卖'),colorgreen;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.04) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
HIGHN:=8;
AA1:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BacKSET(AA1,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDD:=BArslAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DIF2:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA2:=EMA(DIF2,9);
AAA1:=(DIF2-DEA2)*2*60;
起爆:=CROSS(AAA1-REF(AAA1,1),15),colorred,LINETHICK2;
DRAWTEXT(起爆,L*0.99,' 起爆'),coloryellow,LINETHICK2;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'卖'),colorgreen;
买:=CROSS(AAA1-REF(AAA1,1),15),colorred,LINETHICK2;
DRAWTEXT(买,L*0.99,''),coloryellow,LINETHICK2;
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
DRAWTEXT(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.98,' ') ,colormagenta;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'卖'),colorgreen;
趋势线1:IF(MA(CLOSE,P1)<C,MA(CLOSE,P1),DRAWNULL),colorred,LINETHICK4;
趋势线2:IF(MA(CLOSE,P1)>=C,MA(CLOSE,P1),DRAWNULL),colorgreen,LINETHICK4;
B2:=H/REF(C,1)>=1.041;
XG2:=B1 AND B2;
C1:=REF(C,4)/REF(C,5)>1.09 AND REF(C,4)=REF(H,4) AND REF(C,4)>REF(MA(C,5),4) AND REF(O,4)>REF(MA(C,10),4) AND NOT(REF(C,2)/REF(C,1)>=1.09 AND REF(C,3)/REF(C,2)>=1.09);
C2:=H/REF(C,1)>=1.041;
C3:=REF(C,4)/O>1.02;
XG3:=C1 AND C2 AND C3;
D1:=REF(C,5)/REF(C,6)>1.09 AND REF(C,5)=REF(H,5) AND REF(C,5)>REF(MA(C,5),5) AND REF(O,5)>REF(MA(C,10),5);
D2:=H/REF(C,1)>=1.041;
XG4:=D1 AND D2;
E1:=REF(C,6)/REF(C,7)>1.09 AND REF(C,6)=REF(H,6) AND REF(C,6)>REF(MA(C,5),6) AND REF(O,6)>REF(MA(C,10),6);
E2:=H/REF(C,1)>=1.041;
XG5:=E1 AND E2;
F1:=REF(C,7)/REF(C,7)>1.09 AND REF(C,7)=REF(H,7) AND REF(C,7)>REF(MA(C,5),7) AND REF(O,7)>REF(MA(C,10),7);
F2:=H/REF(C,1)>=1.041;
XG6:=F1 AND F2;
TJ1:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND O<MA(C,5) AND REF(C,2)/REF(C,3)<1.099 AND (REF(C,1)<REF(MA(C,5),1) OR L<MA(C,10)) AND MA(C,5)>REF(MA(C,5),1) AND REF(L,1)>REF(MA(C,20),1) AND O/REF(C,1)<1.09 AND C>O;
HXG1:=(XG2 OR XG3 OR XG4 OR XG5 OR XG6)AND TJ1;
TCD1:=MA(C,5)>MA(C,20) AND MA(C,5)>MA(C,10);
WUJQ1:=HXG1 AND TCD1;
ZHW1:=WUJQ1 AND BARSCOUNT(C)<90;
ZHW2:=WUJQ1 AND MA(C,5)>MA(C,60) AND MA(C,5)>MA(C,120) AND MA(C,10)>MA(C,30) AND MA(C,10)>MA(C,60)AND MA(C,10)>MA(C,120);
WUJQ:=ZHW1 OR ZHW2;
STICKLINE(WUJQ,O,C,2.5,0),coloryellow;
DRAWICON(WUJQ,L*0.97,23);

 

同花顺螺旋起爆主图指标公式源码



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识