当前位置:→ 公式网 > 同花顺公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是同花顺VOL判断指标公式源码(无源码的请下载附件导入)

N1:=5;
N2:=10;
N3:=20;
N4:=30;
N5:=60;
K:=2;
总手:=vol;
V5:ma(V,5),colorwhite;
V10:MA(V,10),coloryellow;
HPLZ1:=V/REF(V,1)>=0.95 AND V/REF(V,1)<=1.05;
HLZ2:=REF(HHV(V,2),1);
HPLZ2:=V/HLZ2>=0.95 AND V/HLZ2<=1.05;
HLZ3:=REF(HHV(V,3),1);
HPLZ3:=V/HLZ3>=0.95 AND V/HLZ3<=1.05;
HLZ4:=REF(HHV(V,4),1);
HPLZ4:=V/HLZ4>=0.95 AND V/HLZ4<=1.05;
HLZ5:=REF(HHV(V,5),1);
HPLZ5:=V/HLZ5>=0.95 AND V/HLZ5<=1.05;
HLZ6:=REF(HHV(V,6),1);
HPLZ6:=V/HLZ6>=0.95 AND V/HLZ6<=1.05;
HLZ7:=REF(HHV(V,7),1);
HPLZ7:=V/HLZ7>=0.95 AND V/HLZ7<=1.05;
HLZ8:=REF(HHV(V,8),1);
HPLZ8:=V/HLZ8>=0.95 AND V/HLZ8<=1.05;
HLZ9:=REF(HHV(V,9),1);
HPLZ9:=V/HLZ9>=0.95 AND V/HLZ9<=1.05;
HLZ10:=REF(HHV(V,10),1);
HPLZ10:=V/HLZ10>=0.95 AND V/HLZ10<=1.05;
HLZ11:=REF(HHV(V,11),1);
HPLZ11:=V/HLZ11>=0.95 AND V/HLZ11<=1.05;
HLZ12:=REF(HHV(V,12),1);
HPLZ12:=V/HLZ12>=0.95 AND V/HLZ12<=1.05;
HLZ13:=REF(HHV(V,13),1);
HPLZ13:=V/HLZ13>=0.95 AND V/HLZ13<=1.05;
PLZ:=HPLZ13 OR HPLZ12 OR HPLZ11 OR HPLZ10 OR HPLZ9 OR HPLZ8 OR HPLZ7 OR HPLZ6 OR HPLZ5 OR HPLZ4 OR HPLZ3 OR HPLZ2 OR HPLZ1;
N:=100;
DDL:=100*(V-LLV(V,N))/(HHV(V,N)-LLV(V,N));
M:=13;
DL:=100*(V-LLV(V,M))/(HHV(V,M)-LLV(V,M));
倍量:=V>=REF(V,1)*1.9,coloryellow;
低量:=(V<=HHV(V,13)*0.33 OR DL<5 ) AND V<REF(V,1),colorgray;
地量:=V<=MA(LLV(V,100),100) OR (DDL<4 AND V<REF(V,1)),colorblue;
平量:=PLZ,colorbrown;
倍缩:=V<=REF(V,1)*0.55,colorred;
高压线:MA(HHV(V,100),30)*0.9,colorgreen;
stICKLINE(C>O,0,V,8,1),colorred;
STICKLINE(C<=O,0,V,8,1),colorgreen;
STICKLINE(平量,0,V,8,0),colorbrown;
STICKLINE(倍量,0,V,8,0),coloryellow;
STICKLINE(倍缩,0,V,8,0),colorred;
STICKLINE(低量,0,V,8,0),colorgray;
STICKLINE(地量,0,V,8,0),colorblue;
zz:=IF(REF(C,1)>REF(O,1) AND O>REF(C,1)*1.014 AND C<O*1.02,1,3);
v5:=MA(V,5);
v12:=MA(V,12);
V34:=MA(V,34);
C6:=MA(C,6);
DRAWTEXT (VOL>MA(VOL,5)*2 AND V>V34*3 AND C<REF(C,1)*1.05,V,'天'),coloryellow;
DRAWTEXT (VOL<MA(VOL,5)/2 AND V<v12/2,HHV(V,100)/2,'地'),colorblue;
DRAWTEXT (crOSS(C,C6) AND V>v5*1.2 AND V>v12*1.2 AND zz>2 AND C>H*0.975,HHV(V,100),'吸'),colorred;
DRAWTEXT (CROSS(C6,C) AND V>v5*1.2 AND V>v12*1.2,HHV(V,100),'出'),colorgreen;
DRAWTEXT(BArslAST(V>REF(V,1))>=3,HHV(V,100),'缩');
IF(1>0)
{
说明:="达到或接近绿色量线为天量,底部安全,高位时,成交量回来是头部";
RETURN;
}



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识