当前位置:→ 公式指标网 > 同花顺公式 > 正文 

以下是同花顺上多下空副图指标源码(无源码的请下载附件导入)

指标主要测算价格的背离。
指标使用非常简单,红线上做多,蓝线线做空。
同时K线配以颜色显示,如果红线上且K线也为红色,则为双重信号。
使用时配合其他技术分析手段效果更佳。

DRAWGBK(O>C,RGB(360,0,10),RGB(10,0,1),0,'01',0);
QQ1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,QQ1*(HIGH-LOW),IF(CLOSE<OPEN,QQ1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主卖:=IF(CLOSE>OPEN,0-QQ1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-QQ1*(HIGH-LOW),0-VOL/2));
DD:=(主买+主卖)/10000;
DDX1:=EMA(DD,60)*60;
DDX2:=MA(DDX1,5);
DDX3:=MA(DDX1,13);
STICKLINE(DDX1<DDX3,H,L,0,0),colorgreen;
STICKLINE(DDX1<DDX3,C,O,4,0),COLOR00B500;
STICKLINE(DDX1<DDX3,C,O,3,0),COLOR00C600;
STICKLINE(DDX1<DDX3,C,O,2,0),COLOR00D500;
STICKLINE(DDX1<DDX3,C,O,1,0),COLOR00E600;
STICKLINE(DDX1>DDX3,H,L,0,0),COLOR106FFF;
STICKLINE(DDX1>DDX3,C,O,4,0),COLOR0000C8;
STICKLINE(DDX1>DDX3,C,O,3,0),COLOR0000D7;
STICKLINE(DDX1>DDX3,C,O,2,0),COLOR0000EA;
STICKLINE(DDX1>DDX3,C,O,1,0),COLOR0000FF;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,H,L,0,0),COLORFF5D10;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,4,0),COLORFF5D10;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,3,0),COLORFF7710;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2,0),COLORFF9910;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,H,L,0,0),COLORFF00FF;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,4,0),COLORD000D0;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,3,0),COLORE600E6;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2,0),COLORF900F9;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,1,0),COLORFF09FF;
MA2:=MA(CLOSE,10);
MA34:=MA(CLOSE,34);
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
K:=SMA(VARF,3,1);
顶:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (K>79);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND
(K>79),H*1.02,'风险'),coloryellow;
降:=HHV(EMA(C,3),8),colorcyan;
升:=LLV(EMA(C,3),8),colorred;
走势:=EMA(C,3),coloryellow;
线上多:IF(走势<降,降,DRAWNULL),colorcyan,LINETHICK2;
线下空:IF(走势>升,升,DRAWNULL),colormagenta,LINETHICK2;


同花顺上多下空副图指标源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号