当前位置:→ 公式指标网 > 同花顺公式 > 正文 

以下是同花顺潜龙出海源码副图(无源码的请下载附件导入)

MA5:MA(C,5),LINETHICK3,COLOR00CCFF;

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

五日乖离率:=(C-MA5)/MA5*100;

BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);

加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;

IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK3,colorred;

BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK3,colorgreen;

三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;

VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);

VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);

BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB5,60),10);

加仓:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);

清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);

DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),coloryellow;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;

减仓:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;

买入:=FILTER(MR,10);

DRAWTEXT(减仓,HIGH*1.02,'←风险'),colorcyan;

DRAWTEXT(买入,LOW*0.98,'←买入'),coloryellow;

DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),colorgreen;

DRAWTEXT(强势狙击,LOW*0.95,'←狙击'),coloryellow;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));

VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);

MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;

压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;

 

 

选股公式:

MA5=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

五日乖离率:=(C-MA5)/MA5*100;

BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);

加速度5:=EMA((速度5-REF(速度5,1)),3);

BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

三拾日乖离率:=(C-MA30)/MA30*100;

VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);

VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);

BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB5,60),10);

加仓:FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);
 

同花顺潜龙出海源码副图





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号