当前位置:→ 公式指标网 > 同花顺公式 > 正文 

以下是杨子轩3(无源码的请下载附件导入)

 

GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));

GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));

GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));

GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));

baijin1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;

baijin2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;

baijin3:=GJTJ1>60 AND GJTJ4>70;

DRAWTEXT(baijin1 AND baijin2 AND baijin3,L-0.02,'白金');

huangjin1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;

huangjin2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;

XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5 AND GJTJ1>GJTJ4;

DRAWTEXT(COUNT(XG,3)=1 AND XG AND C>MA(C,20),L-0.02,'暴'),colorred;买:ZIG(3,10);

卖:MA(买,2);

DRAWICON(CROSS(买,卖),L-CLOSE/15,"buy");

DRAWICON(CROSS(卖,买),H+CLOSE/15,"sell");

GET:ZIG(3,5),COLORAAAAAA;

PL5:=ZIG(3,5);

EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);

PL10:=ZIG(3,13);

EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);

EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);

PL20:=ZIG(3,26);

EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);

EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);

PL40:=ZIG(3,55);

;买:ZIG(3,10);

卖:MA(买,2);

DRAWICON(CROSS(买,卖),L-CLOSE/15,"buy");

DRAWICON(CROSS(卖,买),H+CLOSE/15,"sell");

MA(C,3);

N:=10;

T1:=CONST(HHVBARS(V,N));

T0:IF(CURRBARSCOUNT<=N+3,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),COLORFF00FF;

IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT,COLORFF00FF;

X:=30;

X1:=CONST(REF(HHVBARS(V,X),T1+1)+T1+1);

X0:IF(CURRBARSCOUNT<=T1+X+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,X1)),DRAWNULL),COLOR999999;

IF(CURRBARSCOUNT=X1+1,X0,DRAWNULL),CIRCLEDOT,COLORCCCCCC;

W:=20;

W1:=CONST(REF(HHVBARS(V,W),T1+1)+T1+1);

W0:IF(CURRBARSCOUNT<=T1+W+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,W1)),DRAWNULL),COLOR009999;

IF(CURRBARSCOUNT=W1+1,W0,DRAWNULL),CIRCLEDOT,COLOR00CCCC;

M:=10;

Q1:=CONST(REF(HHVBARS(V,M),T1+1)+T1+1);

Q0:IF(CURRBARSCOUNT<=T1+M+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,Q1)),DRAWNULL),COLOR009900;

IF(CURRBARSCOUNT=Q1+1,Q0,DRAWNULL),CIRCLEDOT,COLOR00CC00;

MA1:MA(C,5),colorred,LINETHICK1;

MA2:MA(C,10),coloryellow,LINETHICK1;

MA3:MA(C,30),COLOR9933CC,LINETHICK1;

MA4:MA(C,60),colorgreen,LINETHICK1;

K1:=BACKSET(MA1<REF(MA1,1),2);

IF(K1,MA1,DRAWNULL),COLOR00CC33,LINETHICK1;

K2:=BACKSET(MA2<REF(MA2,1),2);

IF(K2,MA2,DRAWNULL),COLORFFCC66,LINETHICK1;

K3:=BACKSET(MA3<REF(MA3,1),2);

IF(K3,MA3,DRAWNULL),colorblue,LINETHICK1;

阻力价:HHV(HIGH,19),LINETHICK1,NODRAW;

Y:=(MA(C,5)-MA(C,30))/MA(C,5)*100;

YY1:=C>MA(C,5) AND OPEN<MA(C,5);

YY3:=C>MA(C,10) AND OPEN<MA(C,10);

YY5:=C>MA(C,30) AND OPEN<MA(C,30);

DRAWTEXT(YY1 AND YY5 AND YY3,LOW*0.97,'双龙'),colorred;

VAR1:=HHV(HIGH,25);

VAR2:=LLV(LOW,25);

VAR3:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,20);

VAR4:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,5);

VAR5:=CROSS(VAR4,VAR3);

DRAWICON(CROSS(VAR4,VAR3) ,LOW*0.97,11);

M10:MA(CLOSE,10),colorred;

VarD:=EMA(CLOSE,21)-EMA(CLOSE,8);

VarE:=EMA(VarD,5);

Var10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

Var12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

Var13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

Var14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

Var15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

Var16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

Var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

买2:=(Var11+Var13+Var15+Var17);

卖1:=(Var12+Var14+Var16+Var18),linethick2;

买1:=Var10;

DRAWTEXT(买1>0,LOW-0.01,'*\n买\n\n1'),colorred,ALIGN0;

DRAWTEXT(买2>0,LOW-0.01,'*\n买\n\n2'),colorgreen,ALIGN0;

BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,colorwhite;

UPR:BBI+P*STD(BBI,N),coloryellow;

DWN:BBI-P*STD(BBI,N),colorff00ff;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;

DRAWICON(CROSS(84,RSI) ,H*1.03,5);

DRAWICON(CROSS(RSI,11) ,L*0.99,4);

Var27:=REF(CLOSE,1);

Var28:=SMA(MAX(CLOSE-Var27,0),5.5,1)/SMA(ABS(CLOSE-Var27),6,1)*100;

DRAWICON(IF(CROSS(76,Var28),1,0),H*1.03,5);

DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0 AND EMA(CLOSE,12)/LOW>1.15,5),LOW,''),linethick7 , COLORff00ff;

VARA:=((AMOUNT)/(VOL))/(100);

VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);

VARC:=((SUM(AMOUNT,7))/(VARA))/(100);

VARD:=DMA(VARB,(VOL)/(VARC));

VARE:=((CLOSE-VARD)/(VARD))*(100);

VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);

VARJ:=MA(VARE,20)+STD(VARE,20);

BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);

aa:=SMA(VARF,3,1);

ss:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (aa>79);

DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND

(aa>ss),H*1.02,''),LINETHICK7,colorgreen;

Var1:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);

Var2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);

STICKLINE(Var1,C,O,8,0),coloryellow,LINETHICK2;

STICKLINE(Var1,C,O,3,0),coloryellow,LINETHICK2;

STICKLINE(Var1,H,L,1,0),coloryellow,LINETHICK2;

STICKLINE(Var2,C,O,8,0),COLORFF00FF,LINETHICK2;

STICKLINE(Var2,C,O,3,0),COLORFF00FF,LINETHICK2;

STICKLINE(Var2,H,L,1,0),COLORFF00FF,LINETHICK2;

DRAWTEXT(ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2),LOW,''),colorred;
 

杨子轩3




关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号