当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信看盘操作主图源码(无源码的请下载附件导入)

通达信看盘操作主图源码 

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),
COLOR781836;
DRAWKLINE(H,O,L,C);
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
买:IF(CROSS(指导线,界) OR CROSS(买线,卖线),C,DRAWNULL),COLORMAGENTA,NODRAW;
持仓:IF(买线>=卖线,C,DRAWNULL),COLORRED,NODRAW;
卖:IF(CROSS(界,指导线) OR CROSS(卖线,买线),C,DRAWNULL),COLORLIGRAY,NODRAW;
空仓:IF(买线<卖线,C,DRAWNULL),COLORGREEN,NODRAW;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46; AA1:=AMOUNT/V;BB1:=L<AA1*0.9;JJ:=
(CLOSE+HIGH+LOW)/3;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
A:=EMA(JJ,10);
B:=REF(A,1);
VAR1:=STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,1),COLORRED;
VAR2:=STICKLINE(CLOSE>=OPEN,OPEN,LOW,0.5,0),COLORRED;
STICKLINE(CLOSE>=OPEN,HIGH,CLOSE,0.5,0),COLORRED;
VAR3:=STICKLINE(CLOSE<OPEN,CLOSE,OPEN,6,0),COLORGREEN;
VAR4:=STICKLINE(CLOSE<OPEN,HIGH,OPEN,0.5,0),COLORGREEN;
STICKLINE(CLOSE<OPEN,LOW,CLOSE,0.5,0),COLORGREEN;
STICKLINE(A>B,A,B,5,0),COLORYELLOW;
STICKLINE(A<B,A,B,5,0),COLORBLUE;
K:=(C+H+L)/3;
D:=MA(K,4);
操作:D,COLORWHITE,LINETHICK2;
VAR37:=EMA(EMA(EMA(CLOSE,2),2),2);
VAR47:=(MA(VAR37,47))*(0.99);
DRAWTEXT((MA(CLOSE,13) > MA(CLOSE,18)) AND CROSS(CLOSE,MA(CLOSE,4)) AND (MA(CLOSE,4) < MA
(CLOSE,13)),(LOW)*(0.95),'进'),COLOR00FF00;
B36:=MA(CLOSE,3) - MA(CLOSE,6);
B612:=MA(CLOSE,6) - MA(CLOSE,12);
J:=((B36)/(CLOSE))*(10);
J1:=((B612)/(CLOSE))*(10);
DRAWTEXT((J < (-0.2)) AND (J1 < (-0.2)) AND CROSS(J,J1),(LOW)*(0.95),'大牛'),COLORRED;
KS:=((CLOSE - MA(CLOSE,13))/(MA(CLOSE,13)))*((-200));
RKS:=REF(KS,1);
FT:=((RKS)/(KS) >= 1.23) AND (RKS >= 8) AND ((CLOSE)/(REF(CLOSE,1)) >= 1.03);
反弹:STICKLINE(FT,HIGH,LOW,0,1),LINETHICK2,COLOR00FF00;
STICKLINE(FT,OPEN,CLOSE,8,0),COLORYELLOW;
VAR10:=MA(CLOSE,80) - (MA(CLOSE,10))/(3);
VAR11:=REF(CLOSE,1);
VAR12:=((SMA(MAX(CLOSE - VAR11,0),18,1))/(SMA(ABS(CLOSE - VAR11),18,1)))*(100);
DRAWICON(CROSS(79,VAR12),(HIGH)*(1.035),2),COLOR008000;
AK1:=EMA(((CLOSE - VAR1)/(VAR2 - VAR1))*(100),5);
AK:=EMA(((CLOSE - VAR1)/(VAR2 - VAR1))*(50),13);
DD:=EMA((0.667)*(REF(AK1,1)) + (0.333)*(AK1),2);
VAR5:=EMA(((CLOSE - VAR3)/(VAR4 - VAR3))*(100),3);
VAR6:=(AK + VAR5)/(2);
VAR7:=EMA((0.667)*(REF(VAR5,1)) + (0.333)*(AK1),2);
VAR8:=EMA(VAR6,5);
BB:=EMA((0.667)*(REF(VAR8,1)) + (0.333)*(VAR8),2);
AB:=CROSS(AK1,AK);
CD:=(BB1)*(0.6);
DRAWTEXT((AB = 1),(LOW)*(0.98),'■'),LINETHICK2,COLOR66FFCC;
DRAWTEXT((AB = 1),(LOW)*(0.94),'拐点 '),COLOR33CC99;
VAR111:=(((CLOSE - MA(CLOSE,6))/(MA(CLOSE,6)))*(200) + ((CLOSE - MA(CLOSE,24))/(MA
(CLOSE,24)))*(200) + ((CLOSE - MA(CLOSE,32))/(MA(CLOSE,32)))*(200))/(3);
DRAWICON((VAR111 > 20) AND FILTER((VAR111 < REF(VAR111,1)),5),(HIGH)*(1.02),2),COLORFF00FF;
DRAWTEXT(REF(C,1)>D AND C<D AND D>REF(D,1),H*1.02, '卖');
DRAWTEXT(REF(C,1)<D AND C>D AND D<REF(D,1),L*0.98, '买'),COLORWHITE;

{公式在线提供:www.gszx.com.cn}


 





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 2009-2010 gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识