当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信经典成交量指标共五个源码(无源码的请下载附件导入)

通达信经典成交量指标共五个源码

第一个:
{FT-自用VOL}
量:VOL,LINETHICK,COLOR00FFFF;
STICKLINE(CLOSE>REF(CLOSE,1),量,0,3.5,0),COLOR0054A8;
STICKLINE(CLOSE<=REF(CLOSE,1),量,0,3.5,0),COLOR999900;
预量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),COLORFF00FF;
预量增:预量-REF(V,1),LINETHICK,COLORWHITE;
CB:=IF(CAPITAL>1,AMOUNT/VOL/100,(HIGH+LOW+2*CLOSE)/4);
空1:=IF((HIGH-LOW)>0 AND CLOSE>CB, ((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CB)/(HIGH-LOW)*VOL) ,0);
多1:=IF((HIGH-LOW)>0 AND CLOSE>CB, VOL-空1 ,0);
多2:=IF((HIGH-LOW)>0 AND CLOSE<=CB, ((CLOSE-LOW)/(CB-LOW))*((CLOSE-LOW)/(CB-LOW))*((CB-LOW)/(HIGH-LOW)*VOL) ,0);
空2:=IF((HIGH-LOW)>0 AND CLOSE<=CB, VOL-多2 ,0);
多3:=IF((HIGH-LOW)=0 AND CLOSE>REF(CLOSE,1), VOL,0);
空3:=IF((HIGH-LOW)=0 AND CLOSE<=REF(CLOSE,1), VOL,0);
多方量:多1+多2+多3,NODRAW,COLORRED;
空方量:空1+空2+空3,NODRAW,COLORGREEN;
STICKLINE(空方量,量,O,3,0),COLOR005A00;
STICKLINE(空方量,量,O,2.5,0),COLOR006600;
STICKLINE(空方量,量,O,2,0),COLOR006B00;
STICKLINE(空方量,量,O,1.5,0),COLOR007700;
STICKLINE(空方量,量,O,1,0),COLOR007B00;
STICKLINE(空方量,量,0,0.5,0),COLOR009900;
STICKLINE(多方量,多方量,O,3,0),COLOR000066;
STICKLINE(多方量,多方量,O,2.5,0),COLOR000077;
STICKLINE(多方量,多方量,O,2,0),COLOR000099;
STICKLINE(多方量,多方量,O,1.5,0),COLOR0000BB;
STICKLINE(多方量,多方量,O,1,0),COLOR0000DD;
STICKLINE(多方量,多方量,O,0.5,0),COLOR0000FF;
多量线:EMA(多方量,3),COLOR00DBDB,LINETHICK2;
空量线:EMA(空方量,3),COLORBFBFBF,LINETHICK2;

第二个:
{FT-量子力学}
N:=5;QJ0:=(HIGH+LOW+CLOSE)/3;
QJ1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
QJ2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-QJ0);
QJ3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
QJ4:=IF(HIGH=LOW,1,QJ0-MIN(CLOSE,OPEN));
QJ5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
QJ6:="MACD.DIF">"MACD.DEA" AND "MACD.DEA"<0;
QJ7:="KDJ.K">"KDJ.D" AND "KDJ.D"<30;
QJ8:="MACD.DIF"<"MACD.DEA";
QJ9:="KDJ.K"<"KDJ.D" AND "KDJ.K">80;
特大:QJ4*QJ5,NODRAW;大单:QJ3*QJ5,NODRAW;
中单:QJ1*QJ5,NODRAW;小单:QJ2*QJ5,NODRAW;
W1:=SUM(大单,N)+SUM(特大,N);W2:=SUM(小单,N)+SUM(中单,N);
量振1:=特大>大单 AND 大单>小单;
量振2:=特大<小单 AND 大单<小单;
标振1:=QJ6 AND QJ7;
标振2:=QJ8 AND QJ9;
A:=W1-W2;A0:=IF(A>0,A,0);B0:=IF(A<0,A,0);
STICKLINE(A0,0,A0,3,0),COLOR000044;
STICKLINE(A0,0,A0,2.5,0),COLOR000088;
STICKLINE(A0,0,A0,1.5,0),COLOR0000AA;
STICKLINE(A0,0,A0,1,0),COLOR0000CC;
STICKLINE(B0,0,-B0,3,0),COLOR004400;
STICKLINE(B0,0,-B0,2.5,0),COLOR008800;
STICKLINE(B0,0,-B0,1.5,0),COLOR00AA00;
STICKLINE(B0,0,-B0,1,0),COLOR00CC00;
趋势:MA(A,5),COLORFFFFFF;
平滑值:EMA(周趋势,5),COLOR00FFFF;
STICKLINE(标振1 AND 量振1 AND 周趋势>平滑值,0,A0,3,0),COLORYELLOW;
DRAWTEXT(标振1 AND 量振1 AND 周趋势>平滑值,A0,'振'),COLORYELLOW;

第三个:
{FT-提前量}
N1:=12;N2:=26;M:=9;
CC:=(C+L+H+O)/4;
DIFF:=EMA(CC,5)-EMA(CC,13),COLORBB00BB,LINETHICK2;
DEA:=EMA(DIFF,4),COLOR00BB00,LINETHICK2;
MACD:=XMA((DIFF-DEA)*200,2),COLORSTICK;
红柱持股:MACD,NODRAW;
黄色高抛:MACD,NODRAW;
蓝柱持币:MACD,NODRAW;
紫色反弹:MACD,NODRAW;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,6,0 ),COLOR003333;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3.5,0 ),COLOR004444;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR005555;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR007777;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR009999;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.5,0 ),COLOR00BBBB;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00DDDD;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,6 ,0 ),COLOR000033;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.5 ,0 ),COLOR000044;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3 ,0 ),COLOR000055;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.5 ,0 ),COLOR000077;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2 ,0 ),COLOR000099;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.5 ,0 ),COLOR0000BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1 ,0 ),COLOR0000DB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.5 ,0 ),COLOR0000FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,6,0 ),COLORFF00CA;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3.5,0 ),COLORFF00CC;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3,0 ),COLORFF00DB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.5,0 ),COLORFF00DD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFF00DF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.5,0 ),COLORFF00EE;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFF00EF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.5,0 ),COLORFF00FF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,6,0 ),COLOR333300;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3.5,0 ),COLOR444400;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3,0 ),COLOR555500;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.5,0 ),COLOR777700;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLOR999900;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.5,0 ),COLORBBBB00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORDDDD00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.5,0 ),COLORFFFF00;
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
DEAA:=EMA(DIF,9);
RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K:=SMA(RSV,2,1);
D:=SMA(K,2,1);
J:=3*K-2*D;
主流资金:=(EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3))/100, COLORRED,LINETHICK2;
非主流资金:=(EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3))/100,COLORGREEN,LINETHICK2;
KJ共振:CROSS(DIF,DEAA) AND CROSS(K,D) AND 主流资金>非主流资金;
DRAWTEXT(KJ共振,红柱持股,'B'),COLORGREEN;
四连阳:EVERY(红柱持股>REF(红柱持股,1),4),NODRAW;
LAST((H-L)/REF(C,1)<0.1,20,0) AND VOL>REF(VOL,1)*2 AND C>REF(C,1)*1.03
AND "DMI.PDI">"DMI.MDI" AND CROSS("DMI.ADX","DMI.ADXR")
AND"DMI.ADXR">"DMI.MDI" AND "DMI.PDI">"DMI.ADX" AND"KDJ.D">REF("KDJ.D",1);

第四个:
{FT-L001}
{N 1.00 100.00 15.0}{M1:5;M2:10;M3:20;M4:60}
公积金:FINANCE(18),COLORRED,NODRAW;
现金流亿:FINANCE(26)/100000000,NODRAW;
市值:FINANCE(40)/100000000,COLORFF00FF,NODRAW;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);
能量:=SAT,VOLSTICK;
DRAWTEXT(FILTER(SAT>=100,100),VOL*1.06,'爆'),COLORRED;
DRAWTEXT(SAT=100 AND ISLASTBAR,VOL*1.03,'发'),COLORYELLOW;
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
成交:=VOL;
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 *
((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) +
(OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),
(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((买卖差 < 0),0,买卖差,3,0),LINETHICK3,COLOR339933;
STICKLINE((买卖差 < 0),0,买卖差,2,0),LINETHICK3,COLOR33AA33;
STICKLINE((买卖差 < 0),0,买卖差,1,0),LINETHICK3,COLOR33DD33;
STICKLINE((买卖差 < 0),0,买卖差,0.5,0),LINETHICK3,COLOR33FF33;
量比1:=(VOL / MA(VOL,5));
VAR10:=买盘;
VAR20:=卖盘;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
动神:=买盘;
鬼力:=VAR20;
神比:=(动神 / VAR30);
鬼比:=(鬼力 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,动神) + 动神) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,动神) + 动神) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,动神) + 动神) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,0),COLOR000088;
STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,2,0),COLOR0000AA;
STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,1,0),COLOR0000DD;
STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,0.5,0),COLOR0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,0),COLOR008800;
STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,2,0),COLOR00AA00;
STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,1,0),COLOR00DD00;
STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,0.5,0),COLOR00FF00;
STICKLINE((鬼力 > 0),鬼力,0,4,0),COLORFF3399;
加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,3,0),COLOR880088;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,2,0),COLORAA00AA;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,1,0),COLORDD00DD;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,0.5,0),COLORFF00FF;
减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,3,0),COLOR880000;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,2,0),COLORBB0000;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,1,0),COLORDD0000;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,0.5,0),COLORFF0000;
洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,3,0),COLOR999999;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,2,0),COLORAAAAAA;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,1,0),COLORDDDDDD;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,0.6,0),COLORFFFFFF;
高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,3,0),COLOR008888;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,2,0),COLOR00AAAA;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,1,0),COLOR00DDDD;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,0.5,0),COLOR00FFFF;
相对地量:=STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,3,0);
白洗盘进:1,NODRAW,COLORWHITE;
黄高抛低吸:1,NODRAW,COLOR00FFFF;
粉庄进追:1,NODRAW,COLORFF00FF;
兰绿庄撤卖:1,NODRAW,COLOR00FF00;
MAV1:MA(V,M1),LINETHICK1,COLOR00FF00;
MAV2:=MA(V,M2),LINETHICK1,COLORFF00FF;
IF(MA(V,5)>=REF(MA(V,5),1),MA(V,5),DRAWNULL),COLORRED,LINETHICK2;
DRAWICON(V>=3*REF(V,1),V*1.01,23);
DRAWICON(V>=2*REF(V,1),V*0.5,25);

第五个:
{变色成交量 东郭专用系列 副图}
万手:VOL/10000,LINETHICK0;
AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
预测:AA/10000,LINETHICK0;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买:=BUYVOL;
卖:=SELLVOL;
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主买:主动买/10000,COLORFF00FF,LINETHICK0;
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主卖:-主动卖/10000,COLORGREEN,LINETHICK0;
差额:主买+主卖,LINETHICK0;
STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.5,0),COLORWHITE;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,3.5,0),COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3.5,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.5 , 0 ) , COLORYELLOW ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.2 , 0 ) , COLOR0088FF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.7 , 0 ) , COLOR00AAFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.1 , 0 ) , COLOR00CCFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 1.5 , 0 ) , COLOR22FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.9 , 0 ) , COLOR66FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.3 , 0 ) , COLOR99FFFF ;
STICKLINE(主动买>0,0,主动买,3.2,0),COLOR000033;
STICKLINE(主动买>0,0,主动买,2.7,0),COLOR000066;
STICKLINE(主动买>0,0,主动买,2.1,0),COLOR000099;
STICKLINE(主动买>0,0,主动买,1.5,0),COLOR0000CC;
STICKLINE(主动买>0,0,主动买,0.9,0),COLOR0000FF;
STICKLINE(主动买>0,0,主动买,0.3,0),COLORCC66FF;
STICKLINE(主动卖<0,VOL,主动买,3.2,0),COLOR990000;
STICKLINE(主动卖<0,VOL,主动买,2.7,0),COLORCC0000;
STICKLINE(主动卖<0,VOL,主动买,2.1,0),COLORFF4400;
STICKLINE(主动卖<0,VOL,主动买,1.5,0),COLORFF8800;
STICKLINE(主动卖<0,VOL,主动买,0.9,0),COLORFFCC00;
STICKLINE(主动卖<0,VOL,主动买,0.3,0),COLORCYAN;
MA5:MA(V,5),COLORWHITE;
MA35:MA(V,35),COLORYELLOW;
MA135:MA(V,135),COLORGREEN;

通达信经典成交量指标共五个源码





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号