当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信超级MACD指标(无源码的请下载附件导入)

通达信超级MACD指标

DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:EMA(DIFF,9),COLORBLUE;
MACD:(DIFF-DEA)*2;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORRED;
STICKLINE(MACD>=0 AND MACD<=REF(MACD,1),0,MACD,1,0);
STICKLINE(MACD<=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORFF00FF;
STICKLINE(MACD<=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLOR00FFFF;
多转空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
DRAWICON(多转空,MACD,2);
DRAWICON(空转多,MACD,1);
下金叉:=CROSS(DIFF,DEA) AND DIFF<0;
DRAWTEXT(下金叉,-0.2,' 金叉'),COLORYELLOW;
上金叉:=CROSS(DIFF,DEA) AND DIFF>0;
DRAWTEXT(上金叉,0.15,' 金'),COLORRED;
爬坡:=CROSS(DIFF,DEA) AND DIFF>=-0.1 AND DIFF<0.1;
DRAWTEXT(爬坡,0.22,'上'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWTEXT(二叉,DEA*1.06,'二叉'),COLORRED;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
DRAWTEXT(背离,-0.2-MACD,'背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶,0.2+MACD,'顶'),COLORWHITE;
月DIF:="MACD.DIF#MONTH"COLOR0080FF;
月DEA:="MACD.DEA#MONTH",COLOR0080FF,LINETHICK2;
周DIF:="MACD.DIF#WEEK"COLORRED;
周DEA:="MACD.DEA#WEEK",COLORRED,LINETHICK2;
日DIF:="MACD.DIF",COLORWHITE;
日DEA:="MACD.DEA",COLORWHITE,LINETHICK2;
日金:IF(CROSS(日DIF,日DEA),0.1,0),COLORYELLOW;
周金:IF(CROSS(周DIF,周DEA),0.125,0),COLORRED;
月金:IF(CROSS(月DIF,月DEA),0.15,0),COLORFF00FF;
DRAWICON(周金 AND 日金,-0.1,7);
DRAWICON(周金 AND 月金,-0.15,11);

通达信超级MACD指标





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号