当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信筹码峰分布主图指标公式源码(无源码的请下载附件导入)

Z1:=stRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0,0.09,0,EXTERNSTR(0,12)),COLORLIGREEN;{老王}
DRAWTEXT_FIX(ISLASTBAR,0,0.03,0,EXTERNSTR(0,3)),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,EXTERNSTR(0,6)),COLORLIBLUE;
X_1:=ma(CLOSE,4);
X_2:=MA(CLOSE,13);
X_3:=MA(CLOSE,24);
X_4:=MA(CLOSE,30);
X_5:=MA(CLOSE,120);
AA:=Abs((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);
济安线:=DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORMAGENTA;
X_6:=X_2>X_3 AND X_3>X_4 AND X_4>X_5 AND X_2>REF(X_2,1) AND X_3>REF(X_3,1) AND X_4>REF(X_4,1) AND X_5>=REF(X_5,1);
X_7:=ATAN((MA(CLOSE,13)/REF(MA(CLOSE,13),1)-1)*100)*57.299999;
X_8:=120;
X_9:=MA(CLOSE,X_8);
X_10:=POW(CLOSE-X_9,2);
X_11:=MA(X_10,X_8);
X_12:=SQRT(X_11);
X_13:=X_9+2*X_12;
X_14:=X_9-2*X_12;
筹码线:REF(X_13,1),COLORYELLOW,LINETHICK2;
趋势线:MA(CLOSE,24),COLORRED,LINETHICK2;
X_15:=(3*CLOSE+OPEN+LOW+HIGH)/6;
X_16:=(20*X_15+19*REF(X_15,1)+18*REF(X_15,2)+17*REF(X_15,3)+16*REF(X_15,4)+15*REF(X_15,5)+14*REF(X_15,6)+13*REF(X_15,7)+12*REF(X_15,8)+11*REF(X_15,9)+10*REF(X_15,10)+9*REF(X_15,11)+8*REF(X_15,12)+7*REF(X_15,13)+6*REF(X_15,14)+5*REF(X_15,15)+4*REF(X_15,16)+3*REF(X_15,17)+2*REF(X_15,18)+REF(X_15,20))/210;
X_17:=MA(X_16,7);
X_18:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_19:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_20:=IF(CLOSE>REF(CLOSE,1),vol,-VOL);
X_21:=SUM(IF(CLOSE=REF(CLOSE,1),0,X_20),0);
X_22:=MA(X_21,30);
X_23:=VOL;
X_24:=X_23>REF(HHV(X_23,30),1);
X_25:=X_21>X_22;
X_26:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
X_27:=HIGH>=HHV(HIGH,20);
X_28:=REF(X_26,1);
X_29:=COUNT(X_28,5)>=1;
X_30:=COUNT(X_28,13)>=1;
X_31:=OPEN<=REF(CLOSE,1) AND X_18<(-2);
X_32:=COUNT(X_31,2)>=1;
X_33:=X_29 AND X_18>2.5 AND REF(X_32,1) AND REF(X_18<2.4,1) AND X_4>0;
X_34:=X_33 AND COUNT(X_33,30)=1 ;
STICKLINE(X_26,OPEN,CLOSE,2,0),COLORYELLOW;
X_35:=HIGH>=HHV(HIGH,150);
X_36:=X_35=1 AND BArslAST(REF(X_35=1,1))>=1 AND X_18>3;
DRAWICON(FILTER(X_36=1,1),LOW-0.2,25),COLORYELLOW;
X_37:=VOL>MA(VOL,89);
X_38:=X_37=1 AND BARSLAST(REF(X_37=1,1))>=6 AND HIGH>济安线 AND X_4>X_5;
STICKLINE(X_34,OPEN,CLOSE,1,0),COLORF00FF0;
X_39:=X_6 AND CLOSE>X_2 AND LOW<=X_2 AND CLOSE>OPEN AND X_7>47 AND X_30;
DRAWICON(X_34,LOW,24);
DRAWICON(X_34,LOW-0.3,25);
DRAWICON(X_34,LOW-0.6,26);
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND crOSS(A8,MA(A8,2));
{DRAWICON(FILTER(买=1,5),LOW-0.05,26),COLORYELLOW;}
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;

通达信筹码峰分布主图指标公式源码

通达信筹码峰分布主图指标公式源码



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识