当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信价格资金趋势指标公式源码(无源码的请下载附件导入)

X_1:=REF(LOW,1);
X_2:=SMA(Abs(LOW-X_1),3,1)/Sma(MAX(LOW-X_1,0),3,1)*100;
X_3:=EMA(IF(CLOSE*1.2,X_2*10,X_2/10),3);
X_4:=LLV(LOW,38);
X_5:=HHV(X_3,38);
X_6:=1971101;
X_7:=1971201;
X_8:=IF(DATE>X_6,IF(CLOSE<80,1,0),0);
X_9:=IF(DATE>X_7,1,X_8);
X_10:=IF(X_9=0,1,0);
X_11:=EMA(IF(LOW<=X_4,(X_3+X_5*2)/50,0),3)/258*X_10;
X_12:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
X_13:=SMA(X_12,13,8);
主力建仓:X_11,NODRAW,COLORMAGENTA;
吸筹1:stICKLINE(X_11,0,X_11,6,0),COLORRED;
吸筹2:STICKLINE(X_11,0,X_11,5,0),COLOR6600FF;
吸筹3:STICKLINE(X_11,0,X_11,4,0),COLORBB00FF;
吸筹4:STICKLINE(X_11,0,X_11,3,0),COLORMAGENTA;
吸筹5:STICKLINE(X_11,0,X_11,2,0),COLORFF33FF;
吸筹6:STICKLINE(X_11,0,X_11,1,0),COLORFF66FF;
吸筹7:STICKLINE(X_11,0,X_11,0,0),COLORFF99FF;
STICKLINE(1,0,0,6,0),COLOR454545;
STICKLINE(1,100,100,6,0),COLOR454545;
STICKLINE(1,50,50,6,0),COLOR454545;
X_14:=vol/10000;
X_15:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_16:=IF(CLOSE>OPEN,X_15*(HIGH-LOW),IF(CLOSE<OPEN,X_15*(HIGH-OPEN+(CLOSE-LOW)),IF(CLOSE=OPEN AND CLOSE>REF(CLOSE,1)*1.09,VOL,0)))/10000;
X_17:=IF(CLOSE>OPEN,0-X_15*(HIGH-CLOSE+(OPEN-LOW)),IF(CLOSE<OPEN,0-X_15*(HIGH-LOW),IF(CLOSE=OPEN AND CLOSE<REF(CLOSE,1)*0.91,0-VOL,0)))/10000;
X_18:=X_16+X_17;
X_19:=SUM(X_18,5);
X_20:=MA(X_18,1);
X_21:=SMA(SMA(SMA(X_20,2,1),2,1),2,1);
X_22:=REF(X_21,1);
X_23:=SMA(MAX(X_21-X_22,0),7,1)/SMA(ABS(X_21-X_22),7,1)*100;
STICKLINE(X_23>80,97,100,3,0),COLORCYAN;
X_24:=LLV(X_21,35);
X_25:=HHV(X_21,30);
X_26:=EMA((X_21-X_24)/(X_25-X_24)*4,4)*25;
X_27:=X_26;
X_28:=87.5;
X_29:=(X_26-LLV(X_26,4))/(HHV(X_26,4)-LLV(X_26,4))*4*25;
X_30:=EMA(100*(X_21-LLV(X_21,18))/(HHV(X_21,18)-LLV(X_21,18)),3)/4*4*1;
DRAWBAND(X_30,RGB(88,0,0),MA(X_30,2),RGB(0,88,0));
X_31:=(2*CLOSE+HIGH+LOW)/4;
X_32:=LLV(LOW,30);
X_33:=HHV(HIGH,30);
X_34:=IF(X_9!=1,EMA((X_31-X_32)/(X_33-X_32)*100,8),0);
X_35:=EMA(X_34,4);
STICKLINE(X_34-X_35>0,X_34,X_35,2,1),COLOR990099;
STICKLINE(X_34-X_35<0,X_34,X_35,2,1),COLOR999900;
X_36:=X_21;
X_37:=LLV(X_21,30);
X_38:=HHV(X_21,30);
X_39:=IF(X_9!=1,EMA((X_36-X_37)/(X_38-X_37)*100,8),0);
X_40:=EMA(X_39,4);
STICKLINE(X_39-X_40>0,X_39,X_40,4,0),COLOR0000CC;
STICKLINE(X_39-X_40<0,X_39,X_40,4,0),COLOR00CC00;
X_41:=X_39>50 AND X_39-X_40>0 OR (X_39-X_40>0 AND X_34-X_35>0 AND X_30>MA(X_30,2));
X_42:=X_39<50 AND X_39-X_40<0 OR (X_39-X_40<0 AND X_34-X_35<0 AND X_30<MA(X_30,2));
STICKLINE(X_42,X_39,50,1,(-1)),COLOR00CC00;
STICKLINE(X_41,X_39,50,1,(-1)),COLOR0000CC;
X_43:=X_21;
X_44:=LLV(X_21,21);
X_45:=HHV(X_21,34);
X_46:=EMA((X_43-X_44)/(X_45-X_44)*100,13);
X_47:=EMA(0.667*REF(X_46,1)+0.333*X_46,2);
X_48:=EMA(0.382*REF(X_46,2)+0.618*X_46,12);
X_49:=IF(X_9=1,0,1);
X_50:=MA((-100)*(HHV(X_21,34)-X_21)/(HHV(X_21,34)-LLV(X_21,34)),19)*X_49;
流动资金:EMA(100*(X_21-LLV(X_21,18))/(HHV(X_21,18)-LLV(X_21,18)),3)/4*4*X_49,NODRAW,COLOR000088;
资金趋势:X_39,NODRAW,COLOR0000CC;
价格趋势:X_34,NODRAW,COLOR990099;
X_51:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
X_52:=(-100)*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
X_53:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
X_54:=X_51+100;
X_55:=X_52+100;
X_56:=X_53+100;
X_57:=REF(X_56,1)>85 AND REF(X_55,1)>85 AND REF(X_54,1)>65 AND crOSS(X_54,X_55);
X_58:=X_56<REF(X_56,1) AND REF(X_56,1)>80 AND (REF(X_55,1)>95 OR REF(X_55,2)>95) AND X_54>60 AND X_55<83.5 AND X_55<X_56 AND X_55<X_54+4;
X_59:=FILTER(X_58,4);
STICKLINE(X_59,97,100,3,0),COLORCYAN;
X_60:=X_54<12 AND X_56<8 AND (X_55<7.2 OR REF(X_55,1)<5) AND (X_56>REF(X_56,1) OR X_55>REF(X_55,1)) OR (X_54<8 AND X_56<7 AND X_55<15 AND X_55>REF(X_55,1)) OR (X_54<10 AND X_56<7 AND X_55<1);
STICKLINE(X_60,(-3),0,8,0),COLORGREEN;
X_61:=BArslAST(REF(CROSS(X_39,X_40),1));
X_62:=REF(CLOSE,X_61+1)>CLOSE AND REF(X_39,X_61+1)<X_39 AND CROSS(X_39,X_40) AND X_39<50;
X_63:=BARSLAST(REF(CROSS(X_40,X_39),1));
X_64:=REF(CLOSE,X_63+1)<CLOSE AND REF(X_39,X_63+1)>X_39 AND CROSS(X_40,X_39) AND X_39>50;
DRAWICON(X_62,(-2),7);
DRAWICON(X_64,101,8);
资金底背离:X_62,NODRAW,COLORYELLOW;
资金顶背离:X_64,NODRAW,COLORGREEN;

通达信价格资金趋势指标公式源码

通达信价格资金趋势指标公式源码



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识