当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信财神送宝主图源码狙击埋伏龙头(无源码的请下载附件导入)

本指标是通达信主图指标,可以佩服副图,副图指标叫财神送宝或者状元郎,大家也可以搜索找到。
使用方法自己研究,不提供技术支持。软件选股风险自担。
软件已经测试,可以正常使用。
源码:
 
VARQ0:=1.04;
 
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA30:=MA(CLOSE,30),COLORMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN;
MA120:MA(CLOSE,120),COLORAAAAAA;
MA250:=MA(CLOSE,250),COLORAAAAAA;
天龙看盘:(COST(99)+COST(93)+COST(85))/3,LINETHICK1;
VARQ5:=MA(CLOSE,13);
VARQ6:=MA(CLOSE,34);
VARQ7:=MA(CLOSE,55);
DRAWBAND(MA10,RGB(180,50,0),MA20,RGB(0,50,100));
DRAWBAND(MA5,RGB(200,120,0),MA10,RGB(0,100,150));
NOTEXTMA120:MA120,COLORAAAAAA;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(CLOSE > 1.097 * REF(CLOSE,1),CLOSE,OPEN,2.8,0),COLORRED;
STICKLINE(CLOSE < 0.907 * REF(CLOSE,1),CLOSE,OPEN,2.8,0),COLORGREEN;
VARQ15:=OPEN < VARQ5 AND CLOSE > VARQ5;
VARQ16:=OPEN < VARQ6 AND CLOSE > VARQ6;
VARQ17:=OPEN < VARQ7 AND CLOSE > VARQ7;
VARQ18:=CLOSE / OPEN >= VARQ0;
VARQ19:=VOL > HHV(HIGH,10);
VARQ20:=VARQ5 >= REF(VARQ5,1);
VARQ21:=VARQ15 AND VARQ16 AND VARQ17 AND VARQ18 AND VARQ19 AND VARQ20;
DRAWICON(VARQ21,LOW - LOW * 0.05,1);
DRAWICON(VARQ21,LOW - LOW * 0.1,7);
VARQ24:=BARSLAST(VARQ21 > 0) < 25 AND CLOSE < MA10;
VARQ25:=FILTER(VARQ24,25 - BARSLAST(VARQ21 > 0));
DRAWICON(VARQ25,HIGH + HIGH * 0.01,2);
VARQ27:=(OPEN + CLOSE) / 2;
STICKLINE(VARQ21 > 0,VARQ27,VARQ27,20,0),COLORYELLOW;
VARQ29:=CLOSE = HHV(CLOSE,13);
VARQ30:=BARSLAST(FILTER(CROSS(0.8,VARQ29),2)) + 1;
平台高点:REF(CLOSE,VARQ30),NODRAW,COLOR8800FF;
STICKLINE(VARQ30 <= 13,平台高点,平台高点,1,0),COLOR8800FF;
VARQ33:=CLOSE = LLV(CLOSE,13);
VARQ34:=BARSLAST(FILTER(CROSS(0.8,VARQ33),2)) + 1;
平台低点:REF(CLOSE,VARQ34),NODRAW,COLORFF8800;
STICKLINE(VARQ34 <= 13,平台低点,平台低点,1,0),COLORFF8800;
VARQ37:=IF(CLOSE / REF(CLOSE,1) >= 1.099,1,0);
STICKLINE(VARQ37 > 0,LOW,HIGH,0,0),COLORRED;
STICKLINE(VARQ37 > 0,OPEN,CLOSE,3,0),COLOR0022CC;
STICKLINE(VARQ37 > 0,OPEN,CLOSE,2,0),COLOR0033EE;
STICKLINE(VARQ37 > 0,OPEN,CLOSE,1,0),COLOR4444FF;
涨停:=IF(REF(C,1)*1.095-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;

 

 

 
ZT:=C/REF(C,1)>1.099 AND C=H;
A1:=MA5>L AND MA5<O;
A2:=MA60>L AND MA60<O;
A3:=MA120>L AND MA120<O;
A4:=A1 OR A2 OR A3;
昨日涨幅:=(REF(C,1)/REF(C,(2)))<1.09;
主升浪:=ZT AND MA5>MA120  AND C>MA5 AND 昨日涨幅,COLORCYAN;
DRAWTEXT(主升浪,(LOW * 0.97),'←主升浪'),COLORRED;

 
均线金叉:=ZT AND (CROSS(MA5,MA60) OR CROSS(MA5,MA120)) AND 昨日涨幅,COLORRED;
DRAWTEXT(均线金叉,(LOW * 0.97),'←均线金叉'),COLOR00FFFF;
击穿均线:=ZT AND A4 AND 昨日涨幅,COLORMAGENTA;
DRAWTEXT(击穿均线,(LOW * 0.97),'←击穿均线'),COLORRED;

 
海底捞月:=ZT AND C<MA5 AND 昨日涨幅,COLORWHITE;
DRAWTEXT(海底捞月,(LOW * 0.93),'←海底捞月'),COLORBROWN;
鱼跃龙门:=CROSS(C,MA120)  AND ZT AND MA5>MA60 AND (CROSS(MA5,MA60) OR CROSS(MA5,MA120)) AND 昨日涨幅,COLORBROWN;
DRAWTEXT(鱼跃龙门,(LOW * 0.97),'←鱼跃龙门'),COLORMAGENTA;
突破半年线:=CROSS(C,MA120) AND ZT AND 昨日涨幅,COLORYELLOW;
DRAWTEXT(突破半年线,(LOW * 0.97),'←突破半年线'),COLORRED;
一阳洞穿:=REF(C,1)<MA5 AND REF(C,1)<MA20 AND REF(C,1)<MA30 AND REF(C,1)<MA60 AND
C>MA5 AND C>MA20 AND C>MA30 AND C>MA60 AND ZT AND 昨日涨幅,COLORLIRED;  
DRAWTEXT(一阳洞穿,(LOW * 0.97),'←一阳洞穿'),COLORLIMAGENTA;
旱地拔葱:=ZT AND MA120>MA5 AND MA5>MA60 AND OPEN>MA120 AND CLOSE>MA120 AND 昨日涨幅;
DRAWTEXT(旱地拔葱,(LOW * 0.97),'←旱地拔葱'),COLORLIRED;
超跌反攻:=ZT AND C> MA5 AND MA120/MA5>1.15 AND 昨日涨幅,COLORLIMAGENTA;
DRAWTEXT(超跌反攻,(LOW * 0.97),'←超跌反攻'),COLOR00FFFF;
反转:=ZT AND REF(MA5,1)/REF(C,1)>1 AND C/MA5>1 AND 昨日涨幅,COLORBLUE;
DRAWTEXT(反转,(LOW * 0.93),'←反转'),COLOR00FFFF;

 
AA:= REF(EVERY((C/REF(C,1)>1.099 AND O=C AND H=L),3),1);
BB:=O/REF(C,1)>1.099 AND H=O AND L<O ; 
CC:=BARSCOUNT(C)<30;
打开一字:=AA AND BB AND CC;
DRAWTEXT(打开一字,(LOW * 0.93),'←打开一字'),COLORRED;

 
A5:=HHV(H,30);
A6:=CROSS(C,REF(A5,1));
DDT:=MA5>MA10 AND MA10>MA30 AND MA30>MA60;
CDT:=MA30>MA60 AND MA60>MA120 AND MA120>MA250;
PC:=NOT(NAMELIKE('S') OR NAMELIKE('*S')) AND DYNAINFO(17)>=2 AND CAPITAL<=8000000;{非ST}
T1:=MA30>MA5 AND MA30>MA10 AND MA60>MA5 AND MA60>MA10;
T2:=CROSS(C,MA30) AND CROSS(C,MA60);
T3:=MA120>MA60 AND MA120>MA30 AND MA120>MA10 AND MA120>MA5;
T4:=MA250>MA120 AND MA250>MA60 AND MA250>MA30 AND MA250>MA10 AND MA250>MA5;
TP1:=T1 AND T2 AND PC AND C>MA250 AND C>MA120;
TP2:=CDT AND PC AND CROSS(C,MA5) AND CROSS(C,MA10) AND C>MA30;
TP3:=T3 AND CROSS(C,MA120) AND PC OR T4 AND CROSS(C,MA250) AND PC;
TP4:=DDT AND CDT AND PC AND A2;
ZF:=C>O AND C/REF(C,1)>=1.05;
TP5:=EXIST(CROSS(MA10,MA5),10) AND CROSS(C,MA5) AND CROSS(C,MA10) AND ZF;
短线起爆:=TP1 AND ZF OR TP2 AND ZF  OR TP3 AND ZF OR TP5 AND CDT;
DRAWTEXT(短线起爆,(LOW * 0.97),'←短线起爆'),COLOR00FFFF;
跳空高开:=ZT  AND OPEN>MA5 AND LOW/REF(CLOSE,1)>1 AND OPEN/REF(CLOSE,1)>1 AND O<C AND 昨日涨幅;
DRAWTEXT(跳空高开,(LOW * 0.93),'←跳空高开'),COLOR8800FF; 
{DRAWGBK(跳空高开,RGB(0,0,0),RGB(0,0,0),0,'AS6',0);}

 
DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
MACD := 2*(DIFF-DEA);
X1:=EMA(DIFF,5)*5;
X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
A7:=CROSS(X2,X1) AND X1>=0;
DRAWICON(A7,L*0.96,13);
{DRAWTEXT(A7,(LOW * 0.90),'←回调买'),COLORYELLOW;}

 
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,2.8,0),COLORYELLOW;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,2.8,0),COLOR007700;

 
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(90,RSI) , HIGH*0.98,'←逢高出局'),COLOR00FF00 ;

通达信财神送宝主图源码狙击埋伏龙头

通达信财神送宝主图源码狙击埋伏龙头



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识