当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信活跃区间启动指标公式源码头副图(无源码的请下载附件导入)

上市天数:= BARSCOUNT(C);
日期限制:=IF((DATE <= 1991231),1,1);
ma5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
EMA60:=EMA(CLOSE,60);
MAXX:=IF((上市天数 > 100),EMA60,MA20);
均线乖离:=((MA10 - EMA60) / EMA60);
低吸条件:=((CLOSE / REF(CLOSE,20)) < 1.20);
bias10:=((CLOSE - MA10) / MA10);
BIAS20:=((CLOSE - MA20) / MA20);
BIAS60:=((CLOSE - EMA60) / EMA60);
均价:=((0.01 * AMOUNT) / vol);
换手率:=(VOL / CAPITAL*100);
MVOL5:=MA(换手率,5);
MVOL20:=MA(换手率,20);
MVOL60:=EMA(换手率,60);
大阳线:=((CLOSE / REF(CLOSE,1)) > 1.060);
涨停板:=(((CLOSE / REF(CLOSE,1)) > 1.099) && (CLOSE = HIGH));
一字涨停:=(((CLOSE / REF(CLOSE,1)) > 1.099) && (LOW = HIGH));
冲涨停:=((((((HIGH / REF(CLOSE,1)) > 1.099) || ((CLOSE / REF(CLOSE,1)) > 1.09)) && ((CLOSE / REF(CLOSE,1)) > 1.065)) && ((CLOSE / REF(CLOSE,1)) < 1.0992)) && (CLOSE > 均价));
放量长阳线:=(((((CLOSE / REF(CLOSE,1)) > 1.050) && ((换手率 > REF(换手率,1)) || (换手率 > MAX(MVOL5,MVOL60)))) && (CLOSE > 均价)) && (BIAS10 < 0.12));
标志性阳线:=((涨停板 || 冲涨停) || 放量长阳线);
涨停间隔:=BArslAst(标志性阳线);
前均价:=REF(均价,涨停间隔);
均线条件:=((REF(LOW,1) < MAX(REF(MA10,1),REF(MA20,1))) && (CLOSE > MA10));
大盘指数:=INDEXC;
大盘均线乖离:=((INDEXC - MA(INDEXC,10)) / MA(INDEXC,10));
相对强弱:=(3 * (BIAS10 - 大盘均线乖离));
相对强弱条件:=((相对强弱 > 0) || ((相对强弱 > -(0.1)) && (相对强弱 > REF(相对强弱,1))));
累积强弱:=SUM(相对强弱,10);
N:=10;
P:=3;
bbi:=((((MA(CLOSE,3) + MA(CLOSE,6)) + MA(CLOSE,12)) + MA(CLOSE,24)) / 4);
UPR:=(BBI + (P * STD(BBI,N)));
DWN:=(BBI - (P * STD(BBI,N)));
布林宽度:=((UPR - DWN) / 10);
布林条件:=(((布林宽度 < 0.40) && (LLV(布林宽度,5) < (3 * LLV(布林宽度,100)))) || (布林宽度 < 0.20));
当日涨幅:=((((CLOSE / REF(CLOSE,1)) > 1.03) && ((CLOSE / REF(CLOSE,1)) < 1.110)) && ((CLOSE / MA10) < 1.13));
内外盘差:=(VOL / CAPITAL);
A1:=MIN(COUNT((VOL / CAPITAL*100),0),30);
大单:=(VOL / CAPITAL*100);
累计:=(EMA(大单,A1) * A1);
均值:=MA(累计,10);
大单翻红:=(((大单 > 0.10) && (大单 > REF(大单,1))) || ((大单 > 0) && (累计 > 均值)));
大单条件:=((大单 > 0.50) && ((大单 / 换手率) > 0.20));
缩量:=(换手率 < MAX(MVOL5,MVOL20));
缩量条件:=(COUNT(缩量,7) >= 4);
换手率条件:=(((((换手率 > (1.35 * REF(换手率,1))) && (换手率 < (7 * REF(换手率,1)))) && (换手率 > 1.5)) && (换手率 > MVOL5)) && REF(缩量条件,1));
波段启动:=(((((均线条件 && 换手率条件) && 当日涨幅) && 大单翻红) && 相对强弱条件) && 布林条件);
双强模式:=(0.6 * ((((MA10 > MA20) || (MA10 > REF(MA10,1))) || (均价 > MA10)) && (相对强弱 > -(0.02))));
股性活跃:=(0.5 * ((((COUNT(大阳线,60) >= 6) || (COUNT(涨停板,60) >= 2)) || (COUNT((涨停板 || 放量长阳线),30) >= 1)) || (COUNT((相对强弱 > 0.1),120) > 20)));
放量:=(0.2 * (((((换手率 > MAX(MVOL60,MVOL5)) || (MVOL5 > MVOL60)) || 涨停板) || (COUNT((涨停板 || 放量长阳线),3)=1 && (换手率 > MIN(MVOL60,MVOL5)))) && (((CLOSE > MA10) || (相对强弱 > 0)) || ((MVOL5 >= REF(MVOL5,1)) && (CLOSE > REF(CLOSE,1))))));
活跃股:=(0.5 * ((放量 || 双强模式) && 股性活跃));
激活1:=(((((((涨停板 || 放量长阳线) && 活跃股) && (相对强弱 > 0)) && (大单翻红 || 一字涨停)) && (均线乖离 < 0.23)) && (BIAS60 < 0.25)) && 低吸条件);
激活时间1:=BARSLAST(激活1);
活跃区间:(活跃股 && EVERY(活跃股,(激活时间1 + 1))),COLORRED;
计数:=COUNT(激活1,0);
激活2:=((激活1 && 活跃区间) && (COUNT(激活1,0) = 1));
激活:=(((激活1 && 活跃区间) && REF((活跃区间 <> 1),1)) && (COUNT(激活1,0) > 1));
激活3:=(((激活1 && 活跃区间) && REF((活跃股 = 0),1)) && (COUNT(激活1,0) <= 1));
启动:IF((COUNT(激活1,0) > 1),激活,(激活2 || (激活3 && 低吸条件))),LINETHICK0;
激活时间:=BARSLAST(激活);
激活均价:=REF(均价,激活时间);
激活点开盘价:=REF(OPEN,激活时间);
激活点最低价:=REF(LOW,激活时间);
激活点均线价:=REF(MA10,激活时间);
最低止损价:=(激活均价 * 0.95);
建仓区间底价:=IF((激活点开盘价 < (激活均价 * 0.98)),MAX(激活点最低价,最低止损价),最低止损价);
建仓区间顶价:=IF(((REF(大单,激活时间) > 1) && ((REF(大单,激活时间) / REF(换手率,激活时间)) > 0.20)),(激活均价 * 1.03),(激活均价 * 1.02));
回调:=(0.2 * (((((((HHV(CLOSE,5) / CLOSE) > 1.06) && (HHV(BIAS10,6) > 0.08)) && (CLOSE > (0.95 * MA10))) && (CLOSE < (1.09 * MA10))) && ((LOW / MA10) < 1.01)) && 活跃区间));
关注区间:(0.6 * ((((活跃区间 && (LOW <= 建仓区间顶价)) && ((CLOSE >= 建仓区间底价) || (CLOSE > MA10))) && (激活时间 <= 6)) && (激活时间 > 0))),LINETHICK0;
关注:=(0.3 * (放量 && (相对强弱 > 0)));
STICKLINE(启动,0,2,2,0),COLORYELLOW;
STICKLINE((关注区间 > 0),0,2,2,0),COLOR9B85E5;

通达信活跃区间启动指标公式源码头副图

通达信活跃区间启动指标公式源码头副图



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识