当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信操盘量能指标公式源码副图(无源码的请下载附件导入)

{指标介绍:
1、该指标成交量超过135均线,为成交量放大--为主力异动。35均线为洗盘异动线,成交量超过35均线,洗盘结束。5均线上穿35均线,可以考虑开始进场。出现黄色量能柱时为买入更可信!
2、成交量上绿下红,为诱空信号,一般出现在上升通道,出现此形态可多买股票(类似殷保华理论线上阴线买)。
3、成交量上红下绿,为诱多信号,一般出现在下降通道,出现此形态尽量少买股票(类似殷保华理论线下阳线卖)。
4、成交量全部红的,为上升通道趋势走好,但是要注意顶部信号的出现。成交量全部绿的,为下降通道趋势走坏,但是要主要底部信号的出现。
5、当成交量中第一次出现黄色量能柱时为买入点, 黄色量能柱持续期间持股。当成交量中第一次失去黄色量能柱时为卖出点, 无黄色量能柱期间空仓。
6、量能饱和度说明主力当天的意愿如何?超过50%为强,量能饱和度越大,资金进入意愿越强,上涨的概率越大。
7、上图为主力多空双方情况。绿色为空 ,红色 为多,红上有黄色块为拉升意愿,越长拉升意愿越强。}

M:=1.2;
N1:=34;
N2:=N1*1.05;
N3:=N1+3;
SATDSJHKGJKGXDJ:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:IF(SATDSJHKGJKGXDJ>1,1,SATDSJHKGJKGXDJ)*100,COLORLIBLUE,NODRAW;
ZHONGDIAN:=REFDATE(HHV(V,100)/2,DATE);
stICKLINE(CURRBARSCOUNT=N1,ZHONGDIAN*1.9,ZHONGDIAN*1.5,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,ZHONGDIAN*1.88,ZHONGDIAN*1.52,量能饱和度,0),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=N1,ZHONGDIAN*1.82,ZHONGDIAN*1.58,量能饱和度,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,ZHONGDIAN*1.76,ZHONGDIAN*1.64,量能饱和度,0),COLOR0099FF;
STICKLINE(CURRBARSCOUNT=N1,ZHONGDIAN*1.7,ZHONGDIAN*1.7,量能饱和度,0),COLORFFDD55;
DRAWTEXT(CURRBARSCOUNT=N3,ZHONGDIAN*1.82,'量能饱和度'),COLORBLUE;
volUME:VOL,VOLSTICK;
SHORTDSJKGVHKXH:=12;
LONGSDIUJGHVDXD:=26;
MIDIUEHVDJGHDHF:=9;
DIFEIOYHCXJKHDE:=Ema(CLOSE,SHORTDSJKGVHKXH)-EMA(CLOSE,LONGSDIUJGHVDXD);
DEAIOEHFJkdHCGN:=EMA(DIFEIOYHCXJKHDE,MIDIUEHVDJGHDHF);
macd:=(DIFEIOYHCXJKHDE-DEAIOEHFJKDHCGN)*2,COLORSTICK;
STICKLINE(DIFEIOYHCXJKHDE>DEAIOEHFJKDHCGN,0,VOL,3,0),COLORRED;
STICKLINE(DIFEIOYHCXJKHDE<DEAIOEHFJKDHCGN,0,VOL,3,0),COLORGREEN;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
STICKLINE(J>D,VOL/2,VOL,3,0),COLORRED;
STICKLINE(J<D,VOL/2,VOL,3,0),COLORGREEN;
VAEDJHGVJCXGBDN:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
obv1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VAEDJHGVJCXGBDN),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
Mac3:=MA(C,3);
限制:=IF(OBV3>=VOL,VOL,IF(OBV3<VOL,OBV3,0));
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,限制,2,0),COLORYELLOW;
MAVOL5:MA(VOLUME,5),LINETHICK1,COLORFFFFFF;
资金异动135:MA(VOLUME,135),LINETHICK2,COLORFF80FF;
主力洗盘35:MA(VOL,35),LINETHICK2,COLORFFFF80;
TT:=240/FROMOPEN;
比:=TT;
AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
AZ2:=EMA(AY2,9);
LT2:=(AY2-AZ2);
L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
ZGD:=HHV(H,80)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L211,80);
ZDD2:=CONST(ZDD);
YYA4:=MA(CLOSE,20);
YYA5:=(CLOSE > MA(CLOSE,5));
YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YYA7:=(CLOSE > MA(CLOSE,10));
YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YYA9:=(CLOSE > MA(CLOSE,20));
YYA10:=REF(YYA4,1);
YYA11:=(YYA4 > YYA10);
YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
J1:=CONST(IF( YYAVX > 0,200,100));
J2:=CONST(IF( YYAVX > 0,00,100));
J3:=CONST(IF( YYAVX > 0,100,100));
ZGD3:=ZGD2;
ZDD3:=ZDD2;
ZGD4:=ZGD2;
QINGKUANG1:=CONST(IF(((crOSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;
QINGKUANG2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
QINGKUANG3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
QINGKUANG4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
QINGKUANG5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
QINGKUANG6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
QINGKUANG7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
QINGKUANG8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
QINGKUANG9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
QINGKUANG10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
QINGKUANG11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
QINGKUANG12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
QINGKUANG13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
QINGKUANG14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
QINGKUANG15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
QINGKUANG16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
DAPAN1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));
DAPAN2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));
DAPAN3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
DAPAN4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));
DAPAN5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
DAPAN6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
DAPAN7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
DAPAN8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
mfi:=(HIGH-LOW)*1000000/(VOL*比);
绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);
MMM1:=CONST(绿灯);
衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);
MMM2:=CONST(衰退);
伪装:=MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1);
MMM3:=CONST(伪装);
蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);
MMM4:=CONST(蛰伏);
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
量大:=(卖盘+买盘)/REF(VOL,1)>2;
MMM5:=CONST(量大);
量缩:=REF(VOL,1)/(卖盘+买盘)>1.5;
MMM6:=CONST(量缩);
卖量大:=(卖盘-买盘)/买盘>0.4;
MMM7:=CONST(卖量大);
买量大:=(买盘-卖盘)/卖盘>0.4;
MMM8:=CONST(买量大);
TS1:=IF(QINGKUANG1=1,0.06+0.06,0.06); TS2:=IF(QINGKUANG2=1,TS1+0.06,TS1);
TS3:=IF(QINGKUANG3=1,TS2+0.06,TS2); TS4:=IF(QINGKUANG4=1,TS3+0.06,TS3);
TS5:=IF(QINGKUANG5=1,TS4+0.06,TS4); TS6:=IF(QINGKUANG6=1,TS5+0.06,TS5);
TS7:=IF(QINGKUANG7=1,TS6+0.06,TS6); TS8:=IF(QINGKUANG8=1,TS7+0.06,TS7);
TS9:=IF(QINGKUANG9=1,TS8+0.06,TS8); TS10:=IF(QINGKUANG10=1,TS9+0.06,TS9);
TS11:=IF(QINGKUANG11=1,TS10+0.06,TS10); TS12:=IF(QINGKUANG12=1,TS11+0.06,TS11);
TS13:=IF(QINGKUANG13=1,TS12+0.06,TS12); TS14:=IF(QINGKUANG14=1,TS13+0.06,TS13);
TS15:=IF(QINGKUANG15=1,TS14+0.06,TS14); TS16:=IF(QINGKUANG16=1,TS15+0.06,TS15);
TS17:=IF(DAPAN1=1,TS16+0.06,TS16); TS18:=IF(DAPAN2=1,TS17+0.06,TS17);
TS19:=IF(DAPAN3=1,TS18+0.06,TS18); TS20:=IF(DAPAN4=1,TS19+0.06,TS19);
TS21:=IF(DAPAN5=1,TS20+0.06,TS20); TS22:=IF(DAPAN6=1,TS21+0.06,TS21);
TS23:=IF(DAPAN7=1,TS22+0.06,TS22); TS24:=IF(DAPAN8=1,TS23+0.06,TS23);
TS25:=IF(MMM1=1,TS24+0.06,TS24);
TS26:=IF(MMM2=1,TS25+0.06,TS25);
TS27:=IF(MMM3=1,TS26+0.06,TS26);
TS28:=IF(MMM4=1,TS27+0.06,TS27);
TS29:=IF(MMM5=1,TS28+0.03,TS28);
TS30:=IF(MMM6=1,TS29+0.03,TS29);
TS31:=IF(MMM7=1,TS30+0.03,TS30);
TS32:=IF(MMM8=1,TS31+0.03,TS31);
DRAWTEXT_FIX(QINGKUANG1=1 ,0.10,0,0,'量能理想,明显走强,中线参与,仓位控制在70%左右。'),COLORFF00FF;
DRAWTEXT_FIX(QINGKUANG2=1 ,0.10,0,0,'走势趋强,量能不足,短线进场,仓位控制在50%左右。'),COLORFF00FF;
DRAWTEXT_FIX(QINGKUANG3=1 ,0.10,0,0,'量价良好,并无明显走强,短线可进场,仓位50%左右。'),COLORFF00FF;
DRAWTEXT_FIX(QINGKUANG4=1 ,0.10,0,0,'形态尚可,量能不足,未全走强,短入,仓位30%左右。'),COLORFF00FF;
DRAWTEXT_FIX(QINGKUANG5=1 ,0.10,0,0,'形态已变坏,走势尚可,重仓者减大半,清仓者%观望。'),COLOR00FFFF;
DRAWTEXT_FIX(QINGKUANG6=1 ,0.10,0,0,'随DAPAN下跌,明显缩量,考虑DAPAN风险,减持或清仓。'),COLOR00FFFF;
DRAWTEXT_FIX(QINGKUANG7=1 ,0.10,0,0,'该股放量下跌,走势明显偏弱,不抢反弹,离场观望。'),COLORFFFFFF;
DRAWTEXT_FIX(QINGKUANG8=1 ,0.10,0,0,'该股缩量下跌,走势偏弱无力,人气散失,离场观望。'),COLORFFFF00;
DRAWTEXT_FIX(QINGKUANG9=1 ,0.10,0,0,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLOR00FFFF;
DRAWTEXT_FIX(QINGKUANG10=1,0.10,0,0,'上行趋势不变,强势依然,量能开始转弱,注意风险。'),COLOR00FFFF;
DRAWTEXT_FIX(QINGKUANG11=1,0.10,0,0,'该股仍然具备上涨潜力,但股性偏弱,可以考虑减仓。'),COLORFFFFFF;
DRAWTEXT_FIX(QINGKUANG12=1,0.10,0,0,'该股走势趋弱,量能明显不足,减大部分筹码或空仓。'),COLORFFFF00;
DRAWTEXT_FIX(QINGKUANG13=1,0.10,0,0,'该股形态不佳,注意成交量变化,但目前不适合参与。'),COLORFFFF00;
DRAWTEXT_FIX(QINGKUANG14=1,0.10,0,0,'该股趋势不明,股价偏弱,注意量能变化,暂不参与。'),COLORFFFF00;
DRAWTEXT_FIX(QINGKUANG15=1,0.10,0,0,'有走强迹象,但量能不足,趋势不明朗,不适合操作。'),COLORFFFF00;
DRAWTEXT_FIX(QINGKUANG16=1,0.10,0,0,'该股走势太弱,主动性买盘弱,没有太大的参与价值。'),COLORFFFFFF;
DRAWTEXT_FIX(DAPAN1,0.10,0.05,0,'总势量能理想,70%仓位, 若最佳买点,否则谨慎介入。'),COLOR00FF00;
DRAWTEXT_FIX(DAPAN2,0.10,0.05,0,'总势趋强,量不足,若前轮下跌,短进50%,量大加仓。'),COLORFF00FF;
DRAWTEXT_FIX(DAPAN3,0.10,0.05,0,'总势形态走坏,重仓者可减去大部分仓位或放空筹码。'),COLORAAAAAA;
DRAWTEXT_FIX(DAPAN4,0.10,0.05,0,'总势缩量调整,注意DAPAN系统风险,短线可清仓观望。'),COLORFFFFFF;
DRAWTEXT_FIX(DAPAN5,0.10,0.05,0,'总势走势良好,量能理想,可继续持有或加仓强势股。'),COLOR00FFFF;
DRAWTEXT_FIX(DAPAN6,0.10,0.05,0,'总势形态良好,但量能稍显不足,随时准备减仓调仓。'),COLOR00FF00;
DRAWTEXT_FIX(DAPAN7,0.10,0.05,0,'总势趋势不明,注意成交量变化,目前暂不适宜进场。'),COLORFFFFFF;
DRAWTEXT_FIX(DAPAN8,0.10,0.05,0,'总势趋势向下,量能萎缩,短线可杀跌,不适合进场。'),COLORFFFFFF;
DRAWTEXT_FIX(MMM5,0.10,0.15,0,'★今天比昨天的成交量放大一倍以上。'),COLORGREEN;
DRAWTEXT_FIX(MMM6,0.10,0.15,0,'★今天比昨天的成交量缩量一半以上。'),COLORYELLOW;
DRAWTEXT_FIX(MMM7,0.10,0.20,0,'☆该股今天卖出量大于买入量40%以上。'),COLORGREEN;
DRAWTEXT_FIX(MMM8,0.10,0.20,0,'☆该股今天买入量大于卖出量40%以上。'),COLORYELLOW;

通达信操盘量能指标公式源码副图

通达信操盘量能指标公式源码副图



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识