当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信突破龙头选股指标公式源码副图(无源码的请下载附件导入)

A1:=vol;
A2:=ma(A1,5);
A3:=MA(CLOSE,10);
A4:=MA(CLOSE,26);
A5:=EMA(CLOSE,5);
A6:=EMA(CLOSE,14);
A7:=EMA(CLOSE,18);
A8:=EMA(CLOSE,40);
A9:=EMA(CLOSE,60);
A10:=MA(CLOSE,10);
A11:=MA(CLOSE,54);
A12:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
A13:=FILTER(A12,10);
A14:=BArslAst(A13);
A15:=REF(HIGH,A14+2);
A16:=REF(HIGH,A14+1);
A17:=REF(HIGH,A14);
A18:=MAX(A15,A16);
A19:=MAX(A18,A17);
A20:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
A21:=A14<150;
A22:=(OPEN-A19)/A19*100<30;
A23:=(CLOSE-LLV(LOW,A14))/LLV(LOW,A14)*100<50;
A24:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
A25:=VOL/MA(VOL,5)<3.5;
A26:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
A27:=A20 AND A21 AND A22 AND A23 AND A24 AND A25 AND A26;
A28:=FILTER(A27,15);
A29:=(CLOSE-A11)/A11<0.1;
A30:=(CLOSE-A10)/A10<0.3;
A31:=(A29=1 AND A30=1)*0.2;
A32:=(A31=0 AND REF(A31,1)=0.2 AND REF(COUNT(A31=0.2,10)=10,1)=1)*(-0.1);
A33:=A32=(-0.1);
A34:=A28 OR A33;
A35:=DYNAINFO(7)/REF(CLOSE,1)>1.05 AND DYNAINFO(7)/OPEN>1.05;
A36:=VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
A37:=A34 AND CLOSE/REF(CLOSE,1)>1.099 AND A36 AND A35;
A38:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);
A39:=DYNAINFO(4)>0 AND HHV(HIGH,8)/LLV(LOW,8)<2 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15)) AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,120);
A40:=MAX(A8,A9);
A41:=CLOSE>A40 AND A38 AND (CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07);
A42:=A2+A2>A1;
A43:=CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07 AND A39 AND A42;
A44:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>7;
A45:=A39 AND A44;
A46:=A41 AND A45;
A47:=MAX(MAX(MAX(MAX(MAX(A5,A3),A6),A7),A8),A9);
A48:=MIN(MIN(MIN(MIN(MIN(A5,A3),A6),A7),A8),A9);
A49:=CLOSE>A47 AND LOW<A48 AND (CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.09);
A50:=FILTER(A49>0,0)=1;
A51:=MA(REF(HHV(CLOSE,26),1),2);
A52:=POW(CLOSE-A4,2);
A53:=MA(A52,13);
A54:=SQRT(A53);
A55:=A4+2*A54;
A56:=crOSS(CLOSE,A51) AND HIGH>REF(A55,1) OR (CLOSE>A51 AND CROSS(CLOSE,REF(A55,1))) AND CLOSE/OPEN>0.998;
A57:=macd.MacD;
A58:=kd.K;
A59:=KD.D;
A60:=rsi.RSI1;
A61:=RSI.RSI3;
A62:=CLOSE-REF(CLOSE,1);
A63:=IF(A62>=0,A62,0);
A64:=IF(A62<0,-A62,0);
A65:=MEMA(A63,10);
A66:=MEMA(A64,10);
A67:=MEMA(A63,6);
A68:=MEMA(A64,6);
A69:=MA(100*A65/(A65+A66),10);
A70:=MA(100*A67/(A67+A68),6);
A71:=MA(CLOSE,5)/MA(CLOSE,10)>0.999 AND MA(CLOSE,10)/MA(CLOSE,20)>0.9847 AND MA(CLOSE,20)>MA(CLOSE,60) AND REF(COUNT(MA(CLOSE,10)/MA(CLOSE,20)<1.017 OR MA(CLOSE,5)/MA(CLOSE,10)<1.017,8)>=1,1) AND MA(CLOSE,20)/MA(CLOSE,60)<1.121;
A72:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
A73:=COUNT(A72<35,100)>=95;
A74:=A56 AND A71>0 AND NOT(DYNAINFO(4)=0) AND A73 AND REF(COUNT(MA(CLOSE,20)>MA(CLOSE,30),4)=4 AND COUNT(CLOSE>MA(CLOSE,5),3)>=2,1)
AND VOL>REF(VOL,1) AND (REF(COUNT(CLOSE>OPEN,10)>=6 OR COUNT(CLOSE>OPEN,5)>=4,1) OR CLOSE=HIGH) AND (CROSS(A70,A69) OR CROSS(A57,0)
OR REF(COUNT(CROSS(A57,0),3)=1 AND A57<0.15 AND CLOSE/OPEN>0.989 AND CLOSE/REF(CLOSE,1)<1.03,1) OR CROSS(A58,A59)
OR CROSS(A60,A61)) AND REF(CLOSE/OPEN>0.988 AND (CLOSE>OPEN OR (CLOSE<=OPEN AND HIGH/LOW<1.049)),1) AND HIGH/CLOSE<1.013 AND CLOSE/OPEN>1.05;
A75:=A41+A43+A45+A50+A74>=2;
A76:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,60) AND MA(CLOSE,60)>MA(CLOSE,120) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
A77:=CLOSE>REF(CLOSE,1)*1.1-0.01;
A78:=HHV(HIGH,20)=HHV(CLOSE,1) AND VOL>0 AND BARSCOUNT(CLOSE)>=20;
A79:=VOL/REF(VOL,1)>1.9;
A80:=A76 AND A77 AND A78 AND A79;
A81:=CLOSE/REF(CLOSE,1)>1.05 AND REF(CLOSE,1)/REF(CLOSE,2)<1.05 AND CLOSE/LLV(CLOSE,10)<1.4;
A82:=VOL/REF(VOL,1)>2 OR VOL=HHV(VOL,15);
A83:=CAPITAL<10000000;
A84:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*57.299999>40;
A85:=ATAN((MA(CLOSE,10)/REF(MA(CLOSE,10),1)-1)*100)*57.299999>30;
A86:=ATAN((MA(CLOSE,20)/REF(MA(CLOSE,20),1)-1)*100)*57.299999>20;
A87:=ATAN((MA(CLOSE,30)/REF(MA(CLOSE,30),1)-1)*100)*57.299999>10;
A88:=A84 AND A85 AND A86 AND A87;
A89:=kdj.K>REF(KDJ.K,1);
A90:=KDJ.D>REF(KDJ.D,1) AND KDJ.D<70;
A91:=KDJ.J>REF(KDJ.J,1);
A92:=A89 AND A90 AND A91;
A93:=A8 AND A81 AND A82 AND A83 AND A88 AND A92;
A94:=FILTER(A93,15);
A95:=A80 OR A94;
A96:=A95 AND A75 OR A50 OR A46;
突破龙头:A96 OR A39 OR A37,COLORRED;

通达信突破龙头选股指标公式源码副图

通达信突破龙头选股指标公式源码副图



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识