当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信豪杰突破副图指标公式源码(无源码的请下载附件导入)

DRAWKLINE(H,O,L,C);
低天:=15;
高天:=5;
CURR:=CURRBARSCOUNT;
高低:=DRAWLINE(CURR=高天,H,CURR=低天,L,0);
低高:=DRAWLINE(CURR=低天,L,CURR=高天,H,0);
高低线:=IF(高天>低天,高低,低高);
IF(CURR=高天,H,IF(CURR=低天,L,IF(CURR=ROUND((低天+高天)/2),高低线,DRAWNULL))),COLORAA00AA,CROSSDOT,LINETHICK3;
SH:=CONST(REF(H,BARSLAST(CURR=高天)));
SL:=CONST(REF(L,BARSLAST(CURR=低天)));
高低距:=SH-SL;
天距:=ABS(低天-高天);
PR:=ABS(低天-高天)/2+IF(高天>低天,低天,高天);
RN:(SH+SL)/2;
Y弧:=(SH*SL);{半径}
BX:=2*(SH*SL)/天距;
BY:=(SH*SL)/高低距;
XW:=IF(CURR<PR,PR-CURR,CURR-PR)*BX;
SY:=IF(XW<Y弧,SQRT(Y弧*Y弧-XW*XW),0)/BY;
Y震谱1:=IF(高天<低天,RN+SY,RN-SY),COLORRED;
Y震谱2:=IF(高天<低天,RN-SY,RN+SY),COLORRED;
高点:HHV(Y震谱1,10),COLORMAGENTA,LINETHICK2;
XW11:IF(REF(Y震谱1,1)<高点,高点,高点),COLORYELLOW;
{低点:LLV(Y震谱1,(SH*SL)*2);
XW112:IF(REF(Y震谱1,1)>Y震谱1,Y震谱1,低点);}

 
DRAWNUMBER(ISLASTBAR ,高点+0.05,高点),COLORYELLOW;

 
Y弧1:=(SH*SL)/2;{半径}
BX1:=2*(SH*SL)/天距;
BY1:=(SH*SL)/高低距;
XW1:=IF(CURR<PR,PR-CURR,CURR-PR)*BX1;
SY1:=IF(XW<Y弧,SQRT(Y弧1*Y弧1-XW1*XW1),0)/BY1;
Y震谱3:=IF(高天<低天,RN+SY1,RN-SY1),COLORRED;
Y震谱4:=IF(高天<低天,RN-SY1,RN+SY1),COLORRED;
高点1:HHV(Y震谱3,10),COLORBLUE;
XW111:IF(REF(Y震谱3,1)<高点1,高点1,高点1);
XG:=CROSS(C,高点) OR CROSS(C,高点1) AND V/REF(MA(V,5),1)>1.2;
DRAWTEXT(CURRBARSCOUNT<10 AND XG ,L,'━ ━豪杰突破'),COLORYELLOW;

 

 
角线:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
角线MA:=MA(角线,5);
ANA:=PLOYLINE(CROSS(角线,角线MA),角线MA),COLORRED;
ANB:=PLOYLINE(CROSS(角线MA,角线),角线MA),COLORFF00FF ;
角买点:=CROSS(角线,角线MA) AND ((ANB>REF(ANB,1) AND ANB>ANA AND 角线MA<=0) OR ((角线MA<=-45 OR CROSS(角线MA,-45)) AND (ANB<-60 OR LLV("KDJ.J",3)<=-49) AND ANB>0)),COLORGREEN;
DRAWTEXT(角买点,L,'━━买呗'),COLOR00FFFF;

 
MA35:=MA(V,35);
下斜线:=DRAWLINE(V>=HHV(V,20),V,V<=LLV(V,10),HHV(V,6),1),COLORLIMAGENTA,LINETHICK1;
上穿:=CROSS(MA35,下斜线);
DRAWICON((上穿),L,27);

 
HB:=COST(99.9);
 LB:=COST(0.1);
 B3:=(HB-LB)/50;
 B31:=HB-B3;
 B32:=HB-2*B3;
 B33:=HB-3*B3;
 B34:=HB-4*B3;
 B35:=HB-5*B3;
 B36:=HB-6*B3;
 B37:=HB-7*B3;
 B38:=HB-8*B3;
 B39:=HB-9*B3;
 B310:=HB-10*B3;
 B311:=HB-11*B3;
 B312:=HB-12*B3;
 B313:=HB-13*B3;
 B314:=HB-14*B3;
 B315:=HB-15*B3;
 B316:=HB-16*B3;
 B317:=HB-17*B3;
 B318:=HB-18*B3;
 B319:=HB-19*B3;
 B320:=HB-20*B3;
 B321:=HB-21*B3;
 B322:=HB-22*B3;
 B323:=HB-23*B3;
 B324:=HB-24*B3;
 B325:=HB-25*B3;
 B326:=HB-26*B3;
 B327:=HB-27*B3;
 B328:=HB-28*B3;
 B329:=HB-29*B3;
 B330:=HB-30*B3;
 B331:=HB-31*B3;
 B332:=HB-32*B3;
 B333:=HB-33*B3;
 B334:=HB-34*B3;
 B335:=HB-35*B3;
 B336:=HB-36*B3;
 B337:=HB-37*B3;
 B338:=HB-38*B3;
 B339:=HB-39*B3;
 B340:=HB-40*B3;
 B341:=HB-41*B3;
 B342:=HB-42*B3;
 B343:=HB-43*B3;
 B344:=HB-44*B3;
 B345:=HB-45*B3;
 B346:=HB-46*B3;
 B347:=HB-47*B3;
 B348:=HB-48*B3;
 B349:=HB-49*B3;
 A1:=WINNER(HB)*100-WINNER(B31)*100;
 A2:=WINNER(B31)*100-WINNER(B32)*100;
 A3:=WINNER(B32)*100-WINNER(B33)*100;
 A4:=WINNER(B33)*100-WINNER(B34)*100;
 A5:=WINNER(B34)*100-WINNER(B35)*100;
 A6:=WINNER(B35)*100-WINNER(B36)*100;
 A7:=WINNER(B36)*100-WINNER(B37)*100;
 A8:=WINNER(B37)*100-WINNER(B38)*100;
 A9:=WINNER(B38)*100-WINNER(B39)*100;
 A10:=WINNER(B39)*100-WINNER(B310)*100;
 A11:=WINNER(B310)*100-WINNER(B311)*100;
 A12:=WINNER(B311)*100-WINNER(B312)*100;
 A13:=WINNER(B312)*100-WINNER(B313)*100;
 A14:=WINNER(B313)*100-WINNER(B314)*100;
 A15:=WINNER(B314)*100-WINNER(B315)*100;
 A16:=WINNER(B315)*100-WINNER(B316)*100;
 A17:=WINNER(B316)*100-WINNER(B317)*100;
 A18:=WINNER(B317)*100-WINNER(B318)*100;
 A19:=WINNER(B318)*100-WINNER(B319)*100;
 A20:=WINNER(B319)*100-WINNER(B320)*100;
 A21:=WINNER(B320)*100-WINNER(B321)*100;
 A222:=WINNER(B321)*100-WINNER(B322)*100;
 A23:=WINNER(B322)*100-WINNER(B323)*100;
 A24:=WINNER(B323)*100-WINNER(B324)*100;
 A25:=WINNER(B324)*100-WINNER(B325)*100;
 A26:=WINNER(B325)*100-WINNER(B326)*100;
 A27:=WINNER(B326)*100-WINNER(B327)*100;
 A28:=WINNER(B327)*100-WINNER(B328)*100;
 A29:=WINNER(B328)*100-WINNER(B329)*100;
 A30:=WINNER(B329)*100-WINNER(B330)*100;
 A31:=WINNER(B330)*100-WINNER(B331)*100;
 A32:=WINNER(B331)*100-WINNER(B332)*100;
 A33:=WINNER(B332)*100-WINNER(B333)*100;
 A34:=WINNER(B333)*100-WINNER(B334)*100;
 A35:=WINNER(B334)*100-WINNER(B335)*100;
 A36:=WINNER(B335)*100-WINNER(B336)*100;
 A37:=WINNER(B336)*100-WINNER(B337)*100;
 A38:=WINNER(B337)*100-WINNER(B338)*100;
 A39:=WINNER(B338)*100-WINNER(B339)*100;
 A40:=WINNER(B339)*100-WINNER(B340)*100;
 A41:=WINNER(B340)*100-WINNER(B341)*100;
 A42:=WINNER(B341)*100-WINNER(B342)*100;
 A43:=WINNER(B342)*100-WINNER(B343)*100;
 A44:=WINNER(B343)*100-WINNER(B344)*100;
 A45:=WINNER(B344)*100-WINNER(B345)*100;
 A46:=WINNER(B345)*100-WINNER(B346)*100;
 A47:=WINNER(B346)*100-WINNER(B347)*100;
 A48:=WINNER(B347)*100-WINNER(B348)*100;
 A49:=WINNER(B348)*100-WINNER(B349)*100;
 A50:=WINNER(B349)*100-WINNER(LB)*100;
ZX1:=MAX(A1*15,MAX(A2*15,MAX(A3*15,MAX(A4*15,MAX(A5*15,MAX(A6*15,MAX(A7*15,MAX(A8*15,MAX(A9*15,MAX(A10*15,MAX(A11*15,MAX(A12*15,MAX(A13*15,MAX(A14*15,MAX(A15*15,MAX(A16*15,MAX(A17*15,MAX(A18*15,MAX(A19*15,MAX(A20*15,MAX(A21*15,MAX(A222*15,MAX(A23*15,MAX(A24*15,MAX(A25*15,MAX(A26*15,MAX(A27*15,MAX(A28*15,MAX(A29*15,MAX(A30*15,MAX(A31*15,MAX(A32*15,MAX(A33*15,MAX(A34*15,MAX(A35*15,MAX(A36*15,MAX(A37*15,MAX(A38*15,MAX(A39*15,MAX(A40*15,MAX(A41*15,MAX(A42*15,MAX(A43*15,MAX(A44*15,MAX(A45*15,MAX(A46*15,MAX(A47*15,MAX(A48*15,MAX(A49*15,A50*15)))))))))))))))))))))))))))))))))))))))))))))))));
筹码最集中处:=COST(ZX1/15);
上穿11:=CROSS(C,筹码最集中处);
DRAWICON((上穿11),L-0.06,11);

通达信豪杰突破副图指标公式源码

通达信豪杰突破副图指标公式源码



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识