当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信分时超短打板主图指标公式源码(无源码的请下载附件导入)

A1:=(Dvol/C)/2,NODRAW;
A2:=SUM(IF(A1>100 AND CLOSE>REF(CLOSE,1),A1,0),0);
A3:=SUM(IF(A1>100 AND CLOSE<REF(CLOSE,1),A1,0),0);
A4:=SUM(IF(A1<100 AND CLOSE>REF(CLOSE,1),A1,0),0);
A5:=SUM(IF(A1<100 AND CLOSE<REF(CLOSE,1),A1,0),0);
A6:=A2+A3+A4+A5;
A7:=IF((BARstATUS=2),((100*A2)/A6),0);
A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));
A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));
A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));
机构买盘:=(A2),LINETHICK2;
机构卖盘:=(A3),LINETHICK2;
散户买盘:=(A4);
散户卖盘:=(A5);
机构买:=(A2),LINETHICK6,COLORRED;
机构卖:=(A3),LINETHICK6,COLORGREEN;
DD1:=1;
AAA1:=STRCAT(STRCAT('机构买',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖',CON2STR((100*A3)/A6,0)),'%');
AAA3:=STRCAT(STRCAT('净买入',CON2STR((100*(A2-A3))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.04,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.12,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0,0.20,0,AAA3),COLOR00FFFF;
{以上是机构买卖数据,净买入考虑做多,净卖出逢高卖出}
{分时超短打板主图指标公式}
X_0:HHV(H,480),DOTLINE,COLORCYAN;
X_1:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
X_2:=BArslAST((X_1-REF(X_1,1))!=WEEkdAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
X_3:=REF(C,X_2);
X_4:=REF(X_3,X_2);
X_5:=REF(X_4,X_2);
X_6:=REF(X_5,X_2);
X_7:=REF(X_6,X_2);
X_8:=REF(X_7,X_2);
X_9:=REF(X_8,X_2);
X_10:=REF(X_9,X_2);
X_11:=REF(X_10,X_2);
X_12:=maX(DYNAINFO(3),DYNAINFO(5));
X_13:=MIN(DYNAINFO(3),DYNAINFO(6));
X_14:=X_12-X_13;
X_15:X_13+X_14*8/9,COLORLIRED,DOTLINE;
X_16:X_13+X_14*0.5/9,COLORGREEN,DOTLINE;
X_17:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW,DOTLINE;
X_18:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);
X_19:=EMA(X_18,9);
X_20:=10*(X_18-X_19);
X_21:=EMA(X_20,2);
STICKLINE(X_20>=X_21 AND X_20>=0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLIGRAY;
STICKLINE(X_20<X_21 AND X_20>0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLICYAN;
STICKLINE(X_20>=X_21 AND X_20<0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLIGRAY;
STICKLINE(X_20<X_21 AND X_20<0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLIGREEN;
X_22:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
X_23:=expma(CLOSE/X_22,20);X_24:=EXPMA(CLOSE/X_22,60);X_25:=EXPMA(CLOSE/X_22,120);
X_26:=1;1.022,NODRAW;X_27:=1.033;
DRAWTEXT(crOSS(X_23,1.02),C*0.999,' 拉'),COLORMAGENTA,LINETHICK9;
DRAWICON(CROSS(X_23,1.04),C,45);
DRAWTEXT(CROSS(X_23,1.04),C*0.999,' 冲'),COLORRED,LINETHICK9;
X_28:=(VOL/CLOSE)/3;
X_29:=SUM((IF(((X_28>40) AND (CLOSE>(REF(CLOSE,1)))),X_28,0)),0);
X_30:=SUM((IF(((X_28>40) AND (CLOSE<(REF(CLOSE,1)))),X_28,0)),0);
X_31:=SUM((IF(((X_28<40) AND (CLOSE>(REF(CLOSE,1)))),X_28,0)),0);
X_32:=SUM((IF(((X_28<40) AND (CLOSE<(REF(CLOSE,1)))),X_28,0)),0);
X_33:=((X_29+X_30)+X_31)+X_32;
X_34:=IF((BARSTATUS=2),((100*X_29)/X_33),0);
X_35:=((IF((BARSTATUS=2),((100*X_30)/X_33),0)));
X_36:=((IF((BARSTATUS=2),((100*X_31)/X_33),0)));
X_37:=((IF((BARSTATUS=2),((100*X_32)/X_33),0)));
DRAWTEXT(LONGCROSS(X_16,C,2),C-0.01,'满仓买入'),COLORRED,LINETHICK9;
DRAWICON(LONGCROSS(X_16,C,2),C-0.01,1);
STICKLINE(LONGCROSS(X_16,C,2),C,X_15,0,-1),COLORCYAN;
DRAWTEXT(LONGCROSS(C,X_15,2),C+0.01,'卖出'),COLORGREEN,LINETHICK9;
DRAWICON(LONGCROSS(C,X_15,2),C+0.01,45);



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识