当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信资金流分时主图指标公式源码(无源码的请下载附件导入)

通达信资金流分时主图指标公式源码

{资金流量 攻击流量}
{DRAWGBK(1,RGB(0,0,0),RGB(0,0,0),0,'019',0);}
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),stICK,COLORRED;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;
资金出入:=资金流入+资金流出,COLORSTICK;
资金流量:=资金出入,COLORFFFFFF,LINETHICK1;
资金比:=资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-Abs((资金比-100)/2));
增强流量比:=IF(资金流量比>50,资金流量比,50);
攻击量:=((HSL*0.50+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),COLOR0000FF,LINETHICK0;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;
攻击流量:=攻击量A+攻击量B,COLORSTICK;
NOTEXT攻击线:=攻击流量,COLORYELLOW,LINETHICK1;
攻击比:=攻击流量/SUM(V,FROMOPEN)*100,COLORRED,LINETHICK1;
资金攻击度:=IF(攻击比>0,(攻击比+50),100-ABS((攻击比-50)));
攻击度限制:=IF(资金攻击度>100,100,IF(资金攻击度<0,0,资金攻击度));
增强攻击度:=IF(资金攻击度>50,资金攻击度,50);
开始攻击:=crOSS(攻击流量,0) AND (C>REF(C,2) OR (资金流量>0 AND 资金流量>攻击流量));
开始攻击量:=CROSS(攻击流量,0) AND C>REF(C,2) AND V>LLV(V,3)*3;
Q:=250;
高点:=HHV(C,Q);
低点:=LLV(C,Q);
最高:=CONST(高点),NODRAW;
最低:=CONST(低点),NODRAW;
轴差:=最高-最低;
中价轴:=(最高+最低)/2;
HL3:=(100-0)/2*1.3;
HL4:=(100-0)/1*1.3;
中间价轴:=(50-HL3)*轴差/HL4+中价轴;
平安轴:=(中价轴+中间价轴)/2;
{BGTYU:=IF(DATE<=9991231,1,0);意思是日间小于等于9991231时值为1,否则为0 }
BGTYU:=1;
GHYJKU:=BETWEEN((CLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((CLOSE*BGTYU)))/SUM(vol*100,BARSCOUNT((CLOSE*BGTYU)))),1.05,0.95);
VBNH:=IF(GHYJKU=0,ma((CLOSE*BGTYU),BARSCOUNT((CLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((CLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((CLOSE*BGTYU)))));
起动线:=expma((CLOSE/VBNH),20)*1,COLORYELLOW,POINTDOT;
主力线:=EXPMA((CLOSE/VBNH),60)*1,COLORMAGENTA,LINETHICK2;
散户线:=EXPMA((CLOSE/VBNH),120)*1,COLORGREEN,LINETHICK2;
限制起动线:=起动线*中间价轴;
限制主力线:=主力线*中间价轴;
限制散户线:=散户线*中间价轴;
主散MIN:=MIN(限制主力线,限制散户线);
{分时转强:=主散MIN>金龙线 AND ((LONGCROSS(限制主力线,金龙线,2) OR CROSS(限制主力线,限制散户线)) OR (限制主力线>限制散户线 AND LONGCROSS(牵引线,金龙线,2)));}
{DRAWBAND(限制主力线,RGB(250,125,0),限制散户线,RGB(0,100,250));
STICKLINE(起动线<主力线,限制起动线,限制主力线,1.0,0),COLOR00FF00;
STICKLINE(起动线>主力线,限制起动线,限制主力线,1.0,0),COLORFFFFFF;
STICKLINE(VOL>EMA(VOL,60) AND 起动线>主力线,限制起动线,限制主力线,1,0),COLORFF00FF;
STICKLINE(VOL>EMA(VOL,30) AND 起动线>主力线 AND 起动线>1.01 AND 起动线>REF(起动线,1),限制起动线,限制主力线,1,0),COLOR00FFFF;}
主力:限制主力线,DOTLINE,COLORFF00FF,LINETHICK1;
分时均价线:=SUM(C*V,240)/SUM(V,240),DOTLINE,COLORFFFFFF,LINETHICK1;
追击涨停:=限制散户线>分时均价线 AND CROSS(C,限制散户线);
拉升量:=IF(C>REF(C,1),VOL,0);
昨拉升最高值:=CONST(FINDHIGH(拉升量,FROMOPEN,240,1)),LINETHICK1,COLORMAGENTA;
今拉升最高值:=CONST(REF(HHV(拉升量,FROMOPEN),0)),COLORYELLOW,NODRAW;
攻击力度:=今拉升最高值/昨拉升最高值,NODRAW;
TT:=BARSCOUNT(C);{取得有效收盘价}
均价黄:=SUM(C*V,TT)/SUM(V,TT);{分时均线的取值}
量两步:=MA(V,5)>REF(MA(V,5),1) AND REF(MA(V,5),1)>REF(MA(V,5),2);
价两步:= C>=REF(C,1) AND REF(C,1)>REF(C,2);
价上岗量破5:=C>均价黄 AND V>MA(V,5);
量起爆:=V>=REF(V,1)*1 ;
价创新高:=C>=HHV(C,0);
量创新高:=V>=HHV(V,0);
对昨日涨幅:=(C/DYNAINFO(3)-1)*100<=2.50;{涨幅控制2个点以内}
每日一点:=量两步 AND 价两步 AND 价上岗量破5 AND 量起爆 AND 价创新高 AND 量创新高 AND 对昨日涨幅;
TA:=BArslAST(TIME=100000);
TC:=REF(HHV(C,0),TA+1);
TV:=REF(HHV(V,0),TA+1);
ZF:=C/DYNAINFO(3)<1.05;
XG1:=CROSS(C,TC) AND V>TV AND ZF,COLORWHITE;
TA1:=BARSLAST(TIME=110000);
CC1:=REF(HHV(C,0),TA1+1);
VV1:=REF(HHV(V,0),TA1+1);
ZF1:=CC1/DYNAINFO(3)<1.05;
XG2:=CROSS(C,CC1) AND V>VV1 AND ZF1,COLORYELLOW;
突破:=XG1 OR XG2,COLORRED;
STICKLINE(FILTER(突破=1,15),最低+轴差*0.60,最低,1,0),COLORWHITE;
DRAWICON(FILTER(突破=1,15),最低+轴差*0.60,17);
DRAWTEXT(FILTER(突破=1,15),最低+轴差*0.60,'∠分时突破'),COLORWHITE;
STICKLINE(FILTER(开始攻击量=1,15),最低+轴差*0.45,最低,1,0),COLORMAGENTA;
STICKLINE(FILTER(开始攻击=1,30),最低+轴差*0.30,最低,1,0),COLORYELLOW;
STICKLINE(CROSS(EXPMA((CLOSE/VBNH),60),EXPMA((CLOSE/VBNH),120)),最低+轴差*0.15,最低,1,0),COLORCYAN;
DRAWICON(FILTER(开始攻击量=1,15),最低+轴差*0.45,24);
DRAWICON(FILTER(开始攻击,30),最低+轴差*0.30,30);
DRAWTEXT(FILTER(开始攻击量=1,15),最低+轴差*0.45,'∠攻击量'),COLORMAGENTA;
DRAWTEXT(FILTER(开始攻击,30),最低+轴差*0.30,'开始攻'),COLORYELLOW;
DRAWTEXT(FILTER(CROSS(EXPMA((CLOSE/VBNH),60),EXPMA((CLOSE/VBNH),120)),30),最低+轴差*0.15,'★迹'),COLORCYAN;
DRAWICON(FILTER(CROSS(起动线,1.01),30),限制散户线,17);
DRAWTEXT(FILTER(CROSS(起动线,1.01),30),最低,'可能涨停'),COLORMAGENTA;
DRAWTEXT(FILTER(追击涨停,30),分时均价线+(限制散户线-分时均价线)/2,'追击'),COLORRED;
{自己加入的}
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORMAGENTA;
DRAWTEXT(LONGCROSS(支撑,C,2),C,'--买入'),COLORFF00FF;
DRAWTEXT(LONGCROSS(C,阻力,2),C,'--出货'),COLOR70DB93;
XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主攻:=EXPMA(CLOSE/XX,20);
大户:=EXPMA(CLOSE/XX,60);
散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;
高:=1.03;
AA:=主攻>大户 AND 主攻>1.003 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60);
DRAWICON(主攻>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主攻=HHV(主攻,30) AND CROSS(主攻,1.003),C,38);
DRAWTEXT(主攻>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主攻=HHV(主攻,30) AND CROSS(主攻,1.003),C*0.999,'-主攻'),COLORYELLOW;
{DRAWICON(CROSS(主力,1.02),C,24);}
DRAWTEXT(CROSS(主攻,1.02),C*0.999,'--拉升'),COLORCYAN;
{DRAWICON(CROSS(主力,1.04),C,6);}
DRAWTEXT(CROSS(主攻,1.04),C*0.999,'--冲涨停'),COLORLIMAGENTA;
{DRAWICON(CROSS(散户,主力),C,6);}
DRAWTEXT(CROSS(散户,主攻),C*0.9995,'--小心'),COLORGREEN;
{DRAWICON(CROSS(散户,大户),C,6);}
DRAWTEXT(CROSS(散户,大户),C*0.9995,'--走弱'),COLORGREEN;
{均价:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;
DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),120),1.0029),均价,'观察分时量 '),COLORCYAN;
DRAWICON(CROSS(EXPMA((DCLOSE/VBNH),120),1.004),均价,13);}
成交额:=V*C/100,NODRAW;{万元}
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=(A2+A3);
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
DD1:=1;
AAA1:=STRCAT(STRCAT('机构买 = ',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖 = ',CON2STR((100*A3)/A6,0)),'%');
AAA3:=STRCAT(STRCAT('机构总买 = ',CON2STR((100*(A2-A3))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.89,0,AAA1),COLOR00FFFF;
DRAWTEXT_FIX(DD1=1,0,0.945,0,AAA2),COLOR00FF00;
现手买:=BUYVOL*DYNAINFO(7)*100/10000 COLOR0000FF,NODRAW;
现手卖:=SELLVOL*DYNAINFO(7)*100/10000 COLOR00FF00,NODRAW;
合:=ABS(现手买)+ABS(现手卖)COLOR80FFFF,NODRAW;
差:=ABS(现手买)-ABS(现手卖)COLOR80FFFF,NODRAW;
MPB1:=ABS(现手买)/合*100;
MPB2:=ABS(现手卖)/合*100;
TESTSKIP(NOT(现手买 OR 现手卖 OR 合 OR 差 OR MPB1 OR MPB2)!=0);
DRAwrECTREL(640,1000,940,940,RGB(190,190,190));
DRAWRECTREL(640,995,940,945,RGB(200,200,200));
DRAWRECTREL(640,990,940,950,RGB(210,210,210));
DRAWRECTREL(640,985,940,955,RGB(220,220,220));
DRAWRECTREL(640,980,940,960,RGB(230,230,230));
DRAWRECTREL(640,975,940,965,RGB(240,240,240));
DRAWRECTREL(640,970,940,970,RGB(250,250,250));
DRAWRECTREL(790-现手卖*210/合,1000,790,940,RGB(0,128,0));
DRAWRECTREL(790-现手卖*210/合,995,790,945,RGB(0,148,0));
DRAWRECTREL(790-现手卖*210/合,990,790,950,RGB(0,168,0));
DRAWRECTREL(790-现手卖*210/合,985,790,955,RGB(0,188,0));
DRAWRECTREL(790-现手卖*210/合,980,790,960,RGB(0,208,0));
DRAWRECTREL(790-现手卖*210/合,975,790,965,RGB(0,228,0));
DRAWRECTREL(790-现手卖*210/合,970,790,970,RGB(0,248,0));
DRAWRECTREL(790-现手卖*210/合,940,790-现手卖*210/合,1000,RGB(0,128,0));
DRAWRECTREL(790,1000,790+现手买*210/合,940,RGB(128,0,0));
DRAWRECTREL(790,995,790+现手买*210/合,945,RGB(148,0,0));
DRAWRECTREL(790,990,790+现手买*210/合,950,RGB(168,0,0));
DRAWRECTREL(790,985,790+现手买*210/合,955,RGB(188,0,0));
DRAWRECTREL(790,980,790+现手买*210/合,960,RGB(208,0,0));
DRAWRECTREL(790,975,790+现手买*210/合,965,RGB(228,0,0));
DRAWRECTREL(790,970,790+现手买*210/合,970,RGB(248,0,0));
DRAWRECTREL(790+现手买*210/合,940,790+现手买*210/合,1000,RGB(128,0,0));
DRAWRECTREL(789.8,940,790.2,1000,RGB(0,0.0,10));
DRAWRECTREL(639.8,940,640.2,1000,RGB(0,0,10));
DRAWRECTREL(939.8,940,940.2,1000,RGB(0,0,10));
DRAWRECTREL(0,940,1000,940.2,RGB(0,0,10));
DRAWTEXT_FIX(1,0.8,0.88,0,STRCAT(STRCAT('',CON2STR(现手买,2)),'万')),COLOR0000FF;
DRAWTEXT_FIX(1,0.68,0.88,0,STRCAT(STRCAT('',CON2STR(现手卖,2)),'万')),COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)>0,0.755,1.88,0,STRCAT(' ',STRCAT(CON2STR(差,2),'万'))) COLOR00FFFF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)<0,0.755,1.88,0,STRCAT(' ',STRCAT(CON2STR(差,2),'万'))) COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)=0,0.755,1.88,0,STRCAT(' ',STRCAT(CON2STR(差,2),'万'))) COLOR80FFFF;
DRAWTEXT_FIX(1,0.935,0.97,0,STRCAT(STRCAT(' ',CON2STR(MPB2,2)),'%')),COLOR00FF00;
DRAWTEXT_FIX(1,0.585,0.97,0,STRCAT(STRCAT('',CON2STR(MPB1,2)),'%')),COLOR0000FF;
{DRAWTEXT_FIX(1,0.05,0.1,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.12,0.1,0,DYBLOCK)COLORRED;
DRAWTEXT_FIX(1,0.05,0.14,0,GNBLOCK)COLOR0000FF;
DRAWTEXT_FIX(1,0.05,0.18,0,FGBLOCK)COLORFF00FF;};

 

通达信资金流分时主图指标公式源码



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识