当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信板块和个股强度的排序指标 发现热门票的利器 源码 附图(无源码的请下载附件导入)

建议最好先用选股公式选出自已想看的票再排序,这样排序速度更快

强度排序源码

今开%:(O/REF(C,1)-1)*100,NODRAW;

竞价量:=DYNAINFO(15)/DYNAINFO(4)/100,NODRAW;
ZF:=(DYNAINFO(4)/DYNAINFO(3)-1)*100;
LTP:=IF(CAPITAL<120000,120000,CAPITAL);
竞绝杀:(ZF*竞价量/LTP*10000)/100,NODRAW;

竞价额:DYNAINFO(15)/10000,NODRAW;

ZTS:=COUNT(C/REF(C,1)>1.0985,120);                                                                                                                                                                                               
涨停基因评分:=IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND ZTS>=20,85,                                      
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,17,20),80,                                
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,14,18),75,                                
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,11,15),70,                                
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,10,13),65,                                
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,8,11),60,                                  
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,6,9),55,                                   
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,3,7),50,                                   
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,1,4),45,                                   
IF(C/REF(C,1)>=1.00 AND BARSCOUNT(C)>=20 AND RANGE(ZTS,0,2),35,0))))))))));                                                                                     
基因分:IF(COUNT(C/REF(C,1)>1.0985,60)>=1 AND DYNAINFO(8)>0,涨停基因评分,0),NODRAW;
GOODGUPIAO:SMA(MAX(CLOSE-C,0),7,1)/SMA(ABS(CLOSE-C),7,1)*100,NODRAW;
指数强:(INSUM(HYBLOCK,'强度引用',1,0)),VOLSTICK,COLORRED;

连续涨停:=IF(O=C AND C/REF(C,1)>1.095,1,0);
去连续涨停:=COUNT(连续涨停=1,250)<3 ;
五日强:=((C-REF(C,5))/REF(C,5)*100)-((INDEXC-REF(INDEXC,5))/REF(INDEXC,5)*100);
十日强:=((C-REF(C,10))/REF(C,10)*100)-((INDEXC-REF(INDEXC,10))/REF(INDEXO,10)*100);
个股强:IF(去连续涨停 AND 五日强>=5 AND 十日强>=10 AND DYNAINFO(14)>0,指数强*0.5,0),COLORYELLOW;{WWW.GOODGUPIAO.COM}

超短强度:=ATAN((EMA(C,5)/REF(EMA(C,5),1)-1)*100)*57.3;
短期强度:=ATAN((EMA(C,13)/REF(EMA(C,13),1)-1)*100)*57.3;
中期强度:=ATAN((EMA(C,20)/REF(EMA(C,20),1)-1)*100)*57.3;
长期强度:=ATAN((EMA(C,68)/REF(EMA(C,68),1)-1)*100)*57.3;
强评分:((((超短强度/50)+(短期强度/40))+(中期强度/21))+(长期强度/10)),NODRAW;
{超强风口:(强评分>=10);
强风口:((强评分>8) && (强评分<10);
当日风口:((强评分>1.8) && (强评分<=8));}
强变化:强评分-REF(强评分,1),NODRAW;

行业:DRAWTEXT_FIX(1,0.03,0,0,HYBLOCK),NODRAW;

强度引用源码

{指数强度}
当日强:=(C-REF(C,1))/REF(C,1)*100-(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
五日强:=((C-REF(C,5))/REF(C,5)*100)-((INDEXC-REF(INDEXC,5))/REF(INDEXC,5)*100);
十日强:=((C-REF(C,10))/REF(C,10)*100)-((INDEXC-REF(INDEXC,10))/REF(INDEXC,10)*100);
五日条件:=五日强>=5 AND 五日强>=REF(五日强,1)  AND 十日强>=5;
十日条件:=十日强>=10 ;
五日条件 OR 十日条件 ;

通达信板块和个股强度的排序指标 发现热门票的利器 源码 附图



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识