当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信快乐主升指标公式源码副图(无源码的请下载附件导入)

EA:0,COLORWHITE;EB:=100;FA:=5;FB:=15;FC:=ma(C,3);FD:=MA(C,10);FE:=MA(C,20);FF:=MA(C,30);FG:=MA(C,60);
FH:=Abs(FC-FD)/MIN(FC,FD);FI:=ABS(FC-FE)/MIN(FC,FE);FJ:=ABS(FC-FF)/MIN(FC,FF);
FK:=ABS(FE-FD)/MIN(FE,FD);FL:=ABS(FF-FD)/MIN(FF,FD);FM:=ABS(FE-FF)/MIN(FE,FF);
FN:=MAX(MAX(MAX(FH,FI),MAX(FJ,FK)),MAX(FL,FM))*100,LINETHICK2;FO:=ema(FN,3),COLORBLUE;
FP:=HHV(FO,2)>FB AND C<FF AND REF(FO,2)<REF(FO,1) AND REF(FO,1)>=FO;FQ:=HHV(FO,2)>FB AND C>FF AND REF(FO,2)<REF(FO,1) AND REF(FO,1)>=FO;
FR:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;FS:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
FT:=(SMA(FS,3,1)-18)*1.55;FU:=SMA(FT,3,1);FV:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
FW:=SMA(FV,10,1);FX:=(EMA(SMA(FW,8,1),34)-25)*2.6;FY:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
FZ:=POW(MA(LOW,5),2)+MA(LOW,5);GA:=POW(MA(HIGH,5),2)+MA(HIGH,5);GB:=((FY-LLV(FZ,64))/(HHV(GA,64)-LLV(FZ,64))*150+65-10)/2;
GC:=SMA(GB,3,1)*1.5-46;GD:=SMA(GC,3,1);GE:=3*GC-2*GD;GF:=(FR+FS+FV)/3;GG:=((FT+FT+FW+GC)/4-15)*1.67;GH:=((FU+FU+FX+GD)/4-15)*1.67;
GJ:=(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5))*(-1)+0.9;GK:=(HHV(H,10)-C)/(HHV(H,10)-LLV(L,10))*(-1)+0.92;
GL:=(HHV(H,15)-C)/(HHV(H,15)-LLV(L,15))*(-1)+0.93;GM:=(HHV(H,55)-C)/(HHV(H,55)-LLV(L,55))*(-1)+0.94;
GN:=(HHV(H,89)-C)/(HHV(H,89)-LLV(L,89))*(-1)+0.95;GO:=(HHV(H,120)-C)/(HHV(H,120)-LLV(L,120))*(-1)+0.91;
SP:=(HHV(H,180)-C)/(HHV(H,180)-LLV(L,180))*(-1)+0.96;SQ:=(((GJ+GK+GL)*8+GM+GN+SP+GO)/28-0.1)*185;
GR:=SMA(SQ,3,1);GS:=(FT+FW+GR*2)/4,COLOR00FFFF ;GT:=SUM((INDEXV-REF(INDEXV,1))/REF(INDEXV,1),66);GU:=SUM((V-REF(V,1))/REF(V,1),66);
GV:=GU-GT;GW:=MA(GU,10);GX:=REF(FG,1)>FG;GY:=REF(FG,1)<FG;GZ:=GY AND COUNT(GY,20)>18 AND HHV(GX,90)=1;
HA:=(HHV(COUNT(GW>GV,30)=30,60)=1 AND GZ AND crOSS(GV,GW) AND FO<12);HB:=(FO<10 AND GV>0 AND GV>2*LLV(GV,10) AND HHV(GS,40)>100);
HI:=100*(C-REF(C,60))/REF(C,60);HJ:=100*(INDEXC-REF(INDEXC,60))/REF(INDEXC,60);HK:SMA(HI-HJ,2,1),COLORstICK;
HL:=V<LLV(V,30)*1.000001;HM:=V>REF(V,1)*3;HN:=HL AND (FG<C OR FG>REF(FG,1));HO:=HM AND (C<FG AND COUNT(FG<REF(FG,1),10)=10);
水草丰盛:IF(((COUNT(C>O,10)>=8) OR (COUNT(C>O,15)>=12)) AND HI<100,20,0),COLORFF00FF,LINETHICK1;
山峰险峻:IF(COUNT(C>O,33)>=24,30,0),LINETHICK2,COLORGREEN;
牛角初露:IF(FO<8 AND GS>95,GS,0),STICK,LINETHICK1,COLORFFFFFF;
快马加鞭:(HA OR HB)*60,STICK,LINETHICK2,COLORYELLOW;
蹄印点点:=COUNT(HK>0 AND MA(INDEXC,60)<REF(MA(INDEXC,60),1),15)=15 AND HHV(C,100)/LLV(C,100)<2;
卧槽马:=COUNT(HK<0 AND FG>REF(FG,1),10)=10;
快乐主升:=HHV(COUNT(HK<0,50)>40,20) AND C>FG AND HK>0;
跃跃欲试:-HK*(FO<5 AND (水草丰盛 OR 牛角初露) AND HK<0 AND HHV(卧槽马,60)),STICK,COLOR111111;
{DRAWICON(FP,FO*1.2,5),COLORRED;
DRAWICON(FQ,FO*1.2,4),COLORGREEN;}
DRAWTEXT(卧槽马 AND REF(NOT(卧槽马),1),-5,'卧槽马');
STICKLINE(FO>FB AND C<FE,FO,FB,6,0),COLOR00FF00;
STICKLINE(FO>FB AND C>FE,FO,FB,6,0),COLORFF0000;
STICKLINE(FO<FA,FO,FA,6,0),COLOR888800;
STICKLINE(HN AND SUM(牛角初露+快马加鞭,30)>1,-5,-10,8,1),COLOR00FFFF,LINETHICK2;
DRAWICON(HO,HK,5),COLORWHITE;
DRAWTEXT(FILTER(COUNT(快乐主升,3)=3 AND REF(NOT(快乐主升),4),10),-9,'快乐主升');
STICKLINE(卧槽马,0,-8,2,0),COLORRED;
STICKLINE(蹄印点点,0,6,2,0),COLORYELLOW;
DRAWTEXT(REF(NOT(蹄印点点),1) AND 蹄印点点,-1,'蹄印点点');
STICKLINE(跃跃欲试,0,-HK,8,1),COLORRED,LINETHICK3;
DRAWICON(HHV(跃跃欲试,60) AND CROSS(FO,5),HK,1);

通达信快乐主升指标公式源码副图

通达信快乐主升指标公式源码副图



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识