当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信多功能量比副图指标 专用版 源码(无源码的请下载附件导入)


D:=ABS(AMOUNT-REF(AMOUNT,1));
E:=SUM(D,5)/5;
F:=REF(SUM(D,250)/250,1);
微元条件1:= E/F>0 AND E/F<3;
FI:=EMA(SLOPE(C,21)*21+C,39);
GI:=EMA(SLOPE(C,21)*21+C,55);
条件2:=EMA(C,3)>FI AND FI>REF(FI,1) AND FI>GI,NODRAW;
MTR:=EXPMEMA(MAX(MAX(ABS(HIGH-LOW),ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),39);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),39);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),39);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(PDI-MDI)/(MDI+PDI)*100,6);
ADXR:=EXPMEMA(ADX,6);
{引用MACD}
DIF:=EMA(CLOSE,19)-EMA(CLOSE,39);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;

ZZ:=(CLOSE*2+H+L)/4,NODRAW;
VA:=IF(CLOSE>REF(ZZ,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=ZZ,0,VA),0);
MAOBV:=MA(OBV,39);
JBB:=EMA(OBV,3)/SUM(VOL,5)*100;
量:IF(K=1,AMOUNT/VOL/IF(CAPITAL,100,10000),AMOUNT/REF(MA(AMOUNT,5),1)),VOLSTICK;
平均线5:MA(量,5);
AG:=EMA(C,3)-FI;
条件调试:=OBV>MAOBV AND DIF>DEA AND PDI>MDI AND AMOUNT/VOL>MA(AMOUNT/VOL,35) AND 条件2 AND (AG-REF(AG,1))/REF(AG,1)>0 AND AMOUNT/VOL>MA(AMOUNT/VOL,250),NODRAW;
堆量:JBB>0 AND OBV>MAOBV AND DIF>DEA AND ADX>ADXR AND (ADX-ADXR)>REF((ADX-ADXR),1) AND MACD>REF(MACD,1) AND EMA(C,3)>FI AND FI>GI  AND PDI>MDI   AND MA(AMOUNT,5)/MA(AMOUNT,250)>1,NODRAW;
爆量: AMOUNT/REF(MA(AMOUNT,5),1)>5,COLORWHITE,NODRAW;
天量:HHV(AMOUNT,0)=AMOUNT,COLORYELLOW,NODRAW;
倍量:微元条件1 AND DIF>DEA AND PDI>MDI AND AMOUNT>MA(AMOUNT,35)  AND AMOUNT/REF(MA(AMOUNT,5),1)>1 AND AMOUNT/REF(MA(AMOUNT,5),1)>1.9,COLORFF00FF,NODRAW;
STICKLINE(爆量>0 ,0,量,3,0),COLORWHITE;
STICKLINE( 堆量>0 AND 爆量=0 ,0,量,3,0),COLORRED;
STICKLINE( 倍量>0 AND 爆量=0 ,0,量,3,0),COLORMAGENTA;
STICKLINE(天量>0 ,0,量,3,0),COLORYELLOW;
 

通达信多功能量比副图指标 专用版 源码

通达信多功能量比副图指标 专用版 源码



关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识