当前位置:→ 公式网 > 通达信公式 > 正文  公式解密、改选股等业务 联系点击查看详情...

以下是通达信龙趋势指标公式 主图 源码(无源码的请下载附件导入)

通达信龙趋势指标公式 主图 源码

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.0,0 ),COLOR99FF99;

STICKLINE(OPEN>=CLOSE,H,L,0,1),COLOR99FF99;

获利比例:WINNER(C)*100,NODRAW,COLORRED;

来势线:=EMA(CLOSE,7)-EMA(CLOSE,21);

福星:=EMA(来势线,7);

必买:=IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,1,-1),COLORYELLOW ,LINETHICK0;

必卖:= IF(PEAKBARS(3,15,1)=1,1,2),COLORWHITE,LINETHICK0;

DRAWTEXT(必卖,H*1.03,'顶' ),COLORGREEN;

DRAWTEXT(必买,L*0.95,'底'),COLORYELLOW;

龙骨:EXPMA(CLOSE,55)COLORGREEN,LINETHICK2;

龙筋:EXPMA(CLOSE,13)COLORWHITE,LINETHICK2;

MA300:=MA(C,300),NODRAW;

IF(MA300>=REF(MA300,1),龙骨,DRAWNULL),COLORRED,LINETHICK2;

跳空涨停:=1;

TKYY1:=REF(O,1)>REF(C,1) AND O>REF(O+0.01,1) AND C>O AND (V<=REF(V,1) OR V<MA(V,125)) AND C/REF(C,1)<1.098,NODRAW;

TKYY2:=REF(O,1)<REF(C,1) AND O>REF(C,1) AND C>O AND (V<=REF(V,1) OR V<MA(V,125)) AND C/REF(C,1)<1.098,NODRAW;

TKY:=TKYY1 OR TKYY2 ,LINETHICK0;

STICKLINE(TKY,H,L,0,0),COLOR0000FF;

STICKLINE(TKY,C,O,3,0),COLOR000099;

STICKLINE(TKY,C,O,2.5,0),COLOR000099;

STICKLINE(TKY,C,O,2,0),COLOR0000BB;

STICKLINE(TKY,C,O,1,0),COLOR0000DD;

STICKLINE(TKY,C,O,0.3,0),COLOR0000FF;

TKYY3:=REF(O,1)>REF(C,1) AND O>REF(O+0.01,1) AND C>O AND (V<=REF(V,1)*0.66 OR V=LLV(V,125) OR V<MA(V,125)*0.5) AND C/REF(C,1)<1.098;TKYY4:=REF(O,1)<REF(C,1) AND O>REF(C,1) AND C>O AND (V<=REF(V,1)*0.66 OR V=LLV(V,125) OR V<MA(V,125)*0.5) AND C/REF(C,1)<1.098;

LY1:=TKYY3 OR TKYY4 ,LINETHICK0;

STICKLINE(LY1,H,L,0,0),COLOR0000FF;

STICKLINE(LY1,C,O,3,0),COLOR000099;

STICKLINE(LY1,C,O,2.5,0),COLOR000099;

STICKLINE(LY1,C,O,2,0),COLOR0000BB;

STICKLINE(LY1,C,O,1,0),COLOR0000DD;

STICKLINE(LY1,C,O,0.3,0),COLORYELLOW;

LY3:=O>REF(C,1) AND C<O AND V<REF(V,1)*0.55;

STICKLINE(LY3,C,O,3,0),COLOR006600;

STICKLINE(LY3,C,O,2.5,0),COLOR008800;

STICKLINE(LY3,C,O,2,0),COLOR00AA00;

STICKLINE(LY3,C,O,1,0),COLORRED;

STICKLINE(LY3,C,O,0.3,0),COLORRED;

跌停:=C/REF(C,1)<=0.902;

STICKLINE(跌停,H,L,0,1),COLORFFFFFF;

STICKLINE(跌停,C,O,3,0),COLOR555555;

STICKLINE(跌停,C,O,2.5,0),COLOR777777;

STICKLINE(跌停,C,O,2,0),COLOR999999;

STICKLINE(跌停,C,O,1.5,0),COLORBBBBBB;

STICKLINE(跌停,C,O,1,0),COLORDFDFDF;

STICKLINE(跌停,C,O,0.5,0),COLORF0F0F0;

STICKLINE(跌停,C,O,0.1,0),COLORFFFFFF;

SHORT:=7;LONG:=19;

T:=PERIOD;

Z:=IF(T=0,30,{1F}

IF(T=1,25,{5F}

IF(T=8,25,{多分钟}

IF(T=2,20,{15F}

IF(T=3,20,{30F}

IF(T=4,20,{60F}

IF(T=5,10,{日}

IF(T=6,10,{周}

IF(T=7,10,{月}

IF(T=9,10,{多日}

IF(T=10,10{季},10{年})))))))))));

RMA:=EMA(CLOSE,SHORT),COLORLIGRAY;

NMA:=EMA(CLOSE,LONG),COLORMAGENTA;

RISK:=IF(NMA>RMA,NMA,DRAWNULL),COLORGREEN;

DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1) AND L=LLV(L,Z) AND RMA<=NMA,L,H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1) AND H=HHV(H,Z) AND RMA>=NMA,H,0),COLORFF0088,LINETHICK2;

DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1) AND H=HHV(H,Z) AND RMA>=NMA,H,L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1) AND L=LLV(L,Z) AND RMA<=NMA,L,0),COLORCCDDBB,LINETHICK2;

重心线:=TDXDLL5(39,TDXDLL5(38,H,L,O),C,0);

RC1:=REF(C,1);

CS:=IF(C>=1,10000,100000);

C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}

C涨停5 :=1.05*RC1-49/CS;

C跌停10:=0.90*RC1+51/CS;

C跌停5 :=0.95*RC1+51/CS;

ST:=NAMELIKE('S') OR NAMELIKE('*S');

涨停1:= IF(ST, C>=C涨停5, C>=C涨停10);

跌停1:= IF(ST, C<=C跌停5, C<=C跌停10);

大阳线:=C>O AND O<=REF(C+0.01,1) AND C/REF(C,1)<1.098 AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);

大阴线:=C<O AND C/REF(C,1)>0.902 AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);

STICKLINE(大阳线,H,L,0,1),COLORFF88FF;

STICKLINE(大阳线,CLOSE,OPEN,3,0) ,COLORFF88FF;

STICKLINE(大阳线,CLOSE,OPEN,2.5,0) ,COLORFF99FF;

STICKLINE(大阳线,CLOSE,OPEN,2,0) ,COLORFFAAFF;

STICKLINE(大阳线,CLOSE,OPEN,1.5,0) ,COLORFFBBFF;

STICKLINE(大阳线,CLOSE,OPEN,1,0) ,COLORFFCCFF;

STICKLINE(大阳线,CLOSE,OPEN,0.5,0) ,COLORFFDDFF;

STICKLINE(大阴线,CLOSE ,OPEN,3,0 ),COLORFF9900;

STICKLINE(大阴线,CLOSE ,OPEN,2.5,0 ),COLORFFBB00;

STICKLINE(大阴线,CLOSE ,OPEN,2,0 ),COLORFFCC00;

STICKLINE(大阴线,CLOSE ,OPEN,1.5,0 ),COLORFFDD00;

STICKLINE(大阴线,CLOSE ,OPEN,1,0 ),COLORFFEE00;

STICKLINE(大阴线,CLOSE ,OPEN,0.5,0 ),COLORFFFF00;

 

空大阳:=C>O AND O>=REF(C+0.01,1) AND C/REF(C,1)<1.098 AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);

STICKLINE(空大阳,C,(O+C)/2,3,0),COLORFF88FF;

STICKLINE(空大阳,C,(O+C)/2,2.5,0),COLORFF99FF;

STICKLINE(空大阳,C,(O+C)/2,2,0) ,COLORFFAAFF;

STICKLINE(空大阳,C,(O+C)/2,1.5,0),COLORFFBBFF;

STICKLINE(空大阳,C,(O+C)/2,1,0) ,COLORFFCCFF;

STICKLINE(空大阳,C,(O+C)/2,0.5,0),COLORFFDDFF;

盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);

盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);

STICKLINE(盘中涨停,H,MAX(C,O),0.01,0),COLORGREEN;{涨停后回落}

STICKLINE(盘中跌停,L,MIN(C,O),0.001,0),COLORRED;{跌停后回升}

DRAWTEXT_FIX(C>0,0,0.0,0,STRCAT('所属地区:',DYBLOCK)),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.205,0.0,0,STRCAT('主题投资:',GNBLOCK)),COLORF880F8;

 
通达信龙趋势指标公式 主图 源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 增值电信业务经营ICP许可证:湘B2-20210269 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识